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Getting Started

About Xcelsius 2008
Xcelsius 2008 is a data visualization software that enables users to create
dynamic and interactive models that can be added to dashboards or exported
for delivery in a variety of formats.

The software includes a fully-functioning Excel spreadsheet. Data and
formulas can be imported or entered directly into the embedded spreadsheet
and then modified, as required, without reimporting the spreadsheet.

To design a visual model of your data, you simply place components onto
the canvas and link them to the data in the spreadsheet. Xcelsius 2008
includes a wide range of components, such as dials, gauges, charts, maps,
picklists, sliders. You can configure these components to display data directly
from the spreadsheet, to write data to the spreadsheet so it can be used by
other components, or to accept data entered by users when the model is
running.

Xcelsius models can be exported into a variety of formats, such as
PowerPoint, Flash, PDF, AIR, Outlook, and the web (using HTML). These
models retain their full interactivity and require only Adobe Flash Player to
run. The Xcelsius designer and Microsoft Excel are required only during the
design phase.

Depending on your Xcelsius 2008 edition, you can configure your model to
work with live data updates from external sources, such as XML, Portals,
Web Services, SAP BusinessObjects Enterprise (LiveOffice and Query as
a Web Service), and SAP Business Explorer Queries.

Xcelsius 2008 editions

Xcelsius 2008 is available in several editions to address different needs. All
editions have the same basic functionality. The primary difference between
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editions are the formats that models can be exported to and the ability to
access and configure external data connections.

Xcelsius 2008 is available in the following four editions:
• Xcelsius Present enables users to create models with Microsoft Excel

data.
• Xcelsius Engage enables users to create models and connect them to a

single external data sources.
• Xcelsius Engage Server enables users to create models,connect them

to multiple external data sources, and deploy them in a portal environment.
• Xcelsius Enterprise enables users to create models and deploy them in

a BusinessObjects Enterprise or SAP NetWeaver BW environment.

The following table summarizes the features available in each edition of
Xcelsius:

Enter
prise

Serv
er

En
gagePresentFeature

XXXX
Export to Microsoft Excel, PDF, Mi-
crosoft Word, Acrobat 9, Microsoft
PowerPoint

XXXExport to Flash (SWF), Adobe AIR,
HTML, Microsoft Outlook

XXXX
Numerous components including
charts, selectors, single value, maps,
text

XXX

Additional components; Play Button,
Play Selection, Source Data, Accord-
ing Menu, Interactive Calendar,
Panel set, History, Trend Analyzer

XXXXURL Button

XXX
Web Connectivity options including
Slideshow and Connection Refresh
button
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Enter
prise

Serv
er

En
gagePresentFeature

XXXConnect to external data sources

XXXData Connection Manager

XXX

Supports external data connections
to Web Services, XML Data, Flash
Variables, Excel XML Maps, FS
Commands, Crystal Reports Data
Consumer, External Interface

XX
Supports external data connections
to web portals and reporting ser-
vices.

X

Supports external data connections
with the BusinessObjects platform,
including Query as a Web Service
(QaaWS), Live Office, and Busines-
sObjects Enterprise

XSupports Flynet Web Services Gen-
erator

X
Supports external data connections
to SAP Business Explorer (BEx)
Queries

File formats

Xcelsius 2008 models conform to SWF file format. SWF is the vector-based
graphics format designed to run in the Adobe Flash Player. Because a SWF
file is vector-based, its graphics are scalable and play back smoothly on any
screen size and across multiple platforms. Also, a vector-based file usually
has a smaller file size than other animations.
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Xcelsius 2008 files are stored in a zipped format with an XLF extension. The
XLF file format contains the Xcelsius 2008 model information and its
associated embedded spreadsheet file.

Note:
Xcelsius 2008 requires Adobe Flash version 9 or later. Newer Flash versions
have security features that may prevent models from connecting to an
external data source when running them outside the Xcelsius designer.

Related Topics
• Adobe Flash Player Security Restrictions

About Xcelsius 2008 Documentation
The Xcelsius documentation includes procedures for creating models
including, adding and configuring components, linking components to data,
configuring external data sources, and exporting models to different formats.
Use the documentation as a reference for creating basic and advanced
models.

Locate Information Quickly
• Access online help from the Xcelsius Help menu.

Use the Contents tab to view all major sections in the online help and drill
down to specific headings within each section, the Index tab to view topics
in alphabetical order, and the Search tab to enter a keyword to view all
the sections that relate to the keyword.

• Access a PDF version of the SAP BusinessObjects Xcelsius 2008
documentation on the SAP Help Portal at http://help.sap.com.

Sample models
As you are learning how Xcelsius works and what it can do, it can be helpful
to examine sample models as they are during runtime, as well as their
underlying configuration and formatting.

Xcelsius 2008 includes several sample models that illustrate how some of
the components and functions work. Each sample includes its own embedded
spreadsheet data, so you can see how the components are bound to the
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data in the spreadsheet. Use these samples to help you understand how to
configure similar functions in your own model, or even use them as a starting
point and customize them for your own needs.

Note:
Opening a sample file overwrites any data currently in the embedded
spreadsheet.

To view the sample models

1. Click File > Samples.
The "Samples" dialog box opens.

2. In the Category list, click User Guide Samples.
A list of the available samples opens in the Items list.

3. In the Items list, click a sample.
An illustration of the model displays in the "Preview" pane.

4. Click OK.
The sample file opens.

5. To view the model as a user would see it, click Preview.

Importing files created in Crystal Xcelsius
4.5

If you have models (XLF files) created in Crystal Xcelsius 4.5, you can import
them into Xcelsius 2008 and take advantage of the new features in Xcelsius
2008.

You cannot import files created in Xcelsius 3.0, 3.5, and 4.0. To use these
files in Xcelsius 2008, you must first import them into Crystal Xcelsius 4.5
and then import the files into Xcelsius 2008.

Xcelsius 2008 minimizes the impact of migrating models from Crystal Xcelsius
4.5. However, some models or components may appear to be different than
they were in the original file.

The following differences are the most common:
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• Component size. In most cases, the size difference is a few pixels.
• Custom colors may appear to slightly different.
• The Spreadsheet Table component size and formatting.

In addition, if the XLF file you are importing contains an external data
connector (XMLData Button, XMLMapRefresh,WebService Connector,
Live Office, FS Command, orQaaWS), the following actions occur for each
connector or button:
• A connection is created in the "Data Manager" with the previous Refresh

Options and Load Status settings.
• A Connection Refresh Button is added to the canvas and the Trigger

Behavior settings are mapped to it.

In addition, for Web Service and QaaWS connections, refresh options, and
trigger behaviors are mapped as described in the following table:

Setting in Xcelsius 2008Option in Xcelsius 4.5

In the Data Manager, the connec-
tion name for migrated connec-
tions is set as follows:
• For Web Services: SOAP
• For QaaWS: QAAWS

Name

• For versions prior to Xcelsius
2008 SP3, Refresh on Load
is selected on the Usage tab
in the "Data Manager" for the
connection.

• For Xcelsius 2008 SP3 and
later,RefreshBeforeCompo-
nents are Loaded is selected
on the Usage tab in the "Data
Manager" for the connection.

Refresh on Load

Refresh Every is selected on the
Usage tab in the "Data Manager"
for the connection.

Refresh on Interval

12

Getting Started



Setting in Xcelsius 2008Option in Xcelsius 4.5

In the "Properties" panel for the
Connection Refresh Button,
the value in Trigger Cell maps
to Trigger Cell on the Behavior
view, andWhen Value Changes
is selected.

Trigger on Change Only

In the "Properties" panel for the
Connection Refresh Button,
the value in Trigger Cell maps
to Trigger Cell on the Behavior
view, andWhen Value Changes
is selected. At run-time, when a
new value is inserted into the
trigger cell, the data refreshes.

Trigger On Any Insert

To import XLF files created in Xcelsius 4.5

Caution:
Backup your current XLF, JPEG, and external SWF files before upgrading
your model.

1. Click File > Open.
2. Navigate to the file you want to import and click Open.

Xcelsius detects that the file is from the previous version of Xcelsius and
a warning dialog box opens.

Caution:
After you import and save your model with Xcelsius 2008, the model
cannot be opened using an earlier version of Xcelsius.

The model opens on the canvas. Some components in the model may look
slightly different from the original file.
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If the components appear to be formatted differently, select the component
and open the "Properties" panel. Re-bind any properties that are tied to the
cells in the spreadsheet.
Related Topics
• Importing files created in Crystal Xcelsius 4.5
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Working in Xcelsius 2008

Understanding the Xcelsius workspace
Before you begin using Xcelsius, take a moment to familiarize yourself with
the interface. The Xcelsius workspace includes a canvas, an embedded
spreadsheet, Component and Object browsers, a Properties panel, a menu
bar, and multiple toolbars. You can show or hide thee items as required.

Xcelsius toolbars and buttons

Xcelsius includes four toolbars that you can use when working with models:
Standard, Theme, Export, and Format.

To show or hide toolbars
• To toggle between showing and hiding a toolbar, click View > Toolbars

and click the toolbar name.

A checkmark beside a toolbar name indicates that the toolbar is currently
showing.

Standard toolbar

The standard toolbar contains buttons for completing general tasks in
Xcelsius. The following table describes the available buttons:
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DescriptionButton

New Document icon.

Open File icon.

Save icon.

Print icon

Cut icon

Copy icon

Past icon

Undo icon

Redo icon

Selection Tool icon

Component Tool icon

Import Spreadsheet icon

Manage Connections icon

Increase Canvas icon

Decrease Canvas icon

Fit Canvas to Components
icon

Fit Canvas to Window icon

Preview icon

Themes toolbar

The Themes toolbar contains the following buttons for working with themes:
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DescriptionButton

Change Theme icon

Change Color Scheme icon

Export toolbar

The Export toolbar contains the following buttons for exporting your model
to specific formats:

DescriptionButton

Export to PowerPoint icon

Export to Microsoft Word icon

Export to Microsoft Outlook icon

Export to Adobe PDF icon

Export to Xcelsius BusinessOb-
jects platform icon

Format toolbar

The Format toolbar contains the following buttons for adjusting components
on the canvas:

DescriptionButton

Group Components icon

Ungroup Components icon

Align Left icon

Center Horizontally icon

Align Right icon
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DescriptionButton

Align Top icon

Center Vertically icon

Space Evenly Across icon

Space Evenly Down icon

Make Same Width icon

Make Same Height icon

Make Same Size icon

Bring to Front icon

Send to Back icon

Bring Forward icon

Send Backward icon

Setting document properties

The document properties allow you to customize the canvas size, specify
how fonts are used, and enter a description for the file. If you save the file
as a template, these settings apply to all models created from that template.

You can also enter a brief description of your model, the author, the date,
and its intended functionality. When other designers use your XLF file or
when you save your model as a template, this information is available.
Related Topics
• To set the canvas size
• To set global font options
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To set global font options

By default, you can specify different fonts for different components. These
fonts are based on device fonts (the fonts available on your machine) and
are not embedded in the SWF file. If, when the model runs, the specified
fonts are not available, another similar font is substituted for the missing font
and the model may appear different than when it was created.

You can set up a global font so the same font is used for all components.
The global font can be based on device fonts or on embedded fonts. When
device fonts are used, the SWF is smaller, but the text cannot be rotated
and does not use anti-aliasing. When fonts are embedded, you can rotate
text and the text uses anti-aliasing, but the SWF file size is larger and the
model takes longer to load.

1. Click File > Document Properties.
The "Document Properties" dialog box opens.

2. On the "Document Properties" dialog box, select Global Font.
The options for setting up global fonts are enabled.

3. From the list, select the font you want to use for all components.
4. Select one of the following options:
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DescriptionOption

Fonts are not embedded in the SWF file. Device fonts
use the SWF player to render the specified TrueType
fonts. If a specified font is not available at the time
the model runs, another similar font is used. By de-
fault, Xcelsius 2008 uses device fonts.

Tip:
If a model requires the extended character set de-
fined by Unicode, it is recommended that you use
device fonts.

UseDevice
Fonts

Fonts used in models will always be available when
the model runs, text can be rotated, and anti-aliasing
is used.

Note:
Embedding the fonts will increase the file size and
the amount of time required to load the model.

To change the text characters that are embedded in the
SWF file, clickAdvanced, select the characters you want
to embed, and click OK.

Restriction:
Asian characters sets cannot be embedded.

UseEmbed-
ded Fonts

5. Click OK.

Using the Components Browser

The "Components" Browser lists all the components that are available to
add to your model. From this list you can drag components onto the canvas.

You can view the list of components grouped into functional categories
("Category" or "Tree" view) or as an alphabetical list ("List" view). Components
are grouped into the following functional areas:
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DescriptionCategory

A list of components you added to this list.

Note:
Favorites is available only in "Category" and "Tree"
views.

• To add components to the favorites list, in "Category"
or "Tree" view, right-click the component and select
Add to Favorites

• To remove components from the favorites list, in the
favorites list, right-click the component and select
Remove From Favorites.

Favorites

Chart components allow you to create visual represen-
tations of data to make it easy for users to see compar-
isons, patterns, and trends.

Charts

Container components group and display other compo-
nents.

Note:
Container components are not available in Xcelsius
Present.

Containers

Selector components allow users to choose options
when running the model. They allow you to create inter-
active, dynamic models

Selectors

Single-value components can be linked to a single cell
in the spreadsheet and can either allow users to change
the value in that cell or display the product of a formula
from that cell.

Single-Value

Map components provide geographical representations
that allow you to display data by region.

Maps

Text components can be used to add labels to your
model or to allow users to enter text when the model
runs.

Text
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DescriptionCategory

The Other category includes various components that
can enhance your model, such as calendars, trend
icons, panel sets, and print buttons.

Other

Art & Background components allow you to enhance
models by adding images and backgrounds.

Art & Back-
grounds

Web connectivity components allow you to link your
models to the Internet.

Web Con-
nectivity

Category view

In "Category" view, the components are grouped in a sliding accordion menu.
To navigate to the components, click a category title or scroll down to open
each category in sequence. Each category displays a visual representation
of the components.
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Tree view

In "Tree" view, the components are organized in folders according to their
category. To navigate to components, click the folders to expand the
categories and see the list of available components.
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List view

In "List" view, all components are organized alphabetically and are not
grouped by functionality.

To navigate to components in this view, click anywhere within the window,
and type the first letter of the component or scroll up or down to find the
desired component.

24

Working in Xcelsius 2008



Using the Canvas

The canvas area is the main work area where you place and manipulate
components to create models.

You can change the color of the canvas background and add a grid to help
you arrange items on the canvas. You can also adjust the size of the canvas
to give you more space to work or to reduce the overall size of a saved model.

To set the canvas background

By default, the canvas has a transparent background. This setting can be
used in conjunction with the WMODE parameters in HTML to create a
transparent background for your Flash movie. If you do not want a transparent
background, you can add a background to your model.

1. Open or create a model.
2. If the "Properties" panel is not open, click the canvas and then clickView

> Properties.
3. On the "Canvas Properties" panel, set the following options:
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DescriptionOption

Select one of the following types of background:

DescriptionOption

A single solid colorSolid

Two colors that fade to-
gether from top to bot-
tom

Gradient

A JPG or SWF file. Se-
lect the file to import as
the background

Image

A transparent back-
groundNone

Type

If you selected the Solid or Gradient type, click the
Background Color box to set the colors to use in
the background. For Solid backgrounds, select a
single color. For gradient backgrounds, in Back-
ground Color 1, select the color to use at the top of
the model and in Background Color 2, select the
color to use at the bottom.

Back-
ground
Color

If you selected the Image type, click Import to select
the image file to use.

Import

To display a grid on the canvas

When you are arranging components on the canvas, it can be helpful to line
items up along grid lines. You can use the grid manually to position each
component or you can have components snap to the closest gridlines
automatically when they are placed on the canvas.

26

Working in Xcelsius 2008



1. Click File > Preferences.
The "Preferences" dialog box opens.

2. On the left side of the dialog box, click Grid.
3. In the "Grid" area, set the following options:

DescriptionOption

Select to display a grid on the canvas.Show Grid

Select to have components automatically align to
the nearest gridlines.

Snap to Grid

Specify the spacing between grid columns in pixels.Width

Specify the spacing between grid rows in pixels.Height

4. Click OK.

Tip:
To reset all grid options to their default setting, click Restore Defaults

Changing the canvas size

You can change the size of your work area by changing the canvas size.
Xcelsius provides three options for changing the canvas size: set a specific
size in pixels, fit to components, and fit to window. When you are working
on a model, you might want to expand the canvas size as much as possible
to allow for more room to add and arrange the various components. When
your model is complete, you might want to reduce the canvas size around
the components before publishing the model to reduce the overall size of
the file.

Note:
When you export your model, Xcelsius embeds the entire canvas. The canvas
size might affect your ability to size and position your embedded model, as
well as the time required to load the model.
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To set the canvas size
If you want to set a specific size for the canvas, adjust the document
properties.

1. Click File > Document Properties .
The "Document Properties" dialog box opens.

2. On the "Document Properties" dialog box, in the "Canvas Size in Pixels"
area, do one of the following:
• Select Preset Size then, from the list, select one of the available sizes.
• Select Custom Size then, in the Width box, enter the desired canvas

width in pixels and in the Height box, enter the desired canvas height
in pixels.

3. Click OK.

To fit the canvas to the components
Your model is open in Xcelsius.

After you complete your model, you can adjust its final size by eliminating
the surrounding canvas area. You can fit the canvas tightly around all the
components and then fine-tune the size by increasing or decreasing the
canvas size in small increments.

1. Click View > Canvas Sizing > Fit Canvas to Components.
The canvas size is reduced to the minimum size around the components.

2. Adjust the canvas size, as required.
• From the View menu, click Canvas Sizing > Increase Canvas.
• From the View menu, click Canvas Sizing > Decrease Canvas.

Note:
You can also use the toolbar buttons (Fit Canvas To Components),

(Increase Canvas), and (Decrease Canvas) to adjust the canvas
size.

To fit the canvas to the window
If you want to increase the size of your work area, you can expand the size
of the canvas to fit the window.

1. Click View > Canvas Sizing > Fit Canvas to Window.
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The canvas size is expanded to the maximum size available in the window.

2. Adjust the canvas size, as required.
• From the View menu, click Canvas Sizing > Increase Canvas.
• From the View menu, click Canvas Sizing > Decrease Canvas.

Note:
You can also use the toolbar buttons (Fit Canvas To Window),
(Increase Canvas), and (Decrease Canvas) to adjust the canvas size.

Arranging components on the canvas

Xcelsius offers several options for aligning and positioning components
relative to the page or to other components. You can also move components
between different layers on the canvas while you are working or to allow
components to overlap.

If you have numerous components on the canvas, you can group them and
work with those components as though they were a single item.

To place components on the canvas
There are two way that you can place components on the canvas:
• From the "Components" browser, drag the component and drop it on the

canvas where you want it to be.

The component is placed on the canvas.

• In the "Components" browser, click the component and then click the
canvas where you want to place the component.

The component is placed on the canvas.

Note:
If you set a grid on the canvas and have selected the Snap to Grid option,
components are automatically aligned with the nearest grid lines when you
place them on the canvas.

Related Topics
• To display a grid on the canvas
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To align multiple components
You can align the edges or centers of components or groups of components
relative to the first component in the selection.

1. Select a component.
2. Hold the CTRL key and select the components you want to align with the

first component.
3. Click Format > Align and then click one of the following options:

DescriptionOption

Aligns the left edge of the selected components with
the left edge of the component that was selected
first.

Left

Aligns the center of the selected components verti-
cally with the center of the component that was se-
lected first.

Center

Aligns the right edge of the selected components
with the right edge of the component that was select-
ed first.

Right

Aligns the top edge of the selected components with
the top edge of the component that was selected
first.

Top

Aligns the center of the selected components hori-
zontally with the center of the component that was
selected first.

Middle

Aligns the bottom edge of the selected components
with the bottom edge of the component that was se-
lected first.

Bottom

The selected components are aligned according to your selection.

To center components on the canvas
You can center components or groups of components on the canvas
horizontally, vertically, or both.
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1. Select a component or multiple components.

Tip:
To select multiple components, hold the CTRL key and click each
component.

2. Click Format > Center in Canvas and then click one of the following
options:

DescriptionOption

Centers the selected components between the top
and bottom margins of the canvas.

Vertically

Centers the selected components between the left
and right margins of the canvas.

Horizontal-
ly

Centers the selected components both between the
top and bottom margins and the left and right margins
of the canvas.

Both

The selected components are centered on the canvas according to your
selection.

To space components evenly on the canvas
At least two components have been placed on the canvas.

You can distribute multiple components on the canvas to have the same
amount of space between their center points either vertically (down) or
horizontally (across).

Note:
The Space Evenly option adjusts the space between the center points of
components, not between their edges.

1. Select the components you want to space evenly on the canvas.

Tip:
To select multiple components, hold the CTRL key and click each
component.

2. Click Format > Space Evenly and then click one of the following options:
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DescriptionOption

Adjusts the component positions so there is an
equal amount of horizontal space between their
center points.

Across

Adjusts the component positions so there is an
equal amount of vertical space between their
center points.

Down

The space between the selected components is adjusted according to your
selection.

To group and ungroup components
Multiple components have been placed on the canvas.

When you are working on a complex model with multiple components, you
may want to group some components together so they are not accidentally
separated as you design the layout. Grouped components act as a single
item and retain their relative positions when moved.

Note:
Components can also be grouped and ungrouped through the Object
Browser. For more information, see Using the Object Browser.

1. Select the components you want to group or ungroup.
2. Do one of the following:

• Click Format > Group.
• Click Format > Ungroup.

The selected components are either grouped so a single set of boundary
markers surround all the grouped components and the group can be moved
as a single item, or ungrouped so each component has boundary markers
around itself and can be moved independently of the other components.

To move components between design layers
Multiple components have been placed on the canvas.

On the canvas, components and grouped components are in layers.
Components on a front layer cover or overlap any components that are on
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the layers behind. When you are designing your model, you may want to
move components from back to front so you can focus on each one.

Note:
You can also move components between layers from the Object Browser.
For more information, see Using the Object Browser.

1. Select a component.
2. Click Format > Order and then click one of the following options:

DescriptionOption

Moves the selected components to the top layer.Bring to
Front

Moves the selected components one layer closer to
the top from its current position.

Bring For-
ward

Moves the selected components one layer closer to
the bottom layer from its current position.

SendBack-
ward

Moves the selected components to the bottom layer.Send to
Back

The selected components are moved to a layer according to your selection.

To copy size settings to other components
Multiple components have been placed on the canvas.

To quickly adjust the size of multiple components, you can copy the height
and width settings of one component to other components on the canvas.

1. Select a component.
2. Hold the CTRL key and select the components you want to make the

same size as the first component.
3. Click Format > Make Same Size and then click one of the following

options:
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DescriptionOption

Sets the width of each selected components to the
width of the first component.

width

Sets the height of each selected components to the
height of the first component.

height

Sets both the height and the width of each selected
components to the height and width of the first com-
ponent.

Both

The size of the selected components is adjusted according to your selection.

Using the Object Browser

The Object Browser provides a list of the components that are currently part
of your model. You can use the Objects Browser to select and manipulate
these components, as well as to lock or hide them on the canvas.

Selecting components

To select a component in the Object Browser, click the component name or
icon to make it the active component on the canvas.

To select multiple components, click a component name or icon, and then
hold down the CTRL key while you click additional components. To select
a range of components, hold down the SHIFT key while selecting the range
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in the Object Browser, or click the canvas and drag the cursor over a group
of components.

Combine methods by selecting a group of components first with SHIFT+click
and then other separate components usingCTRL+click. Always select using
SHIFT+click first; this method will not work in reverse.

Select all components by selecting any component, then pressing CTRL+A.

Note:
On the canvas, you cannot select components that are marked as hidden
or locked. You can select those components only in the Object Browser.

Hiding components

When you are designing a model, you may have many components on the
canvas and it can be helpful to move some out of the way while you focus
on others. However, it would be inconvenient to delete them or move them
to the side. In the Object Browser, you can temporarily hide components on
the canvas. Hidden components are still part of the model and retain all their
formatting, but they are not visible in design mode.

Note:
If you preview or export the model, the SWF includes hidden components.

To hide or show components on the canvas, in the Object Browser, do any
of the following:
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Do thisTo

Beside the component, click the dot in the column
under the Hide icon ( ).

Hide a component

Beside the group, click the dot in the column
under the Hide icon ( ).

Hide a group

In the toolbar, click the Hide icon ( ).Hide all compo-
nents

Beside the hidden item, click the check mark in
the column under the Hide icon ( ).

Show a hidden
component or
group

If all items are hidden, in the toolbar, click the
Hide icon ( ).

OR

If some items are hidden, in the toolbar, click the Hide
icon to hide all components and then click it again to
show all components.

Show all hidden
components and
groups

Opening properties panels

In the "Object " browser , you can open the "Properties" panel for components
or groups in one of the following ways:
• Double-click the icon or label for the component.

Note:
Double-clicking a group icon or label expands or collapses the group
within the tree.

• Select the component or group and press ALT + ENTER

• Right-click the component or group and click Properties.
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Note:
Once the "Properties" panel is open for one component you can navigate to
the "Properties" panel of another component or group by clicking the item in
the "Object Browser ".

To rename components

When you place a component on the canvas, it is automatically assigned a
name. This name appears in the title bar of the "Properties" panel and in the
"Object Browser". You can rename components as required.

1. In the "Object Browser", click the component you want to rename.
2. Click the name of the component.

The name is highlighted and the cursor is in the name text box.

3. Type a name for the component and press Enter.

Grouping components

Objects in the Object Browser can be grouped in the following ways:

• Select several components, then right-click on any of the components
and select Group from the context menu.

• Select several components, then click the toolbar.

Once grouped, the components will appear in the browser in tree form with
a folder representing the group. Expand the group folder by clicking the +
button or double-clicking the folder icon or the group label. Components can
be dragged into and out of the group by dragging them to a different location
in the browser tree.

To ungroup selected components, click the toolbar or right-click the group
to access the context menu, then select Ungroup.

Locking Components

Components and groups can be locked on the canvas to prevent any
interaction with them. This can be helpful when there are many components
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laid out on the canvas. The component or group will be selectable only in
the "Object" browser.

To lock or unlock components on the canvas, in the "Object" browser, do
any of the following:

Do thisTo

Beside the component, click the dot in the column
under the Lock icon ( ).

Lock a compo-
nent

Beside the group, click the dot in the column under
the Lock icon ( ).

Lock a group

In the Object Browser toolbar, click the Lock icon
( ).

Lock all compo-
nents

Beside the locked item, click the check mark in the
column under the Lock icon ( ).

Unlock a com-
ponent or group

If all items are locked, in the Object Browser toolbar,
click the Lock icon ( ).

OR

If some items are locked, in the Object Browser toolbar,
click the Lock icon ( to lock all components and then
click it again to unlock all components.

Unlock all com-
ponents and
groups

Moving Components Forward/Back

Click and drag a component in the browser to change the image layer it
appears in. Moving a component higher in the list moves the component to
a higher layer; moving the component down places it in a lower layer.

Component layers can also be changed by right-clicking the component
name in the "Object" browser and selecting one of the following options:
• Bring to Front
• Send to Back
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• Bring Forward
• Send Back

Using the context menu

Display a context menu by right-clicking any component in the browser or
on the canvas.

The context menu provides access to many of the functions that are available
in the "Object" browser.

Customizing Xcelsius with add-ons
A variety of model components and feature extensions are available for
Xcelsius. These items (called add-ons) have been created by
BusinessObjects partners and customers and are available for sale or free
from Information OnDemand . You can download charts, maps, and other
model and feature extensions and use them to customize your Xcelsius
models.

To download add-ons

Before you can install an add-on, you must download it to your system.

1. Click File > Manage Add-ons.
The "Xcelsius Manage Add-ons" dialog box opens.

2. Click Get More Add-ons and, in the security dialog box, click OK.
The "Information OnDemand" website opens to the "Xcelsius Add-on
Marketplace" page.

3. Under "Find an Add-on", clickVisit theMarketplace to ViewAll Add-ons.
The Information OnDemand website lists the available add-ons. Click the
one you want to download.

4. Click Check Out.
The "Sign In" dialog box opens.
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5. On the "Sign In" dialog box, do one of the following:
• Enter your sign-in information and click Sign In.
• To register, click Create New Account and follow the instructions.

6. Read the terms of the offering and select I agree to the Terms of Use
checkbox. Click Checkout and follow the online instructions to download
the file.

The add-on is available for installation.

If the add-on was in a zipped folder, extract the files, and then install the
downloaded add-on.

To install add-ons

The add-on has been downloaded to your system.

After you download an add-on, you must install it before you can use it.

1. Click File > Manage Add-ons.
The "Xcelsius Manage Add-ons" dialog box opens.

2. Click Install Add-on.
3. Navigate to the location where the add-in files were saved and extracted.

Select the XLF file and click Open.

The add-on is installed and available for use.

To remove add-ons

An add-on is installed.

1. Click File > Manage Add-ons.
The "Xcelsius Manage Add-ons" dialog box opens.

2. From the list on the left, select the add-on you want to remove. Click
Remove.
The "Confirm Add-on Removal" dialog box opens.

3. Click Remove.
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The add-on is removed from Xcelsius.
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Working with Components

Using the Properties panel
The "Properties" panel contains the setting and format options for the selected
component. After you place a component on the canvas area, you can access
the "Properties" panel is several different ways:
• Double-click the selected component
• Right-click the component and select Properties
• Press ALT+ENTER
• In the "Object" browser, right-click the component and select Properties
• In the "Object" browser, select the component and press ALT+ENTER

In general, the "Properties" panel has the same structure for all components,
but the options available are specific to each individual component.

The "Properties" panel may include the following views:
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Descriptionview

Use the General view to set the basic configuration
for components, such as titles, labels, and the location
of the source and destination data.

The Drill Down view is available for some charts. Use
this menu to configure charts to act as selectors, so
that clicking a chart element inserts more detailed in-
formation into the embedded spreadsheet so it can be
used by another component to create drill down behav-
ior. For information about configuring chart drill down
behavior, see Configuring drilldown behavior.

Use the Behavior view to set up how the component
will work within the model. For example, setting limits,
interactivity, and visibility.

Use the Appearance view to format the look of compo-
nents, including font size, title locations, legends, col-
ors, and so on.

Use the Alerts view to set up notifications regarding
the data. You can turn alerts on, set the number of
colors, and the target limits. For information about us-
ing alerts, see Understanding Alerts.

Setting properties for multiple components

By selecting multiple components on the canvas, you can simultaneously
edit properties for the selected components. To access properties for multiple
components select the components and double-click the selection. You can
also access the properties by right-clicking the selection and selecting
Properties from the context menu.
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If the components are of the same type, you can edit properties specific to
that component type. For example, if your current selection contains three
Line Chart components, you will be able to access the properties specific
to the Line Chart. Any change made to the properties will apply to all
components in the selection. The "Properties" panel selections with
components of mixed types or groups are limited to the Dynamic Visibility
parameters on the Behavior view. When a number of components are
grouped, the properties for individual components within that group may be
accessed by right-clicking that sub-group component in the "Object" Browser
. See Using the Object Browser for more information.

Setting colors for component elements

You can select specific colors for almost every element of every component
in Xcelsius. Colors are specified on the "Properties" panel for each component
on either the Appearance view or the Alerts view.

To set the color for an element, you click the Color Selector icon ( ) or the

Bound Color Selector icon ( ) beside the element name.

When you specify a color for an element, you can select from a number of
common color definitions, create your own definitions, or bind the color to a
cell in the embedded spreadsheet to allow the color to be dynamically set
during run-time.

To specify element colors

A component is placed on the canvas.

To set the color for a component element, you can select from a number of
predefined colors.

1. Select the component and open the "Properties" panel.
2. On the "Properties" panel, select the Appearance or Alerts view and

beside the element you want to define, click the Color Selector icon ( ).
The "Color" dialog box opens.
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3. To assign a predefined color, click a color from one of the following
sections:

DescriptionOption

These colors are in the currently assigned theme.ThemeCol-
ors

These are a selection of basic colors settings.Standard
Colors

These are colors that you have recently used for
another element.

Recent
Colors

Use this option to display a larger color wheel with
a greater selection of colors. When you select a color
on the wheel, it is displayed in the New block next
to the Current color so you can compare the differ-
ence. When you have selected the color you want.
Click OK.

More

The selected color is applied to the component element and the Color
Selector icon is updated to display the current color.

To create a custom color for elements

A component is placed on the canvas.

If you want to assign a specific color to component elements, you can specify
the RGB or HSL values to define the color precisely. Custom colors can then
be assigned to component elements in the same way predefined colors are
assigned.

1. Select the component and open the "Properties" panel.
2. On the "Properties" panel, select the Appearance or Alerts view and

beside the element you want to define, click the Color Selector icon ( ).
The "Color" dialog box opens.

3. On the "Color" dialog box, click More Colors.
4. Click the Custom tab.

46

Working with Components



5. In the Color Model list, select either RGB or HSL and then set the
applicable color setting levels, that is, for RGB, set the Red, Green, and
Blue levels and for HSL, set the Hue, Saturation, and Luminosity levels.
The resulting color is displayed in the New block next to the Current color
so you can see the difference.

6. To save and apply the custom color to the selected element, click OK.

The custom color setting is applied to the selected component element and

the Color Selector icon ( ) is updated to display the current color.

To dynamically set colors at run-time

A component is placed on the canvas.

If you want to configure a component or component element to change colors
at run-time based on user input or a setting for another component, you can
bind the color setting to a cell in the embedded spreadsheet.

When the color is bound to a spreadsheet cell, it uses whatever value is
entered in that cell to set the color. You can then configure the value in the
cell to be set by user input, another component, an external data source,
and so on.

Note:
Colors that are bound to a cell are not affected by changes to the color theme
applied to the model.

The following color formats are supported:
• HEX (For example, FFFFFF, #FFFFFF, 0xFFFFFF)
• RGB (For example, (255,255,255) )
• VGA Color names (For example, Aqua, Black, Blue, Fuchsia, Gray, Green,

Lime, Maroon, Navy, Olive, Purple, Red, Silver, Teal, White, Yellow.)
• Decimal Color Equivalent (For example, F00FF becomes 16711935)

Caution:
If the value in the specified cell is not a valid color setting or the cell is empty,
the component element color is set to Black.

1. Select the component and open the "Properties" panel.
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2. On the "Properties" panel, select the Appearance or Alerts view and,

beside the element you want to define, click the Color Selector or icon.
The "Color" dialog box opens.

3. On the "Color " dialog box, click Bind to a Color.
4. In the "Select a Range" dialog box, select the cell you want to bind the

color to. Click OK.

The element color is updated based on the value in the selected cell and the

Color Selector icon ( ) changes to a Bound Color Icon ( ) to indicate
that the setting is bound to a cell.

Using Xcelsius 2008 Components

Using Chart components

Charts allow you to represent data visually to make it easy for users to see
comparisons, patterns, and trends. Xcelsius includes the following types of
charts.

Area Chart

A standard chart with vertical and horizontal axes. Each point along the
horizontal axis represents a data point. The actual values for each data point
are plotted against the vertical axis. For each series, colored areas are
created by connecting the plotted points against the horizontal axis. Use this
chart in models that emphasize a trend line, such as Stock Prices or Revenue
History.
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Bar Chart and Column Chart

A single- or multi-bar chart that shows and compares one or more items over
a period of time or in a specific range of values. You could, for example, use
a column chart in models that contain the quarterly headcount by region.

Bubble Chart

The bubble chart is one of the most powerful analytic tools available. It lets
you compare a group or series of items based on three different parameters.
It has an X-axis and Y-axis to represent the item location over the chart area,
and a Z value to represent the item size.

You could, for example, use this chart to represent the market composition
with the X-axis representing the Return On Investment (ROI) by industry
type, the Y-axis representing the Cash Flow, and the Z-axis representing
the Market Value.
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Bullet charts

This chart component provides a method to display information in a
condensed, less-distracting format and is available with either a vertical or
horizontal orientation.

The Bullet chart components have a single primary measure (for example,
current year-to-date revenue) that is displayed as a vertical or horizontal bar.
A marker indicates a target or performance goal and changing color hues
behind the bar indicate qualitative ranges of performance (for example, poor,
satisfactory, and good).

Designers can configure the Bullet chart to display multiple series and can
configure the scale, axis, and ticks separately for each series. For example,
the chart can be configured to show revenue in thousands of dollars, profit
in dollars, and order size as a count.

Combination Chart

A combination column and line chart ideal for displaying a range of values
and a trend line for those values. You can use the combination chart in
models examining stocks. A line series might show the historical stock price
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over the year, and a column chart might show the volume of trading for that
stock.

Line Chart

A single- or multi-line chart is ideal for showing tendency over a period of
time. Use this chart in models that emphasize a trend or a continuing
sequence of data, such as Stock Prices or Revenue History.

OHLC Chart and Candlestick Chart

The open-high-low-close (OHLC) and candlestick charts are primarily used
to display stock data. Each marker corresponds to the values, which are
represented as lines attached to the marker on the OHLC chart and as colors
on the candlestick chart. The open value displays the opening price of the
stock. The high value displays the highest price the stock achieved on that
day. The low value displays the lowest price the of the stock on that day.
The close value displays the closing price of the stock.
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Pie Chart

A circular chart that represents the distribution or participation of each item
(represented by a slice) of a certain total that is represented as the overall
pie value. The pie chart is appropriate for models such as Revenue
Contribution by Product. In that example, the overall pie size would represent
the total revenue, and each slice would represent a different product.

Radar Chart and Filled Radar Chart

Radar charts have axes that radiate outwards from the center of the chart.
These charts can have several axes. They are useful for plotting
multi-dimensional sets of data. In the filled radar chart, the shape created
by connecting the points along each axis is filled in with color. You could use
the radar charts to compare aspects of stocks. One axis could display the
price, another the volume, another the Price to Earnings ratio, and any other
relevant data.
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Sparkline

The Sparkline chart is based on the Sparkline chart created by Edward Tufte.
It provides a method for displaying a one-dimensional series (or multiple
series) of numeric data in a way that is dense, takes up a small space, and
can be quickly interpreted.

Designers can set key data points (start value, end value, low value, and
high value) that are displayed as markers on the Sparkline chart. They can
also define a normal range that is displayed as a colored background behind
the chart.

Stacked Area Chart

This standard chart has vertical and horizontal axes. Each point along the
horizontal axis represents a data point. The actual values for the data points
are plotted against the vertical axis, with each series adding to the total value.
You could use the stacked area chart to compare the revenue for multiple
products as well as the combined revenue of all the products and the
contribution of each product to the combined revenue.
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Stacked Column Chart and Stacked Bar Chart

Stacked bars compare one or more variables, with each series adding to the
total value. This chart compares several variables over a period of time, for
example, Marketing Cost and Administrative Cost. Each one of the cost
components is presented in a different color and each bar represents a
different time period. The total bar size represents the Total Cost.

Tree Map

This chart displays hierarchical data in a small area. Each data point is
represented by a rectangle.The tree maps display two parameters,
represented by size and color intensity and can be used to compare two sets
of data.

For example, a tree map could be used to represent the size and interest
rate of loans. You can set the size of the rectangle as the loan amount; a
large loan would be represented by a larger rectangle. The color of the
rectangle would represent the interest rate; a higher interest rate would be
represented by a brighter color value.

Tip:
To see an example of a model with a Tree Map component, click File >
Samples and open the sample file Tree Map.
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XY Chart

This chart displays data that encompasses two dimensions. The XY chart
shows each data point as a result of the intersection of X values and Y values.
You can, for example, use the XY chart in models that compare ROI (on the
X axis) against Market Value (on the Y axis) for a group of companies.
Related Topics
• To set up a chart

To set up a chart

A list of values is entered in the embedded spreadsheet and a chart is placed
on the canvas.

1. Select the chart and open the "Properties" panel.
2. On the "Properties" panel, click the General view and enter the titles and

labels for the chart elements, then link the chart to the data in the
spreadsheet. For more information about the available options, see Chart
General properties.
The chart is updated with the changes.

3. If applicable, click the Drilldown view and set the required options. For
more information about the available options, see Chart Drilldown
properties.
The drilldown feature allows you to set up a chart to act as a selector to
display more detailed information. For example, you could set up a pie
chart to show the annual sales in different regions and when the user
clicks a pie section, another chart displays the monthly sales for that
region.
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4. Click the Behavior view and set the options for how the component
functions in the model including handling variable amounts of data, scaling,
and animations. For more information about the available options, see
Chart Behavior properties.

5. Click the Appearance view and set the visual characteristics for each
chart element and, if desired, add a legend. For more information about
the appearance options, see Chart appearance properties.

6. If applicable, click the Alerts view to set up notifications of when specified
values have been reached. For more information about alerts, see
Understanding Alerts.

7. Click File > Save and enter a location and filename for the model. Click
OK.

The chart is added to the model and configured. To see how the model will
look at run-time, on the Toolbar, click Preview.
Related Topics
• Using the Properties panel

Chart General properties

Use the following table as a guide for setting the Chart component properties
on the General view. Note that some options are available only for specific
chart types.

DescriptionOption

"Titles"

All

The main title for the chart. By default, it is centered at the
top of the chart.

Chart

All

A secondary title for the chart. By default, the subtitle is
centered at the top of the chart below the chart title.

Subtitle
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DescriptionOption

Line, Pie, OHLC, Candlestick, Column, Stacked Col-
umn, Combination, Area, Stacked Area

The label for the data categories displayed along the X axis.

Category
(x) Axis

Bar, Stacked Bar, Bubble, XY

The label for the data categories displayed along the Y axis.
Category
(Y) Axis

Horizontal Bullet Chart

The label for the data along the X axis.
Horizontal
(X) Axis

Vertical Bullet Chart

The label for the data along the Y axis.
Vertical (Y)
Axis

Line, Pie, OHLC, Candlestick, Column, Stacked Col-
umn, Combination, Area, Stacked Area

The label for the values displayed along the Y axis.

Value (Y)
Axis

Bar, Stacked Bar, Bubble, XY

The label for the values displayed along the X axis.
Value (X)
Axis

Line, Column, Combination, Area

The label for the secondary Y axis displayed on the right
of the chart.

Note:
This option is available only if By Series is selected
and Plot Series On is set to Secondary Axis.

Secondary
Value (Y)
Axis
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DescriptionOption

Bar

The label for the secondary X axis displayed at the top of
the chart.

Note:
This option is available only if By Series is selected
and Plot Series On is set to Secondary Axis.

Secondary
Value (X)
Axis

"Data"

All except Pie

Select this option to display a range of values for a single
series.

Select one of the following options:
• If the data series is from the columns of the worksheet,

select Data in Columns.
• If the data series is from the of rows the worksheet, se-

lect Data in Rows.

By Range
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DescriptionOption

Line, Column, Stacked Column, Bar, Stacked Bar,
Bubble, XY, Stacked Area, Radar, Filled Radar

Select this option to display multiple series of values.

To add a series to the chart, click the Plus icon ( ).

Then, select each series and set the following options:

DescriptionOption

The name for the series.Name

The X or Y data points from the
spreadsheet.Values

The axis you want to plot the series
on.Plot Series On

The label displayed on the X axis
to identify each category in the se-
ries.

Category Labels

By Series

By Series
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DescriptionOption

OHLC, Candlestick

Select this option to display multiple series of values.

Set the following options:

DescriptionOption

The name of the series. For reference
only.

Series
Name

The range for the opening value.Open

The range for the high value.High

The range for the low value.Low

The range for the closing valueClose

The label displayed on the X axis to
identify each category in the series.

Category
Label

Tree

Select this option to display multiple series of values.

To add a series to the chart, click the Plus icon ( ).

Then, select each series and set the following options:

DescriptionOption

The name of the series. For refer-
ence only.Display Labels

The range of values represented
by the size of squares on the chart.Values (size)

The range of values represented
by the color intensity on the chart.

Values (color in-
tensity)

By Series
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DescriptionOption

By Series

Horizontal and Vertical Bullet

Select this option to display multiple series of values.

To add a series to the chart, click the Plus icon ( ).

Then, select each series and set the following options:

DescriptionOption

The name of the series. For refer-
ence only.Label

A secondary label for the series
that appears below the series label.Sublabel

The range of values that represent
actual performance.

Performance
Value

The range of values for the target
performance.

Comparative
Value

The range of values that define the
scale for performance, for example,
poor, fair, good.

Scale Value

Pie

The range of values represented by each color on the chart.

Select one of the following options:
• If the data series is from the columns of the worksheet,

select Data in Columns.
• If the data series is from the of rows the worksheet, se-

lect Data in Rows.

Values
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DescriptionOption

Pie

The labels displayed beside each color in the chart key,
Labels

Sparkline

The labels displayed beside each series in the chart.
Header La-
bels

Related Topics
• To set up a chart
• Chart Behavior properties
• Chart Drilldown properties
• Chart appearance properties

Chart Drilldown properties

Use the following table as a guide for setting the Drilldown properties for
charts that contain a series. Note that some options are available only for
specific chart types.

Note:
Drilldown options are not available for Area, Stacked Area, Vertical and
Horizontal Bullet, Sparkline, Radar, or Filled Radar charts.

DescriptionOption

All

Allows the chart to behave as a selector. This option
is available only to charts that contain a series. For
more information about setting up a series, see Chart
General properties.

Enable Drill-
down
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DescriptionOption

All except Pie charts

The cell in the embedded spreadsheet where the
currently selected series name will inserted. This op-
tion is used to identify the series of data that is insert-
ed.

Series Name
Destination

All

Select the structure of the data that will be inserted
into the embedded spreadsheet when a selection is
made.

Insertion Type

Line, Column, Stacked Column, Bar, Stacked
Bar, Combination , Pie

For each series the chart contains, select the series
and, then, set the Source Data, Value Set (when In-
sertion type is Value), and Destination values.

For Pie charts, the Series list is not available. Define
the Source Data and Destination values.

Series

All

Specifies how selections are made on the component.
Interaction Op-
tions

All

Specifies the item or series that will be selected when
the model is loaded.

Default Selec-
tion

Related Topics
• To set up a chart
• Chart General properties
• Chart Behavior properties
• Chart appearance properties
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Chart Behavior properties

Use the following table as a guide for setting the Behavior properties for
charts. Note that some options are only available for specific chart types.

DescriptionOption

Common Tab

All

Note:
The In Series option is not available for Pie,
Candlestick, OHLC, or Tree Map charts.

Specifies whether blank cells at the end of the data
are displayed on the chart or ignored.

Set any of the following options:
• In Series — The chart does not display empty se-

ries past the last non-empty series in a range.
• In Values — The chart does not display empty

values past the last non-empty value in a series.

For more information about using this option, see
Working with variable amounts of data.

Ignore Blank
Cells

Sparkline Chart components only.

Select this option to enable an area of color behind
the sparkline to indicated the range of normal values
for the given data.

Normal Range
Area

Sparkline Chart components only.

Select this option to set the normal range area based
on the variance of the data.

Auto
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DescriptionOption

Sparkline Chart components only.

Select this option to set the normal range area based
on specific low and high values. Enter the low and
high values or click the Cell Selector icon ( ) to
select a source data location for these values.

Manual

All except Pie, Tree Map, Horizontal and Vertical
Bullet charts.

Specifies whether users are able to adjust the chart
scale during runtime. If this option is selected, when
the model runs, a set of runtime tools are available
and allow users to adjust the chart scale. You can also
select which tools are available in the runtime tool set.
For more information about using this option, see Al-
lowing users to adjust chart scales

.

Enable Run
Time Tools

Line, Bar, Stacked bar, Column, Stacked column,
Candlestick, Combination, OHLC, Area, Stacked
Area charts

Adds a range slider to allow users to focus on a partic-
ular data set rather than viewing the entire chart at
once. Users can change the size of the range by ad-
justing control handles on either side of the range
slider. For more information about using this option,
see Adding Range Sliders to charts

.

Enable Range
Slider
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DescriptionOption

Line, Pie, Column, Stacked column, Bar, Stacked
bar, Combination, Area, Stacked area, Radar,
Filled Radar charts

Sorts the chart values according to specified data se-
ries or chart labels.

Select one of the following options:

DescriptionOption

Sort according to the data val-
ues.

If the chart has multiple series, in
the Series list, select the series to
sort on. In the Order list, select
Ascending or Descending.

Data

Sort by category axis labels.

Labels are sorted alphanumerically
in ascending order. To sort in de-
scending order, select theReverse
Order check box.

Category La-
bels

Enable Sorting

All

This option allows you to specify conditions that control
when the chart is visibile in the model. For more infor-
mation about using dynamic visibility, see Managing
the Visibility of Components.

Dynamic Visibili-
ty

Scale Tab

66

Working with Components



DescriptionOption

Use these options to specify how the scale looks
on the chart. For more information, see Configur-
ing Scales.

Scale

Animations and Effects Tab

All except Tree Map

When enabled, data animations add movement to
chart components. For example, in Bar charts the bars
gradually increase or decrease in size and, in point-
based charts, the points slide to there new position as
the data changes. When not enabled, the value
markers jump to their new position when the data
changes.

Enable Data
Animation

If dynamic visibility is enabled, select how you
want to the chart to appear on the canvas when
triggered. You can select an entry effect and
specify how long you want to components appear-
ance to take. For more information about dynamic
visibility, see Managing the Visibility of Compo-
nents

Entry Effect

Related Topics
• To set up a chart
• Chart General properties
• Chart Drilldown properties
• Chart appearance properties

Configuring Scales
The scale controls how data is plotted on the chart and how the chart axes
adjust as the data values change.

Note:
Scales do not apply to Pie, Tree, or Sparkline charts.
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You can allow chart scales to adjust automatically based on the data.
However, depending on what the data is showing, the auto-created scale
may not be appropriate and you may want to control the scale manually. If
you set a manual scale, the scale will not change to accommodate the data
and if data values exceed the chart range, they will not show on the chart.
For example, if your data is represented as a percentage of a specific
quantity, it may not be appropriate to include 120%.

You can also specify the scale format as either linear (based on addition) or
logarithmic (based on multiplication). In general, you should try using a
logarithmic scale for larger number ranges or for data that contains a wide
variation of values.

Note:
If you want to allow users to adjust the scale at runtime, enable runtime tools
on the Behavior > Common menu.

Related Topics
• Allowing users to adjust chart scales
• Chart Behavior properties

To configure chart scales
A chart has been placed on the canvas and linked to cells in the embedded
spreadsheet.

1. Select the chart and open the "Properties" panel.
2. In the "Properties" panel, click Behavior > Scale .
3. If you are configuring a Bullet Chart component, to configure a different

scale for each series, select theConfigure Scale by Series option. Then
select the series you want to configure from the list.
Use this option when you need to display metrics that are not closely
comparable within a single scale or when the series use different scale
measures, for example, percent, count, dollars.

4. Under Scale, select one of the following options:
• Manual Axis

Select this option to set fixed scale limits that will not change to
accommodate the data values. If the data values exceed the specified
scale range, the markers do not show the outlying values. Users can
see the values when in a tooltip when they move the mouse over the
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marker. If you select this option, set the Maximum and Minimum Limits
for each scale axis.

• Auto Axis

Select this option to allow the scale limits to change to accommodate
the data values, then set the following options:

DescriptionOption

Select this option if you want the scale to grow
as data values increase, but not shrink when
the values decrease. This option minimizes
the number of times the chart must rescale
and is useful to reduce the impact on perfor-
mance when the chart is included in an anima-
tion.

Allow Zoom
Out Only

If Allow Zoom Out Only is selected, adjust
the amount the axis scale will change. Move
the slider to the right to increase the amount
the axis scale will increase when the chart
scale increases.

Zoom Sensi-
tivity

5. In the Axis Scale list for each chart axis, select one of the following
options:
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DescriptionOption

A linear scale increases by adding a set amount to
each scale marker (for example, 1, 2, 3, 4). This is
the most commonly used scale and works well when
the data value range is fairly small.

Linear

A linear scale increases in multiples. This scale is
helpful when the data value range is broad or in-
cludes some values that are much larger than others.
For example, if you had quantities like 10, 100, and
60,000, these values would not fit well on a linear
scale and the smaller values would be lost. A loga-
rithmic scale may reveal structured relationships over
many orders of magnitude.

Logarith-
mic

6. To lock the width of the axis labels and prevent them from being resized
if the scale changes, select Fixed Label Size.

7. If Fixed Label Size is selected, to define the axis scale labels, click the
Manual Edit icon ( ) beside Label Abbreviations and then edit the
abbreviations.

8. If the Manual Axis option is selected , under "Divisions", select one of
the following options:

Note:
If a scale is defined for more than one chart axis, the division settings
apply to all of them and can't be set differently for each axis.

• Number of Divisions

To set the number of scale markers to show on the axis. The value of
the markers is determined by the range of the scale. If the scale
changes, the values of the markers are adjusted to maintain the same
number of markers.

• Size of Divisions

To set the values of the markers based on a specific amount between
markers. The value of the markers is determined by adding this amount
to the previous marker. If the scale changes, the number of markers
may change, but the values of the markers remain the same.
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9. In the Minor Divisions list, select the number of grid lines to show
between chart markers.

Note:
If Show Major Ticks or Show Minor Ticks are not selected on the
Appearance > Axis menu, division markers do not show on the chart.

Related Topics
• Allowing users to adjust chart scales
• Chart Behavior properties
• Chart appearance properties

Adding Range Sliders to charts
When you add a range slider to a chart, a miniature version of the chart
displays below or beside to the chart. A slider on the miniature chart allows
users to select a portion of the data to show in the main chart.

Note:
For Bar and Stacked Bar charts, the range slider appears to the left of the
chart.

When you configure the range slider, you can specify the size and location
of the range slider by setting the beginning and end range values. By default,
these values are set to 0 (zero) and the maximum value, so the range spans
the entire chart range. You can set the values to a specific data position or,
if category axis labels are defined for the chart, to specific category labels.
You can also bind the range values to cells in the embedded spreadsheet
that are set by another source, such as a selector component in the model.
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Note:
If the beginning range value is larger than the end range value, the range
slider will select the entire chart range and the main chart will show the entire
range by default.

To change the data displayed in the main chart, users drag the range slider
across the miniature chart. Users can also expand the size of the range in
the main chart by dragging the control handles on either side of the range
slider.
Related Topics
• Using Chart components
• Chart Behavior properties

To configure range sliders
1. Select the chart and open the "Properties" panel.
2. In the "Properties" panel, click Behavior > Common.
3. Select the Enable Range Slider checkbox.
4. In the Beginning Range Value list, select one of the following options:

• Position -- to specify a data position in the chart. For example, if 30
points are being plotted in the chart, a value of 2 would refer to the
second point in the data set.

• Category Label -- to specify a category axis label. For example, if
category axis labels are set to the days of the month, you could specify
March as the beginning range value.

Note:
If category axis labels are not defined, this option is not available.

5. In the Beginning Range Value box, type a range value or select the Cell
Selector icon ( ) to select a cell in the embedded spreadsheet.

Note:
To have the value set by another component, select an empty cell and
then configure another component to enter a value in that cell.

6. Repeat steps 4 and 5 to set the End Range value.
7. Beside the Range Labels box, do one of the following:

• Select the Cell Selector icon ( ) to select cells in the spreadsheet.
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• Select the Manual Entry icon ( ) to type in the names of the labels.
The range labels are distributed across the miniature chart. The placement
of the labels depends on the number of data points and the total number
of labels. For example, if there are 36 data points plotted on the chart
and 4 labels, a range label is displayed every 8 data points.

A range slider is added to the chart as defined.

Working with variable amounts of data
If the amount of data available for a chart may vary, for example, to
accommodate the number of days in a month, you can configure the chart
to only display the values that are available and to ignore blank cells at the
end of a range. For example, if data is entered for each day in a month, when
the month has 31 days, you want the chart to include the data for each of
those days. When a month has 30 days, the chart should not display an
empty value for day 31. You must set the range to include 31 days, but if the
last cells are empty, you do not want them to appear on the chart.

Note:
Although the chart does not display all the data within the data range, the
size of the range still affects the model's performance.

To configure a chart for variable amounts of data
1. Select the chart and open the "Properties" panel.
2. Click the Behavior view.
3. On the Common tab, select Ignore Blank Cells.
4. To prevent the chart from displaying empty series past the last non-empty

series in a range, select In Series.
5. To prevent the chart form displaying empty values past the last non-empty

value in a series, select In Values.

Empty cells at the end of a range for the series and/or values are not included
in the chart.
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Chart appearance properties

Layout view

Use the following table as a guide for setting the Appearance properties for
chart layout. Note that some options are available only for specific chart
types.

DescriptionOption

Layout Tab

All

Select this option to include a solid background behind
the chart. If this option is not selected, the chart is
transparent. If you include a background, set the follow-
ing options:

DescriptionOption

Select the amount of space to
allow between the edge of the
background and the data

Margin

For Sparkline charts, set the
amount of space between the
series labels and the plot area

Horizontal Gap

For Sparkline charts, set the
amount of space between each
series of data

Vertical Gap

Tip:
You can set a color for the chart background on
the color tab.

Show Chart
Background
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DescriptionOption

All except Tree Map charts

For the plot area (the area bounded by the chart axes),
set the following options:

DescriptionOption

Applies a background to the plot
area.Show Fill

Applies a border around the plot
area.Show Border

If Show Border is selected, se-
lect a thickness for the border.

Border Thick-
ness

Plot Area

All

For the area behind the title, set the following options:

DescriptionOption

Applies a background to the title area.Show Fill

Applies a border around the title area.Show Bor-
der

If Show Border is selected, select a
thickness for the border.

Border
Thickness

Title Area

All except Sparkline, Vertical Bullet, and Horizontal
Bullet charts

Select this option to display a legend for the chart. For
more information about configuring legends, seeAdding
legends to charts.

Enable Legend
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Series tab

Use the following table as a guide for setting the Appearance properties for
chart series. Note that some options are available only for specific chart
types.

Note:
The Series tab is not available for Area, Stacked Area, and Filled Radar
Chart components.

DescriptionOption

Series Tab

All except Sparkline charts

Lists the series that have been defined for the chart.

Note:
If, on the General view, the By Series option is not
selected and set up for the chart, this column is
empty.

Series column

Combination chart only

Select the type of marker to use for this series:
• Column
• Line

Type column

Pie chart only

Select each data point and specify a color. This sets the
colors of the wedges in the Pie chart.

Data Point
column
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DescriptionOption

Line, Combination, Radar, and XY chart compo-
nents only.

Select one of the following marker symbols to appear
on the series data points:
• circle
• diamond
• star
• triangle
• X

Shape col-
umn

Line, Combination, and Radar chart components

Click the Color Selector icon ( ) and select a color
for the line that connects the data points.

Line column

All except Bullet, Tree Map, Candlestick, and Line
charts

Click the Color Selector icon ( ) and select a color
to represent each series.

Fill column

Bullet charts only

Click the Color Selector icon ( ) and select a color
to represent the actual performance values.

Performance
Color column

Bullet charts only

Click the Color Selector icon ( ) and select a color
to represent the target data values.

Comparative
Marker Color
column
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DescriptionOption

Bullet charts only

Click the Color Selector icon ( ) and select a color
to represent high value marker color.

Scale High
Color column

Bullet charts only

Click the Color Selector icon ( ) and select a color
to represent low value marker color.

Scale Low
Color column

Tree map only

Click the Color Selector icon ( ) and select a color
to represent the color for high values.

High Color
column

Tree Map only

Click the Color Selector icon ( ) and select a color
to represent the color for low values

Low Color
column

Combination and Radar charts only.

Select a series and set the thickness for the lines that
connect the data points.

Note:
For Combination charts, this option is available only
when Line is selected in the Type column for the
selected series.

Line Thick-
ness

Combination charts only

Select this option to show data point markers on the line
graph.

Enable Mark-
ers
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DescriptionOption

Line charts only

Select this option to show the data point markers on the
line graph.

Enable Series
Markers

XY, Radar, Bubble, Bar, Column, Line, and Combi-
nation charts only

Specify the size of the data point marker.

Note:
For Combination charts, marker size is set for both
the Column Settings and the Line Settings.

Marker Size

Stacked Bar and Stacked Column charts only

Specify the amount of space between the markers for
each series.

Marker Gap

Stacked Bar and Stacked Column charts only

Specify how much the bars or columns for each series
overlap the bars or columns of the other series. If set to
100, they appear in the same bar or column space to
make a single bar or column that changes color to show
the second series.

Marker Over-
lap

XY, Radar, Bubble, Bar, Column, Line, Filled Radar,
Stacked Area, Area, Stacked Bar, Stacked Column,
Candlestick, OHLC, Pie, and Combination charts
only

Set the visibility of objects behind the chart or chart
markers.

Note:
For Combination charts, transparency is set for both
the Column Settings and the Line Settings.

Transparency
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DescriptionOption

Bullet charts only

Specify the size of the marker that indicates the actual
performance value.

Performance
Marker Size

Bullet charts only

Specify the size of the marker that indicates the target
value.

Comparative
Marker Size

Tree Map and Pie charts only

Specify if lines should be visible between the sections
that show different series values. If this option is select-
ed, specify the line thickness.

Show Lines

Candlestick and OHLC charts only

Specify a color for positive values.
Positive Color

Candlestick and OHLC charts only

Specify a color for negative values.
Negative Col-
or

Axes tab

Use the following table as a guide for setting the Appearance properties for
chart axes. Note that some options are available only for specific chart types.

Note:
The Axes tab is not available for Pie and Sparkline charts.

DescriptionOption

Axes Tab
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DescriptionOption

All except Horizontal Bullet charts

Select this option to include a line along the vertical axis.
If selected, you can specify the thickness and line color,
and whether to show ticks to indicate major or minor
values.

Enable Verti-
cal Axis

All except Filled Radar and Radar charts

Select this option to include a line along the horizontal
axis. If selected, you can specify the thickness and line
color, and whether to show ticks to indicate major or
minor values.

Enable Hori-
zontal Axis

All except Bullet, Bar, Stacked Bar, and Stacked
Column charts

Select this option to display gridlines for the horizontal
axis. If selected, you can choose to display Major or Mi-
nor gridlines and set the thickness for the lines.

Horizontal
Gridlines

XY, Bar, and Bubble charts only

Select this option to display gridlines for the vertical axis.
If selected, you can choose to display major or minor
gridlines and set the thickness for the lines.

Vertical Grid-
lines

Text tab

Use the following table as a guide for setting the Appearance properties for
chart text. In the Show column, select the checkbox for each text item you
want to display on the chart. Then, select the text item and format the text
appearance. Note that some options are available only for specific chart
types.

Note:
The Series tab is not available for Area, Stacked Area, and Filled Radar
charts.
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DescriptionOption

Text Tab

All

Displays a main title for the chart.Chart Title

All

Displays a secondary title for the chart.
Sub Title

Sparkline chart only

Displays labels above the columns in the chart.
Header Labels

Sparkline, Vertical Bullet, and Horizontal Bullet
charts only

Displays the name for each data series.
Series Labels

Vertical Bullet and Horizontal Bullet charts only

Displays a secondary label beside the series label for
each data set.

Series Subla-
bels

Sparkline charts only

Displays the first value in the data set to the right of
the plot area.

Start Value

Sparkline charts only

Displays the lowest value in the data set to the right
of the plot area.

Low Value

Vertical Bullet charts only

Displays a title along the vertical axis.
Vertical Axis Ti-
tle
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DescriptionOption

Horizontal Bullet charts only

Displays a title along the horizontal axis.
Horizontal Axis
Title

Vertical Bullet charts only

Displays value labels along the vertical axis.
Vertical Axis La-
bels

Horizontal Bullet charts only

Displays value labels along the horizontal axis.
Horizontal Axis
Labels

Stacked Area, Area, XY, Bubble, Column, Can-
dlestick, OHLC, and Line charts only

Displays a title for the value scale along the vertical
axis.

Vertical (Value)
Axis Title

Stacked Area, Area, XY, Bubble, Column, Can-
dlestick, OHLC, Radar, Filled Radar, and Line
charts only

Displays labels for values along the vertical axis.

Vertical (Value)
Axis Labels

XY, Bubble, Stacked Bar, Bar charts only

Displays a title for the value scale along the horizontal
axis.

Horizontal (Val-
ue) Axis Title

XY, Bubble, Stacked Bar, Bar charts only

Displays labels for values along the horizontal axis.
Horizontal (Val-
ue) Axis Labels

Stacked Bar and Bar charts only

Displays a category title along the vertical axis.
Vertical (Catego-
ry) Axis Title
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DescriptionOption

Stacked Bar and Bar charts only

Displays a label for categories along the vertical axis.
Vertical (Catego-
ry) Axis Labels

Stacked Area, Area, Stacked Column, Column,
Candlestick, OHLC, and Line charts only

Displays a category title along the horizontal axis.

Horizontal (Cate-
gory) Axis Title

Stacked Area, Area, Stacked Column, Column,
Candlestick, OHLC, Radar, Filled Radar, and
Line charts only

Displays labels for categories along the horizontal
axis.

Horizontal (Cate-
gory) Axis La-
bels

All except Sparkline charts

Displays values when the user moves the mouse
pointer over a data marker.

Mouse Over
Values

All except Sparkline, Vertical Bullet, and Horizon-
tal Bullet charts.

Displays a legend that defines the symbols and
markers in the chart. For more information about using
legends, see Adding legends to charts.

Legend

All except Sparkline, Vertical Bullet, and Horizon-
tal Bullet charts

Displays data labels on or around the chart markers.
If the chart contains multiple series, you can specify
if data labels are displayed for each series. For more
information about using data labels, see Displaying
data labels on charts.

Data Labels
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DescriptionOption

Stacked Area, Area, Stacked Bar, Bar, Stacked
Column, Column, Candlestick, OHLC, and Line
charts only

If the Range Slider is enabled on the Behavior view,
this option displays labels on the Range Slider. For
more information about using the Range Slider, see
Adding Range Sliders to charts.

Note:
The Range Labels ignore duplicate, sequential
values in the label data. For example, if the labels
are bound to cells in the spreadsheet where year
values for the data are inserted, on the Range
Slider the first occurrence of a year appears in a
label and subsequent occurrences of that year
are ignored. The next year value is displayed and
subsequent occurrences for that year are ignored.

Range Labels

Color tab

Use the following table as a guide for setting the Appearance properties for
chart colors. For more information about using the "Color" dialog box to set
component colors, see Setting colors for component elements.

DescriptionOption

Color Tab

All

Set the color for the background area behind component
elements.

Background
Color
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DescriptionOption

Radar, Bullet, Tree Map, Bubble, Bar, Candle, and
OHLC charts only

Applies to the color of the markers that represent the
data. You can also set the color for specific series val-
ues such as Performance, Comparative Marker, Scale
High and Low for Bullet charts and High and Low values
for Tree Map charts.

Series

Area, Combination, Column, Pie, and Line charts
only

Applies to the color of the markers that represent the
data.

Slices

All

Applies to the area around the title

You can set a different color for the fill and border.

Title Area

All

Applies to the area where the data is plotted.

You can set a different color for the fill and border.

Plot Area

All

Applies to the area behind the legend.
Legend Area

All except Tree Map and Pie charts

Applies to the chart axes lines and gridlines.

You can set a different color for horizontal and vertical
axes and gridlines, as well as for major and minor
gridlines as appropriate for the chart.

Axes and Grid-
lines
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DescriptionOption

Pie charts

Applies to the lines between the slices of the pie.
Line Color

Related Topics
• To set up a chart
• Chart General properties
• Chart Drilldown properties
• Chart Behavior properties

Adding legends to charts
If you use a chart to show multiple series of data, you might want to add a
legend to define the various markers used in the chart. When you add a
legend, you can define the appearance and location of the legend. In addition,
you can allow users to hide or show the data for a specific series at run-time.
With this ability, users can choose to view all the data on the chart at once
or to simplify the chart and view only some of the series data.

To add a legend
A Chart component is on the canvas.

1. Select the Chart component and open the "Properties" panel.
2. On the "Properties" panel, click Appearance > Layout.
3. Select Enable Legend and set the following options:
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DescriptionOption

Specify a position for the legend in the Chart
component. Select from the following options:
Top, Left, Right, Bottom.

Position

If Left or Right is chosen in Position, you can
shift the legend vertically relative to its position.
Type or select a value. Negative numbers shift
the legend down and positive numbers shift it
up.

Vertical Offset

If Top or Bottom is chosen in Position, you
can shift the legend horizontally relative to its
position. Type or select a value. Negative
numbers shift the legend to the left and positive
numbers shift it to the right.

Horizontal Offset

Adds a solid background color behind the leg-

end. Click the Color Selector icon ( ) to
specify a color for the background.

Show Fill

Adds a border around the legend. Click the

Color Selector icon ( ) to specify a color for
the border.

Show Border
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DescriptionOption

If Show Border is selected, type or select a
value to change the border thickness.

Border Thick-
ness

Select this option to allow users to select spe-
cific series to show on the chart. If selected,
users can click a checkbox beside the series
name or the series name to display or hide the
series values in the chart.

Enable
Hide/ShowChart
Series at Run-
time

If Enable Hide/Show Chart Series at Run-
time is selected, select one of the following
user interaction options:
• Checkbox - adds a checkbox in front of

each series label in the legend. Users click
the checkbox to show or hide the series.

• Mouse Click - Users click the series name
to show or hide the series data on the chart.

Interaction

A legend is added to the Chart.
Related Topics
• Setting colors for component elements

Displaying data labels on charts
Data labels allow you to display data values or labels directly on or around
the data markers. To show data labels overlaid on the markers, you first
mark them to be displayed on the Appearance > Text tab. Then, you can
configure their position, contents, and label separators as required.

To configure data labels
A Chart component is placed on the canvas.

1. Select the chart component and open the "Properties" panel.
2. Click Appearance > Text.
3. In the Show column beside Data Labels, select the checkbox.
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If the chart contains multiple series, you can enable and configure data
labels for each series individually. For Combination charts, you must
configure the data labels individually since Line and Bar markers have
different properties.

4. In the "Format Text" area, set the text appearance properties.
5. In the Position list, select where you want the label to appear relative to

the data marker.
The options available depend on the type of chart and may includeCenter,
Inside End, Outside End, Best Fit, Left, Right, Above, Below, Inside
Base, and Outside with Leader Lines (Pie charts only). For
Combination charts, if you select the Data Label option (instead of
selecting the series), the Position list is not available. You must set the
label position for each series in the Combination chart individually.

6. In the Offset lists, select values to adjust the label location more
specifically by setting the X and Y offsets.

7. Depending on the type of chart, you can also specify what data to include
in the label including the series name, Category Name, Value,
Percentage, X Value, Y Value, Bubble Size, Size Value, and Color
Intensity Value.

8. For some charts you can also choose a separator value to separate data
in the label. In the Separator list, select a value or select Custom and,
in the Custom box, type the value to use.

Data labels are displayed on or near the data markers as defined.

Chart alerts properties

You can set up alerts for the following Chart components:
• Bar
• Bubble
• Column
• Combo
• Line
• Radar
• Stacked Bar
• Stacked Column
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• XY

To set up alerts, select the component and open the "Properties" panel. Then
click the Alerts view, select the Enable Alerts checkbox and set the alert
options. For more information about setting alert options, see Understanding
Alerts.
Related Topics
• To set up selectors
• Selector general properties
• Selector behavior properties
• Selector appearance properties

Configuring drilldown behavior

The chart drill-down capability allows charts to behave as selectors, that is,
when users click a part of the chart, it writes specific data to the embedded
spreadsheet. That data can then be used by another component to display
more detailed information.

For example, a Pie chart that shows annual sales could be configured to
insert the monthly sales totals into specified destination cells. Then a Bar
chart could use that data to display the monthly totals each time a piece in
the Pie chart is clicked.

Tip:
To see an example of a model with drilldown behavior, click File > Samples
and open the sample file Chart - Drilldown.

Related Topics
• To set up a chart
• Chart Drilldown properties
• To configure charts to drill down

To configure charts to drill down
A chart has been configured and bound to a series of data. The spreadsheet
also contains more detailed information that can be drilled down to from the
chart.
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Note:
Drilldown options are not available for Area, Stacked Area, Horizontal and
Vertical Bullet, Sparkline, Radar, or Filled Radar charts.

1. Select the chart you want to use to drill down and open the "Properties"
panel.

2. Click the Drilldown view.
3. On the Drilldown view, select Enable Drilldown.

Note:
If the Enable Drilldown checkbox is not available, verify that the chart
is bound to a range of data.

4. If the chart contains a series, in the Series Name Destination box, select
a cell in the spreadsheet where the name of the series will be inserted.

5. In the Insertion Type list, select one of the following options to specify
the structure of the data that will be inserted into the embedded
spreadsheet when a selection is made:
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DescriptionOption

When a series is selected, the position of the value
within the series is entered in the target cell. For ex-
ample, if the series contains three cells, when the
first one is selected, a 1 is entered in the destination
cell. When the second is selected, a 2 is entered and
for the final one, a 3 is entered.

Position

When a selection is made, the value in the source
cell for that selection is entered in the destination
cell.

For Bubble, OHLC, XY, Candlestick, and Tree Map charts,
the value is based on the specified value set. For exam-
ple, for a Tree Map chart, you might use the values for
size or for color intensity.

Value

When a selection is made, the row of source data
values corresponding to the selection is entered in
the target row.

Row

When a selection is made, the column of source data
values corresponding to the selection is entered in
the destination column.

Column

When a selection is made, a value of 1 is entered in
the cell in the range representing that selection and
a value of 0 is entered in the other cells of the target
range.

Status List

6. For Pie charts, skip this step. In the Series list, select a series to configure.
7. If the Insertion Type is set to Row, or Column, beside Source Data,

click the Cell Selector icon ( ). Then, select the cells in the spreadsheet
that contain the source data.

Note:
If the Insertion Type is set to Value, Position or Status List, the source
data is determined by the selection in the chart.
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8. For Bubble, XY, Candlestick, OHLC, and Tree Map charts , if Insertion
Type is set to Value, in the Value Set list, select the value that will be
inserted when a selection is made.

9. Beside the Destination box, click the Cell Selector icon ( ) and select
the cells in the spreadsheet where the source data or value set will be
inserted when a selection is made.

Note:
The destination range must be blank and large enough to store all the
cells in the source range.

10. Under Interaction Options, in the Insert On list, select Mouse Click to
insert the data when the user clicks the chart or Mouse Over to insert
the data when the user moves the mouse pointer over the chart selection.

11. Under "Default Selection", in the Series list, select the series and, in the
Item list, select the item that will be selected when the model loads.

The chart is configured to insert data into a destination range when a selection
is made. The data in the destination range can now be used by another
component in the model.

Place another chart on the canvas and configure it to display the data inserted
into the destination range.
Related Topics
• Using Chart components
• Chart Drilldown properties
• Configuring drilldown behavior

Allowing users to adjust chart scales

When you design a chart based on dynamic data that can be entered or
adjusted by users at run-time, you don't have complete control over those
values and it can be difficult to set a reasonable scale. For many charts, you
can define a manual scale and, then include a toolbar to allow users to adjust
the scale values at run-time. These run-time tools allow users to create a
custom scale without dealing with the mechanics or mathematics of custom
scaling.
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Note:
Run-time tools are not available for Pie, Tree Map, Horizontal and Vertical
Bullet, or Sparkline charts.

When Run-time tools are enabled, a Run-time Tool icon ( ) is available in
the upper left corner of the chart. When users move the mouse pointer over
this icon, the Run-time Tool menu opens.

Depending on which Run-time Toolbar options are selected, the menu can
contain the following buttons:
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DescriptionButton

Sets the scale to Allow Zoom Out Only, which
allows the scale to grow as data values in-
crease, but doesn't' shrink when data values
decrease. This setting minimizes the number
of times the chart scale changes, but allows it
to show all the data values when they increase.

This option is useful when users are trying different
options that may push the scale limits and don't want
to reset the scale each time, or when the chart is
used in animations.

GROW

Turns off scaling so the chart uses the minimum
and maximum data points as the minimum and
maximum scale values. The chart continues
using this scale even if the data changes.

OFF

Sets the scaling behavior to Auto, so the mini-
mum and maximum scale values automatically
adjust to accommodate all data points.

AUTO

When chart scaling is set to Off, the Focus Chart
Data button forces the chart axes to rescale
based on the current data. The chart then re-
tains that scale even if the data subsequently
changes.

The Reset Chart Scale button sets the scale
values back to what they were when the model
was opened.

Related Topics
• To display the Run-time Tools menu on charts
• Using Chart components
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To display the Run-time Tools menu on charts
A model containing a chart component is open on the canvas.

1. Click the chart component and open the "Properties" panel.
2. Click Behavior > Common .
3. Select the Enable Run-time Tools checkbox.
4. To customize which buttons are available on the toolbar menu, select

any of the following options:

DescriptionOption

Displays the Focus Chart Data button.Show Focus Button

Displays the Reset Scale button.Show Reset Scale But-
ton

Displays the Grow, Off, and Auto but-
tons.

Show Scale Behavior
Options

Note:
If you deselect all the tool options, the Run-time Tools icon will not be
available, even if Enable Run-time Tools is selected.

When the model runs, the Run-time Tools icon is available in the upper, right
corner of the chart.
Related Topics
• Using the Properties panel
• Allowing users to adjust chart scales
• Chart Behavior properties

Using Container components

Containers group and display other components.

Note:
Container components are not available in Xcelsius Present.
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Container components can be nested within each other to create multi-layer
models. To avoid decreasing the model's performance, use only one layer
of nesting, for example, a parent Tab Set component on each tab with no
container components within the child containers.

Canvas

The Canvas container component is similar to the Panel container component,
but it does not have any art, for example, background, borders, heading bar,
and so on.

In design mode, the container is visible to allow the designer to work with
the component, but when the model is run, the container is invisible so
components in the container appear to be free floating. If the components
in the Canvas container extend beyond the container borders, scrollbars are
added.

Panel Container

The Panel Container component acts as a smaller canvas within the main
canvas and can hold one or more components. Components in the panel
container can be moved, added, changed or deleted. In the "Object Browser"
panel, to see the list of components within a panel container, click the Plus
icon next to the Panel Container name.

Note:
The Panel2 Container component has the same functionality as a Panel
Container, but with a different look.
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To explore a sample model that includes a Tab Set component, click File >
Samples and select Panel Container.

Tab Set

The Tab Set component acts as a smaller canvas within the main canvas
and contains multiple tab views. Each view can contain one or more
components, which can be linked to different data sets. To display a view,
users click its corresponding tab.

When you configure the Tab Set component, you can increase or decrease
the number of tab views by selecting the Tab Set component, and then
clicking the Plus or Minus icons above the row of tabs. When the model runs,
the Plus and Minus icons are not visible.

Note:
The Tab Set component functions as a single grouping of tabs. You cannot
create sub-groups of the tabs within the component.

To see an example of a model with a Tab Set component, click File >
Samples and open the sample file Tab Set.

To set up a container

A list of values is entered in the embedded spreadsheet.

1. Open the "Components" browser and drag a container onto the canvas.
2. If you add a Tab Set component, add and label the required tabs.
3. Select the container and open the "Properties" panel.
4. On the "Properties" panel, click the General view and enter the titles and

labels for the container elements, for the Tab Set component, also set
the location for the tabs. For more information about the available options,
see Container general properties .
The container is updated with the changes.
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5. Click the Behavior view and set the options for how the component
functions in the model including handling variable amounts of data, scaling,
and animations. For more information about the available options, see
Container behavior properties.

6. Click the Appearance view and set the visual characteristics of each
container element. For more information about the appearance options,
see Container appearance properties.

7. From the "Components" Browser, drag components onto the container
canvas and configure the components as you would for components on
the main canvas.

8. Click File > Save and enter a location and filename for the model. Click
OK.

The container is added to the model and configured. To see how the model
will look at run-time, on the Toolbar, click Preview.

Container general properties

Use the following table as a guide for setting the Container component
properties on the General view. Note that some options are available only
for specific container types.

DescriptionOption

Tab Set only

Specify whether the tabs appear to the right, center, or left
of the tab set canvas.

Tab Align-
ment

Tab Set canvases only

Type a label for the tab or click the Cell Selector icon ( )
to link the label to a cell in the embedded spreadsheet.

Note:
To select a Tab Set canvas, on the component, click
the tab to select it and then click the canvas area.

Label
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DescriptionOption

Panel containers only

Type a title for the panel container or click the Cell Selector
icon ( ) to link the label to a cell in the embedded
spreadsheet.

Note:
You can configure the title format on the Appearance
view.

Title

Related Topics
• To set up a container
• Container behavior properties
• Container appearance properties

Container behavior properties

Use the following table as a guide for setting the Behavior properties for
containers. Note that some options are only available for specific container
types.

DescriptionOption

Common Tab

Tab Set component only

Select the tab that will be open when the model loads.
Selected
Item

Tab Set canvases, Canvas, and Panel components
only

Specify whether a horizontal scroll bar is available on the
canvas always (On), never (Off), or if the contents of the
canvas exceeds its width (Auto).

Horizontal
Scroll Bar
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DescriptionOption

Tab Set canvases, Canvas, and Panel components
only

Specify whether a vertical scroll bar is available on the
canvas always (On), never (Off), or if the contents of the
canvas exceeds its height (Auto).

Vertical
Scroll Bar

Tab Set, Canvas, and panel components

Note:
You cannot set dynamic Visibility for individual sub-
canvases on the Tab Set component.

This option allows you to specify conditions that control
when the container is visible in the model. For more infor-
mation about using dynamic Visibility, see Managing the
Visibility of Components.

Dynamic Visi-
bility

Animations and Effects Tab

Tab Set, Canvas, and Panel components only

Note:
You cannot set entry effects for individual subcan-
vases on the Tab Set component.

If dynamic visibility is enabled, select how you want the
container to appear on the canvas when triggered. You
can select an entry effect and specify how long you want
the components appearance to take. For more informa-
tion about dynamic visibility, see Managing the Visibility
of Components

Entry Effect

Related Topics
• To set up a container
• Container general properties
• Container appearance properties
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Container appearance properties

Use the following table as a guide for setting the Appearance properties for
containers. Note that some options are available only for specific container
types.

DescriptionOption

Text Tab

Tab Set and Panel containers

Lists the elements that can have text. To hide the text for
an element, deselect it.

Note:
You cannot deselect the tab labels on Tab Set com-
ponents.

Show Text

Tab Set and Panel containers

The settings in this area allow you to format the text for
the selected text element.

Note:
If a global font is set for the document, you cannot
change the font type. For more information about
global fonts, see To set global font options.

Format Se-
lected Text

Color Tab

All except Canvas containers

Set the color for the background area behind the sub-
canvas.

Background
Color

Panel containers

Set the color for the sub-canvas on the panel.
Panel Color
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DescriptionOption

Tab Set containers

Set the color for tabs on the container. You can set a dif-
ferent color for when the tab is not active (Default color),
when the mouse pointer moves over the tab (Over color),
and when the tab is active (Selected color).

Tab Back-
grounds

Tab Set sub-canvas, Canvas, and Panel containers

Set the color for the following parts of the scroll bar:
• Track
• Thumb
• Button
• Button Symbol

Scroll Bar

Tab Set container

You can set a different color for when the tab is not active
(Default color), when the mouse pointer moves over the
tab (Over color), and when the tab is active (Selected
tab).

Note:
You can also set the label text color on the General view.

Labels

Related Topics
• To set up a container
• Container general properties
• Container behavior properties
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Using Selector components

Selector components allow you to pick an item from many members or from
a list and insert the selected item's row, position, value, label, and so on into
another row or cell in the embedded spreadsheet. Other components can
then retrieve that information to complete other tasks.

Note:
For information about the functionality of Selector components, on the
component's "Properties" panel, click the Information icon ( ).

Accordion Menu

The Accordion Menu is a two-level menu that lets users first select a category
and then select from items within that particular category.

Note:
This component is not available in Xcelsius Present.

Tip:
To see an example of a model with an Accordion Menu component, click
File > Samples and open the sample file Accordion Menu.

Check Box

A standard user-interface component where users toggle between two states:
checked and unchecked.
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Combo Box

A standard user-interface component that drops down a vertical list of items
when it is clicked. Users can then select an item from the list.

Filter

The Filter component looks at a range of cells with multiple fields of data and
categorizes them by unique data entries. The Filter sifts through the data
range and inserts data corresponding to the list selections.

Tip:
To see an example of a model with a Filter component, click File > Samples
and open the sample file Filter.

Fisheye Picture Menu

With the Fisheye Picture Menu, users select from a set of pictures or icons.
As the mouse is moved over each item in the menu, the item is magnified.
The closer the mouse is to the center of the item, the more the item is
magnified. This creates an effect similar to that of a fish-eye lens.

Note:
This component is not available in Xcelsius Present.
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Icon

The Icon can be used as a selector or display component. As a selector, it
functions similar to the Check Box component. It can represent the actual
value contained in one cell and be compared to its target value in another
cell.

The Icon component can also be set to change color depending on its value
relative to the target value, which is an Alert. For more information about
alerts, see Understanding Alerts.

At the same time, you can use the Icon to activate and display other
components. For more information about controlling component visibility,
see Managing the Visibility of Components.

Note:
To configure the Icon component as a display-only component, click the
Appearance view and deselect ShowOn/Off. User will not be able to select
the icon.

Label Based Menu

The Label Based Menu component lets users select items from a vertical
or horizontal grouping of buttons.

List Box

A standard user-interface component that lets users select items from a
vertical list.
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List Builder

The List Builder provides a way for users to build their own set of data at
run-time. This data set can then be used to populate another component.
The List Builder consists of a "Source" list containing all possible selections,
a "Destination" list containing the selected items, and an Update button.
Users move items between the "Source" and "Destination" lists in one of the
following ways:
• Double-clicking items in either the "Source" or "Destination" list to move

the item to the other list.
• Dragging items from one list to another.
• Using the Add and Remove buttons.

When the Update button is clicked, the items in the "Destination" list are
inserted into the destination range to be used by other components. To
change the order of items in the "Destination" list, drag an item up or down
in the list.

Note:
This component is not available in Xcelsius Present.

Tip:
To see an example of a model with a List Builder component, click File >
Samples and open the sample file List Builder.
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List View

The List View component has the same functionality as the Table
component, but lets the user sort the columns and adjust the width of the
columns in the exported SWF file.

Play Selector

The Play Selector component sequentially inserts one row or column from
a defined range into the destination cells you selected. You can link the
destination cells to a chart so the chart data changes each time the play
selector inserts a new row or column. The Play Selector component can
display a large amount of data with a movie effect, which lets users view the
data without clicking each selection.

Note:
This component is not available in Xcelsius Present.

Push Button

The Push Button component inserts specific data each time it is clicked. It
can be used to allow users to restore Single Value components to their default
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values without resetting the values for the entire model or to create a pop-up
window that appears when the button is pushed.

You can configure the Push Button to set the values of one or multiple cells
to specific values when users click the button. The values only change when
the user clicks the button, so users have more control over when the data
is copied to the destination cells.

Radio Button

The Radio Button component lets users select from a vertical or horizontal
group of selections.

Scorecard

The Scorecard component allows you to display visual alerts in a grid. At
run-time, users can click column headings to sort the grid according to the
column's data. This component is similar to a List View selector, but it includes
options to enable and configure alerts in columns and to add headers that
allow users to sort the columns at run-time.

Alert levels can be displayed with cell background colors, font colors, or alert
icons with or without values.
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Sliding Picture Menu

With the Sliding Picture Menu, users select from a set of icons or pictures.
The users can use arrows to scroll through the icons or the menu can be
configured to scroll through the icons as the user moves the mouse.

Note:
This component is not available in Xcelsius Present.

Tip:
To see an example of a model with a Sliding Picture Menu component, click
File > Samples and open the sample file Sliding Picture Menu.

Spreadsheet Table

The Spreadsheet Table component is a what-you-see-is-what-you-get
(WYSIWYG) representation of any group of cells from your spreadsheet.

Note:
The Spreadsheet Table component can be used as a display component
as well as a selector component. As a display component, the spreadsheet
table is a graphic representation of a range of cells in the spreadsheet. To
use the spreadsheet table as a display component, click the Cell Selector
icon ( ) beside Display Data and select a range of cells to display from
the spreadsheet. On the Behavior view, click Deselect All. Users will not
be able to select rows in the table. To use the spreadsheet table as a selector
component, after setting the Display Data range, set the Insert Option to
rows.
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Ticker

The Ticker component displays horizontally scrolling text in your model.
Scrolling stops when the user moves the mouse pointer over the labels.

Toggle Button

A standard user-interface component that lets users toggle between two
states: on and off.
Related Topics
• To set up selectors

To set up selectors

A list of values is entered in the embedded spreadsheet and a Selector
component has been placed on the canvas.

1. Select the component and open the Properties panel.
2. On the "Properties" panel, click the General view and enter the titles and

labels for the selector elements, then link the selector to the data in the
spreadsheet. For more information about the available options, see
Selector general properties.
The selector is updated with the changes.

3. Click the Behavior view and set the options for how the component
functions in the model including handling variable amounts of data, scaling,
and animations. For more information about the available options, see
Selector behavior properties.

4. Click the Appearance view and set the visual characteristics of each
selector element. For more information about the appearance options,
see Selector appearance properties.

5. If applicable, click the Alerts view to set up notifications of when specified
values have been reached. For more information about alerts, seeSelector
alerts properties.
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6. To create effects based on the setting for the selector, add other
components to your model and link them to the cells where the selector
stores data.

7. Click File > Save and enter a location and filename for the model. Click
OK.

The selector is added to the model and configured. To see how the model
will look at run-time, on the Toolbar, click Preview.
Related Topics
• Using the Properties panel

Selector general properties

Use the following table as a guide for setting the Selector component
properties on the General tab. Note that some options are only available for
specific selector types.

DescriptionOption

"Titles "

All except Icon, toggle Button, spreadsheet Table, Play
Selector, and Push Button components

The main title for the selector. For the List Builder compo-
nent, you can also specify titles for the "Source" list and
"Destination" list.

Note:
You can change the location and format of the title on
the Appearance view.

Title
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DescriptionOption

All except Accordion menu, Check Box, List View,
Spreadsheet Table, Play Selector, Push Button, and
Filter components

Sets the labels that identify selector elements. Click the Cell
Selector icon ( ) to select the label text from the embedded
spreadsheet or click the Manual Edit icon ( ) to type the
label text. For the List Builder component, you can also
specify labels for the Add Button, Remove Button, and Update
Button.

Note:
The Manual Edit icon ( ) does not apply to the Icon
component.

Labels

Ticker component only

The value labels display the values associated with each label.
Click the Cell Selector icon ( ) to select the value labels
from the embedded spreadsheet .

Value La-
bels

Spreadsheet Table and List View components only

The range of data that appears in the component. Click the
Cell Selector icon ( ) to select the range of cells from the
embedded spreadsheet.

Display
Data

Filter component only

Specifies the number of drop-down selectors available for
setting filters.

Display
Options:
Number
of Filters
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DescriptionOption

Icon component only

The selected value is displayed in a tooltip when the user
moves the mouse pointer over the component. Type a value
or click the Cell Selector icon ( ) to select the label text
from the embedded spreadsheet.

Note:
The value must be numeric. If a non-numeric value is entered,
a zero is displayed.

Display
Value

Fisheye Picture Menu and Sliding Picture Menu compo-
nents only

Set the image files used in the component. Select one of the
following:
• Embedded - stores a copy of the image files in the model.

Click Import to select the file to embed.

Note:
The order that images appear in the menu is determined
by the order they are imported. Import the images in the
order you want them to appear in the menu.

• By URL - references the specified URL to load the image
files. Type the URL or click the Cell Selector icon ( ) to
link to a cell in the spreadsheet.

Images
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DescriptionOption

All

The settings in this section define the type of data the selector
controls, as well as the source and destination locations.
When a selection is made, data is copied from the source lo-
cation to the destination location. If the data in the source lo-
cation changes after a selection is made, the data in the
destination location is not automatically updated.

Note:
For the Scorecard component, the Rows are Selectable
option must be selected on the Behavior view to allow users
to select rows to insert. If that option is not selected, users
cannot interact with the Scorecard.

Some selector components can be configured to insert multi-
ple data items with a single selection. For more information
about multiple insertions, seeConfiguring selectors for multiple
insertions.

Note:
The Ticker component can be set up as a display or selector
component. To set it as a selector component, select the
Data Insertion checkbox and set the options.

Data In-
sertion

All

Specifies the structure of the data that is inserted when a se-
lection is made. Select one of the following options: Position,
Label, Value, Row, Column, Filtered Rows, or Status Lists .

For a description of each Insertion Type, see Understanding
insertion types .

Insertion
type
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DescriptionOption

All

Specifies the location of the source data for selections. Click
the Cell Selector icon ( ) to select the range from the
spreadsheet. For Check Box, Icon, and Toggle Button com-
ponents, click the Manual Edit icon ( ) to manually enter
values.

Note:
If the Insertion Type is set to Position, Label, or Status
List, source data cells are not available.

Source
Data

All

Specifies the location in the spreadsheet where the source
data will be inserted. Click the Cell Selector icon ( ) to se-
lect the range in the spreadsheet.

Note:
The required size of the destination range varies according
to the structure selected in Insertion Type. For structures
that use columns or rows of data, be sure to select a range
that is large enough to contain your largest column or row of
data.

Destina
tion

All except Play Selector, Push Button, Toggle Button,
and Icon components

If a selector is in a "no selection" state, when this option is
selected, any existing data in the destination location is
deleted. If this option is not selected, the data remains in the
destination location until another selection is made.

Clear
Destina-
tion
When
No Se-
lected
Item
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DescriptionOption

All except Push Button, Toggle Button, and Icon compo-
nents

Select one of the following options to specify when data is
inserted into the destination location:
• Data Change and Interaction - data is inserted whenever

the data changes or when the user makes a selection.
• Interaction Only - data is inserted only when the user

makes a selection.

Insert On

Label Based Menu and Radio Button components only

Specifies the orientation for the selector. Select either Hori-
zontal or Vertical.

Orienta
tion

Accordion Menu component only

Specifies the categories used on the component. Click the
Plus icon to add categories and then enter the category name,
labels and source data

Cate
gories

Accordion Menu component only

Specifies the category name for the item selected in the cat-
egories list. Type a name or click the Cell Selector icon ( )
to select the name from the spreadsheet.

Name

Accordion Menu component only

Specifies the labels for items within the selected category.
Type a label or click the Cell Selector icon ( ) to select the
label from the spreadsheet.

Labels
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DescriptionOption

Accordion Menu component only

Specifies the source data associated with the labels for the
selected category. Click the Cell Selector icon ( ) to select
the label from the spreadsheet.

Source
Data

Accordion Menu component only

Specifies the target cells for the specified category. Click the
Cell Selector icon ( ) to select the label from the spread-
sheet.

Category
Label
Destina-
tion

Related Topics
• To set up selectors
• Selector behavior properties
• Selector appearance properties
• Selector alerts properties

Configuring selectors for multiple insertions
The following selectors can be configured to retrieve source data from multiple
locations and insert the data into multiple destination locations with a single
selection:
• Spreadsheet Table
• Ticker
• Scorecard
• Radio button
• List Builder
• List Box
• Label Based Menu
• Sliding Picture menu
• Fisheye Picture menu
• Combo box
• Play Selector
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When you set up a selector for multiple insertions, you specify the source
and destination for each chunk of data the same way you would set up the
data source and destination for a single insertion. For each chunk, you can
define the insertion type (row, column, label, position, status).

Note:
The insertion type, Filtered Rows, is not supported when a selector is
configured for multiple insertions.

To set up multiple insertion behavior
A selector that supports multiple insertions is placed on the canvas.

1. Select the component and open the "Properties" panel.
2. On the General view, under "Data Insertion", click the Plus icon ( ) to

add the number of data items you want to insert with each selection.
3. In the list of insertion items, select the first item and set the following

options:
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DescriptionOption

Enter a name for this data itemName

Select the insertion type for this data item.

For a description of each Insertion Type, see Understand-
ing insertion types .

Note:
When multiple insertion is used, Filtered Rows is not
available as an insertion type.

Insertion
Type

Click the Cell Selector icon ( ) and select the
source data location for this data item.

Note:
If the Insertion type is set to Label or Position, the
source data is set as the selected item and this box
is not available.

Source Da-
ta

Click the Cell Selector icon ( ) and select the
destination data location for this data.

Note:
When a selection is made, if the source data location
for a data item is empty, the destination location for
that item will be blank.

Destination

Related Topics
• Using the Properties panel

Selector behavior properties

Use the following table as a guide for setting the Behavior properties for
selectors. Note that some options are only available for specific selector
types.
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DescriptionOption

Common Tab

Accordion, Fish Eye, Icon, Sliding Picture, Label Based
Menu, List Box, Ticker, and Play Selector components
only

Specifies how the component responds when users interact
with it. For example, when the mouse passes over it, when
it is clicked, and so on.

Interaction
Options

Sliding Picture Menu component only

Specifies how the menu scrolls through the thumbnails.
Select one of the following:
• Buttons — user clicks buttons at each end of the menu

to scroll.
• Mouse — user moves the mouse across the thumbnails

to scroll.

Slider
Method

Sliding Picture Menu component only

Specifies how far the slider moves. Select one of the follow-
ing options:
• One — scrolls through thumbnails one at a time
• Page — scrolls through thumbnails a page at a time.

The number of thumbnails on a page is determined by
the width of the component.

Slider
Amount

Sliding Picture Menu component only

Adjusts the speed of the slide behavior as the user scrolls
through the thumbnails.

Scroll
Speed
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DescriptionOption

Accordion Menu component only

Specifies how fast categories expand when the user clicks
the category label. Move the speed slider to adjust the
speed.

Slide
Speed

Play Selector component only

Specifies the length of time the sequence plays. Select the
number of seconds from the list.

Play Time
(seconds)

Play Selector component only

If selected, the Play Selector starts automatically when the
model runs.

Auto Play

Play Selector component only

If selected, the Play Selector rewinds itself automatically
when the sequence has finished playing.

Auto
Rewind

Play Selector component only

If selected, the Play Selector automatically restarts the se-
quence when if finishes playing it.

Auto Re-
play

Fish Eye, Icon, Sliding Picture, Label Based Menu,
List Box, and Ticker components only

Specifies when source data is copied to the destination lo-
cation. Select Mouse Click or Mouse Over. For Label Based
Menu components, if the Always Expanded option is se-
lected, the Insert On option is not available.

Insert On
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DescriptionOption

Play Selector component only

Specifies the size of the popup effect when the mouse
moves over an image. Slide the size slider to adjust the
size.

Zoom Size

Play Selector component only

Specifies the speed that images popup on the selector when
the mouse moves over the images. Slide the speed slider
to adjust the speed.

Zoom
Speed

Label Based Menu component only

If selected, the menu is static (always displays the available
labels). If not selected, you must specify what will trigger
the menu to open and the direction the submenu will appear.

Note:
If this option is selected, the Insert On option is not
available.

Always Ex-
panded

Label Based Menu component only

Specifies how the menu is triggered to open. Select either
Mouse Click or Mouse Over.

Expand On

Label Based Menu component only

Specifies the direction the menu expands when its opened.

Note:
The available options depend on the Orientation set-
ting on the General view. When the orientation is set
to Horizontal, the menu only expands left and right.
When the orientation is set to Vertical, the menu can
expand in combinations of up and down and left, cen-
ter, and right.

Expand Di-
rection
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DescriptionOption

Label Based Menu component only

When selected the menu opening is animated, that is, the
menu items appear to unfold one by one.

Open Ani-
mation

Ticker component only

In this area, you can set options specific to the Ticker
component.

Ticker Op-
tions

Ticker component only

Specifies the separator character used between items on
the Ticker.

Item Sepa-
rator

Ticker component only

Specifies the direction the data scrolls across the ticker.
Select Left or Right.

Scroll Di-
rection

Ticker component only

Specifies how fast the data scrolls across the ticker. Slide
the speed slider to adjust the speed.

Scroll
Speed

Scorecard component only

Select this option to allow users to sort the Scorecard at
run-time. If selected, users can click a column heading to
sort the data in that column.

Allow Col-
umn Sort-
ing

Scorecard component only

Select this option to use the Scorecard as a selector. When
selected, users can click a row to insert the associated data
into a defined destination location. If this option is not select-
ed, the Scorecard will not work as a selector even if the
Data Insertion options are configured on theGeneral view.

Selected
Item: Rows
are Se-
lectable
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DescriptionOption

Accordion component only

Specifies the category that is open by default with the
model runs. Select the category based on its relative posi-
tion in the list of categories. If you select No Selection, an
item is not selected until the user makes a selection.

Selected
Item : Cate-
gory
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DescriptionOption

Ticker, Radio Button, List Builder, List Box, Label
Based menu, and Combo Box components only

Specifies the type of data that will be matched to determine
the default selection. If a match is not found, the selection
is set to none.

Choose one of the following options:

DescriptionOption

The data in the source location is matched
to the component's labels. If the source
data is set to None, an item is not select-
ed.

Label

The position of each selection item for the
component is assigned a number value
starting from 1.The data in the source loca-
tion is matched to the position numbers.

If the source data is set to -1, an item is not
selected.

Position

The position of each selection item is as-
signed a number starting from 0. The data
in the source location is first matched to
the component's labels. If a match is not
found, the data is matched to the position
number. If a match is still not found, the
first item is selected.

Dynamic

Selected
Item: Type

Selected
Item : Item
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DescriptionOption

All except Push Button, Toggle Button, Icon, Filter, and
Play Selector components

Specifies the item that is selected by default when the
model runs. Select the item based on its relative position
in the list of items. If No Selection is selected, an item is
not selected until the user makes a selection.

Note:
For the List Builder, the selected items are added to
the Destination list, but are not added to the destina-
tion cells until the user clicks Update. To insert the
selected items into the destination cells at run-time,
select the Insert Items at Run-time option.

Ticker, Radio Button, List Box, Label Based menu, and
Combo Box components only

Specifies a location to store the selected item value.

Tip:
To reset a selector component to a "no selection" state,
add another selector to set this value to None when
Insertion Type is set to Label and -1 when its set to
Position.

Selected
Item: Insert
Selected
Item

List Builder only

Select this option if you want to pre-populate the List Builder
Destination list and insert the selected items into the des-
tination cells. If selected, the items selected in the Item box
are added to the Destination list on the component and
inserted into the destination cells in the embedded spread-
sheet when the model loads at run-time.

Selected
Item: Insert
Items at
Runtime
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DescriptionOption

Spreadsheet Table component only

Determines whether users can select specific rows in the
table. By default, all rows are selectable. To prevent a row
from being selected, deselect the checkbox beside the row
number. To set the selectability for all rows in the table,
select or deselect the checkbox beside Row.

Row Se-
lectability

All except Check Box, Icon, Toggle Button, and List
Builder components

If selected, the component does not display blank cells past
the last non-empty Label. This option is useful when the
number of selections in the component varies.

Ignore
Blank Cells

All

This option allows you to specify conditions that control
when the selector is visible in the model. For more informa-
tion about using dynamic Visibility, see Managing the Visi-
bility of Components.

Dynamic
Visibility

Animations and Effects Tab

All

If dynamic visibility is enabled, select how you want to the
chart to appear on the canvas when triggered. You can
select an entry effect and specify how long you want to
components appearance to take and, for some selectors,
whether the component makes a sound when it appears.
For more information about dynamic visibility, seeManaging
the Visibility of Components .

Entry Ef-
fect

Related Topics
• To set up selectors
• Selector general properties
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• Selector appearance properties
• Selector alerts properties

Understanding insertion types
When you configure a Selector component, you set it up to insert specific
data into the embedded spreadsheet. That data can then be used by other
components. Depending on what you want to do with the data, you can insert
values from the source to the target cells. You may also want to insert the
selection's position in a list, the label applied to the data, or even a status or
"on/off" value.

The following table describes each of the Insertion types available:

DescriptionInsertion Type

The selection's position in a list
of items is written to the target
cell. For example, if the second
item in a list is selected, the
number two (2) is inserted in the
target cell.

Position

The label specified for the selec-
tion is written to the target cell.
For example, if B is selected from
the options A, B, and C, the label
"B" is inserted in the target cell.
This is useful when labels can
change at runtime and the labels
are used for a subsequent data
search.

Label

A value in the specified source
cell is written to the target cell.
The number of cells specified in
the source data range needs to
match the number of labels dis-
played in the component.

Value
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DescriptionInsertion Type

A specified row from the source
data is written to the target row.Row

A specified column from the
source data is written to the tar-
get column.

Column

A specified range of rows from
the source data is written to the
target range.

Filtered Rows

A 1 is entered in the target cell
for the selection and a 0 is en-
tered in the target cells for all
other items in the list.

Status Lists

Selector appearance properties

Layout tab

Use the following table as a guide for setting the Appearance properties for
selector layout. Note that some options are available only for specific selector
types.

DescriptionOption

Layout Tab
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DescriptionOption

Fish-eye Picture and Sliding Picture Menu com-
ponents only

Specifies how images are sized to fit the thumbnail
area. Select one of the following options:
• Scale— images retain their aspect ratio and may

not completely fill the available space in both di-
rections.

• Stretch — images are sized to fit within the
thumbnail space exactly.

Images : Sizing
Method

Fish-eye Picture and Sliding Picture Menu com-
ponents only

Specifies the width of the thumbnail area in pixels.
Images : Width

Fish-eye Picture and Sliding Picture Menu com-
ponents only

Specifies the height of the thumbnail area in pixels.
Images : Height

Fish-eye Picture and Sliding Picture Menu com-
ponents only

Specifies the horizontal spacing between thumbnail
images in pixels.

Thumbnails :
Horizontal Margin

Fish-eye Picture and Sliding Picture Menu com-
ponents only

Specifies the vertical spacing between the thumbnail
images and the area border in pixels.

Thumbnails :
Vertical Margin
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DescriptionOption

Combo Box and Filter components only

Specifies the number of labels available in the list or
menu. If more labels are defined for the component,
users can scroll down to see the additional labels.
Enter a number between 2 and 50.

Number of La-
bels Displayed

Filter component only

Specifies the amount of space between each filter
list on the component.

Filter Gap

Radio Button component only

Specifies the size of the radio button. Select a size
between 1 and 300.

Marker Size

Radio Button component only

Specifies the distance between the radio buttons and
labels and the left and right edges of the component.

Horizontal Margin

Radio Button component only

Specifies the vertical distance between radio buttons.
Vertical Margin

Radio Button component only

Specifies whether the background behind the buttons
is visible. If selected, you can set the transparency
level for the background.

Enable Back-
ground

Label Based Menu component only

Specifies the amount of space between label tabs.
Button Separa-
tion
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DescriptionOption

Play Selector component only

Specifies which elements are displayed on the com-
ponent. Select the appropriate checkbox to display
the following elements:

DescriptionOption

Determines whether the back-
ground behind the controls is
visible.

Show Back-
ground

Determines whether the progress
slider is visible.

Show
Progress In-
dicator

Determines whether fast forward
and rewind buttons are available.

Show
Rew/Fwd

Determines whether previous and
next buttons are available.

Show
Prev/Next

Auto Replay

Icon, Label Based Menu, List Box, Radio Button,
Toggle Button, Play Selector components only

Specifies whether objects behind the component are
visible. A transparency of 0 means that users cannot
see objects behind the component. A transparency
of 100 means that the component is completely
transparent and invisible to users.

Note:
List Transparency applies to the drop-down list
portion of the component only.

List Transparen-
cy or Transparen-
cy
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DescriptionOption

Ticker component only

Specifies whether the background behind the ticker
labels is visible.

Show Ticker
Background

Push Button component only

Specifies whether the background behind the button
label is visible. If selected, you can also set the
transparency level by moving the slider to the right
for more transparency and to the left for less trans-
parency.

Show Button
Background

List View and Scorecard components only

By default, the List View component adjusts the size
of the columns to fit the size of the source data. If
you want to adjust the column size manually, select
this option and click the Manual Edit icon ( ) to
set the column widths in pixels.

Custom Column
Widths

List View and Scorecard components only

Specifies whether the vertical gridlines are visible in
the table. If selected, you can click the Color Selector
icon to specify the line color.

Show Vertical
Gridlines

List View and Scorecard components only

Specifies whether the horizontal gridlines are visible
in the table. If selected, you can click the Color Se-
lector icon to specify the line color.

Show Horizontal
Gridlines

Text tab

Use the following table as a guide for setting the Appearance properties for
selector text. In the Show column, select the checkbox for each text item
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you want to display on the selector. Then, select the text item and format
the text appearance. Note that some options are available only for specific
selector types.

Note:
The Text tab is not available for Spreadsheet Table and Play Selector
components.

DescriptionOption

Text Tab

All except Push Button, Toggle Button, and Icon
components

Displays a main title for the component.
Title

List Builder selector only

Displays a title above the Source list.
Source List Ti-
tle

List Builder selector only

Displays a label for each item in the Source list. This
option cannot be deselected.

Source List
Labels

List Builder selector only

Displays a title above the Destination list.
Destination
List Titles

List Builder selector only

Displays a label for each items in the Destination list.
This option cannot be deselected.

Destination
List Labels

List Builder selector only

Displays a label on each button. This option cannot be
deselected.

Button Labels
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DescriptionOption

All except List Builder, Icon, and Check Box selec-
tors

Displays a label on the component elements. This option
cannot be deselected.

Labels

Ticker selector only

Displays the data value for each item.
Display Values

Scorecard and List View components only

Displays a heading row for the grid.
Header

Icon selector only

Displays the label in a tooltip when the user moves the
mouse pointer over the icon.

Mouse Over
Label

Icon selector only

Displays the value in a tooltip when the user moves the
mouse pointer over the icon.

Mouse Over
Value

Accordion Menu only

Displays the category names. This option cannot be
deselected.

Category
Names

All except Spreadsheet Table and Play Selector
components

The settings in this area allow you to format the text for
the selected text element.

Note:
If a global font is set for the document, you cannot
change the font type. For more information about
global fonts, see To set global font options.

Format Select-
ed Text
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DescriptionOption

Allows you to set the position for some text ele-
ments relative to the component.Position

Allows you to adjust the position of some text ele-
ments by offsetting them relative to their set posi-
tion.

Offset

Allows you to set the number format for some text
elements.

Number For-
mat

Color tab

Use the following table as a guide for setting the Appearance properties on
theColor tab for selectors. For more information about using the Color dialog
to set component colors, see Setting colors for component elements.

Note:
If Alerts are enabled for an Icon component, the Color option is disabled.

DescriptionOption

Color Tab

Scorecard component only

Set the color of the border around the scorecard.
Border Col-
or

Accordion Menu, Fisheye Menu, Sliding Picture, List
View, List Builder, Radio Button, Ticker, and Play
Selector components only

Set the color for the background area behind component
elements.

Note:
For the Ticker component, if Show Ticker Back-
ground is not selected on the Layout tab, you cannot
set a background color.

Background
Color
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DescriptionOption

Accordion Menu component only

Applies to the text color on the category buttons.

You can set a different color for when the button is not
active (Default color), when the mouse pointer is over the
button (Over Color), and when the category is selected
(Selected Color).

Category
Names

Accordion Menu component only

Applies to the background color on the category buttons.

You can set a different color for when the button is not
active (Default color), when the mouse pointer is over the
button (Over Color), and when the category is selected
(Selected Color).

Category
Background

List View and Scorecard components only

Applies to the column header text.

You can set a different color for when the column is not
active (Default color), when the mouse pointer is over the
header (Over Color), and when the column is selected
(Selected Color).

Header La-
bels

List View and Scorecard components only

Applies to the column header background.

You can set a different color for when the column is not
active (Default color), when the mouse pointer is over the
header (Over Color), and when the column is selected
(Selected Color).

Header
Background
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DescriptionOption

Toggle and Push Button components only

Applies to the button color.

You can set a different color for when the button is on and
when it is off.

Button

Combo Box, Accordion Menu, Filter, Label Based
Menu, List Box, List View, Push Button, Scorecard,
and Ticker components only

Applies to the label text.

You can set a different color for when the element is not
active (Default color), when the mouse pointer moves over
the element (Over color), and when the element is active
(Selected Color).

Labels

Combo Box, Accordion Menu, Filter, Label Based
Menu, List Box, List View components only

Set the color for labels on the component.

You can set a different color for when the element is not
active (Default color), when the mouse pointer moves over
the element (Over color), and when the element is active
(Selected color).

Label Back-
grounds

Fisheye and Sliding Picture components only

Applies to the background color of the heading bar.

Note:
The label text color is set on the Text tab in Labels
text formatting.

Label Head-
er Color
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DescriptionOption

Combo Box and Filter components only

Applies to the drop-down button beside the labels.

You can set different colors for the background (Button
Color) and the drop-down symbol (Arrow Color), as well
as for those items when selected or not selected.

Drop-Down
Button

Ticker component only

Applies to the text color for the display values displayed
in the ticker.

You can set a different color for the text when it is not active
(Default Color), when the mouse point moves over the text
(Over Color), and when the element is selected (Selected
Color).

Note:
On the Ticker component, the color settings for the Labels
are independent of the color settings for the Display Values.

Display Val-
ues

List Builder component only

Applies to the text color for items in the source list.

You can set a different color for the text when it is not active
(Default Color), when the mouse pointer moves over the
text (Over Color), and when the text is selected (Selected
Color).

Source List
Labels
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DescriptionOption

List Builder component only

Applies to the area in the source list behind the text.

You can set a different color for the background when the
text is not active (Default Color), when the mouse pointer
moves over the text (Over Color), and when the text is
selected (Selected Color).

Source List
Background

List Builder component only

Applies to the text color for items in the destination list.

You can set a different color for the text when it is not active
(Default Color), when the mouse pointer moves over the
text (Over Color), and when the text is selected (Selected
Color).

Destination
List Labels

List Builder component only

Applies to the area in the destination list behind the text.

You can set a different color for the background when the
text is not active (Default Color), when the mouse pointer
moves over the text (Over Color), and when the text is
selected (Selected Color).

Destination
List Back-
ground

Fisheye Menu and Sliding Picture Menu components
only

Applies to the thumbnail area behind the images.

You can set a different color for the background when the
item is not active (Default Color), when the mouse pointer
moves over the item (Over Color), and when the item is
selected (Selected Color).

Thumbnails
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DescriptionOption

Accordion Menu, Sliding Picture, List Builder, and Play
Selector components only

Applies to buttons on the component. Depending on the
component, you can set a different color for the following
elements:
• the button background for active, pressed, or disabled

buttons
• the symbol for active, pressed, or disabled buttons
• the button label for default and pressed buttons

Buttons

List View, Scorecard, and Spreadsheet Table compo-
nents only

Applies to the lines between columns and rows in the table.

Note:
If, on the Layout tab, ShowGridlines is not selected,
this option is not available.

Gridlines

List View, Scorecard, and Ticker components only

Applies to the arrow symbol that appears beside the col-
umn title to show the current sort direction.

Note:
The symbol is not visible in design mode.

Sort Sym-
bol : Sym-
bol Color
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DescriptionOption

Spreadsheet Table and Scorecard components only

Applies to the rows in the spreadsheet.

You can set a different row color for when the mouse
pointer moves over the row (Over Color), and when the
row is selected (Selected Color).

For the Scorecard component, you can also set a different
color for alternating rows.

Note:
The default row color is set to the color defined for the
source cells in the embedded spreadsheet.

Rows

Combo Bar, Accordion Menu, Filter, List Box, List
View, List Builder, Scorecard, and Spreadsheet Table
components

Set the color for the parts of the scroll bar.

Scroll Bar

Check Box component only

Applies to the color of the checkbox when it is not selected.
Unchecked
Color

Check Box component only

Applies to the color of the checkbox when it is selected.
Checked
Color

Radio Button component only

Applies to the color of the button.

You can set a different color for when the button is not
selected (Default color) and when it is selected.

Marker
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DescriptionOption

Play Selector component only

Applies to the progress bar indicator.

You can set a different color for the track and for the
marker.

Progress In-
dicator

Related Topics
• To set up selectors
• Selector general properties
• Selector behavior properties
• Selector alerts properties

Selector alerts properties

You can set up alerts for the following Selector components:
• Combo Box
• Icon
• Label-based Menu
• List Box
• List Builder
• Ticker
• Scorecard

To set up alerts, select the component and open the "Properties" panel. Then
click the Alerts view, select Enable Alerts and set the alert options. For
more information about setting alert options, see Understanding Alerts.
Related Topics
• To set up selectors
• Selector general properties
• Selector behavior properties
• Selector appearance properties
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Using the Single Value components

Single Value components let you add user interactivity to your models. Single
Value means that the component or each component marker is linked to a
single cell in the spreadsheet. At runtime, users can view the output of each
component or marker, or adjust a marker to change the value in the
associated cell.

Input vs. output

Single Value components have been classified as both input and output
components, which means that you can use any Single Value component
as an input or output element in your model.

What dictates whether a Single Value component is an input (which permits
user interaction) or output, is the cell to which it is linked. If the cell contains
a formula of any type, the component is interpreted as an output. If the cell
does not contain a formula, it is represented as an input.

For example, if you have a Gauge linked to a cell that does not contain a
formula, you can modify the value by dragging the gauge needle, thereby
modifying the cell value. If you have a Gauge linked to a cell that contains
a formula, you cannot modify the value. The value is set by the formula in
the cell.

Note:
You can control user interaction with Single Value components by setting
the Enable Interaction option on the Behavior view for selectors.

Dial

An input component. A Dial represents a variable that can be modified to
affect other components. For example, to represent the Price per Unit.
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Slider and Dual Slider

An input component. A Slider represents a variable that can be modified to
affect other components. For example, to represent the Price per Unit. The
Dual Slider allows you to adjust both the minimum and maximum values.

Progress Bar

An output component. A Progress Bar represents a value that changes and
fills the progress bar area depending on its value.

Gauge

An output when bound to a cell containing a formula, or an input when bound
to a cell containing a value.

As an output, a Gauge represents a value that changes and moves the
needle. As an input, a Gauge represents a variable that can be modified to
affect other components. Users can interact with the Gauge by dragging the
needle to change the value.

Note:
A single gauge can be configured to show multiple markers linked to different
cells in the spreadsheet.

Value

An output when bound to a cell containing a formula, or an input when bound
to a cell containing a value.
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As an output, a Value represents a value that changes. As an input, a Value
represents a variable that can be modified to affect other components. Users
can interact with the Value by typing in a new value.

Spinner

An input component. A Spinner represents a variable that can be modified
to affect other components. Users can interact with the Spinner by clicking
the up and down arrows or by typing a value into the component.

Play Control

An input component. Play Control is used to automatically increase the
value of a cell in your spreadsheet. For example, link the play button to a
cell that contains the headcount. What will happen if the headcount increases
by one, two, three, or more? Play Control takes the initial headcount value
and increases its value automatically in increments.
Related Topics
• To set up Single Value components

To set up Single Value components

A list of values is entered in the embedded spreadsheet.

1. Open the "Components" browser and drag a single value component
onto the canvas.

2. Select the component and option the"Properties" panel.
3. On the "Properties" panel, click the General view and enter a title for the

component, then link the component to the data in the spreadsheet, and
set the scale options. For more information about the available options,
see Single Value component general properties.
The component is updated with the changes.
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4. Click the Behavior view and set the options for how the component
functions in the model including needle movements, interaction options,
and dynamic visibility. For more information about the available options,
see Single Value component behavior properties.

5. Click the Appearance view and set the visual characteristics of each
component element. For more information about the appearance options,
see Single Value component appearance properties.

6. If applicable, click the Alerts view to set up notifications that specified
values have been reached. For more information about alerts, see Single
Value component alerts properties.

7. Click File > Save and enter a location and filename for the model. Click
OK.

The single value component is added to the model and configured. To see
how the model is working, on the Toolbar, click Preview.

Single Value component general properties

Use the following table as a guide for setting the Single Value component
properties on the General view. Note that some options are available only
for specific component types.

DescriptionOption

"Titles"

All

The title is centered at the top of the component by default.

Note:
You can change the location and format of the title on
the Appearance view.

Title

All except Gauge components

These components link to one value point. You can type the
value in the box or click the Cell Selector icon ( ) to select
the a cell from the embedded spreadsheet.

Data
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DescriptionOption

Gauge components

Select the range of cells in the spreadsheet that contain the
data series to use for the markers. You can link Gauge
components to multiple series of data and display multiple
indicators on a single gauge; however, gauges with multiple
indicators can only be used to display values. Users cannot
manipulate the gauge to during run-time.

Tip:
Selecting a range here sets up theBy Indicator values,
which you can then customize in the "By Indicators"
area.

By Range

Gauge Components

Select each indicator in the list and set the following values:

DescriptionOption

A name for the markerName

The value associated with this markerValue

The type of marker (needle, inside mark-
er, or outside marker)Type

By Indica-
tors

Dual Slider components only

The Dual Slider has two points. To set the default value for
the left marker (low point), type the value in the box or click
the Cell Selector icon ( ) to select the a cell from the em-
bedded spreadsheet.

Low Val-
ue
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DescriptionOption

Dual Slider components only

The Dual Slider has two points. To set the default value for
the right marker (high point), type the value in the box or
click the Cell Selector icon ( ) to select the a cell from the
embedded spreadsheet.

High Val-
ue

All

In this section, set the method used to defined the scale.
Select one of the following options:
• Manual
• Auto

Scale

All

Select this option to set the limits.

Type the minimum and maximum limits in the boxes or click
the Cell Selector icon ( ) to select the a cells from the
embedded spreadsheet.

Manual
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DescriptionOption

All

Select this option to have the minimum and maximum limits
calculated based on the selection in the list. Select this option
and then select one of the following calculation methods:

DescriptionOption

The limits comprise a range around the
value. This option is not available for Play
Control, Spinner, Dual Slider, or Value
components.

Value
Based

The limits comprise a range that uses the
value as the upper limit and zero as the
lower limit.

Zero
Based

The limits comprise a ranges that includes
the value and its negative with zero at the
center point.

Zero Cen-
tered

The limits comprise a range based on the
selected alert method.

Alert
Based

Auto

Related Topics
• To set up Single Value components
• Single Value component behavior properties
• Single Value component appearance properties
• Single Value component alerts properties
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Single Value component behavior properties

Use the following table as a guide for setting the Behavior properties for
single value components. Note that some options are available only for
specific component types.

DescriptionOption

Common Tab

Progress Bar, Slider, and Gauge components

This option specifies how changes are shown on the com-
ponent. Select one fo the following options:

DescriptionOption

Restricts values to a specific amount.
Type the desired increment in the Incre-
ment box or click the Cell Selector icon
to select a cell in the embedded
spreadsheet.

Increment

Progress moves incrementally on major
ticks.Major Ticks

Progress moves incrementally on major
and minor ticks.

Major and
Minor Ticks

Progress
Movement,
Slider
Movement,
or Needle
Movement

Gauge components only

This option determines the springiness of the needle. If you
select less elasticity, the needle snaps to values. If you
select more elasticity, the needle bounces around before
finally settling into place.

Object
Elasticity
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DescriptionOption

Spinner, Value, and Dial components

This option specifies the amount of movement shown on
the component. Type the desired increment in the Incre-
ment box or click the Cell Selector icon to select a cell in
the embedded spreadsheet.

Increment

All except the Play Control component

This option specifies how limits are restricted when the
model runs. For each of theMinimum andMaximum limits,
select from the following options:

DescriptionOption

Users cannot set the value to a number
less than the minimum value or greater
than the maximum value.

Fixed

Users can adjust the values beyond the
set limits. This option is not available for
the Value component.

Ad-
justable

Users can set the value to any number
that does not conflict with the specified
minimum or maximum values

Open

Limits

All

If this option is selected, users can interact with the compo-
nent. If you want the component to display values and not
accept input from users at run-time, deselect this option.

Enable In-
teraction

Value and Spinner components only

If this option is selected, the component will automatically
expand or contract to fit the size of the entered value.

Auto Re-
size
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DescriptionOption

Value, Gauge, and Dial components

This option determines how sensitive the component is to
mouse movements. When the setting is high, small pointer
movements can change the value by large increments.
When the setting is low, pointer movements change the
value by small increments.

Mouse
Sensitivity

Gauge and Dial components only

This option specifies the direction the mouse pointer moves
to change the value on a component. Select one of the
following options:
• Vertical - the user moves the mouse pointer up and

down to adjust the value.
• Radial - The user moves the mouse pointer in a circular

motion to adjust the value.

Mouse
Tracking

Value components only

This option determines the action required to change the
value. Select one of the following options:
• Manual - the user moves the mouse pointer above or

below the component to change the value. For each
increment of change, the user must continue to move
the pointer.

• Auto - The user moves the mouse pointer and places
it above or below the component to adjust the value.
While the mouse button is pressed, the value continues
to change without requiring further pointer movement.

Scroll Be-
havior
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DescriptionOption

All except Dual Slider and Spinner components.

When this option is selected, the play button is available
for the component. When the user clicks the Play button,
the component goes through the values from minimum to
maximum in the increments set for the component.

Enable
Play Button

Play Control component only

This option is available if the Enable Play Button is selected.

If this option is selected, the play sequence for the compo-
nent automatically plays when the model is loaded.

Auto Play

All except Dual Slider and Spinner components.

This option allows you to set the duration of the play se-
quence. Type the number of seconds from 1 to 100 in the
box.

Play Time

All except Dual Slider and Spinner components.

If this option is selected, when the play sequence reaches
the maximum value, it automatically rewinds to the mini-
mum value.

Auto
Rewind

All except Dual Slider and Spinner components.

If this option is selected, the play sequence automatically
repeats.

Auto Re-
play

All

This option allows you to specify conditions that control
when the selector appears in the model.

For more information about using dynamic Visibility, see
Managing the Visibility of Components.

Dynamic
Visibility
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DescriptionOption

Animations and Effects Tab

All

If dynamic visibility is enabled, select how you want to the
chart to appear on the canvas when triggered. You can
select an entry effect and specify how long you want to
components appearance to take. For more information
about dynamic visibility, see Managing the Visibility of
Components

Entry Effect

Related Topics
• To set up Single Value components
• Single Value component general properties
• Single Value component appearance properties
• Single Value component alerts properties

Single Value component appearance properties

Layout tab

Use the following table as a guide for setting the Appearance properties on
the Layout tab for single value components. Note that some options are
available only for specific component types.

DescriptionOption

Layout Tab

All except Spinner and Value components

If this option is selected, small markers that indicate val-
ues (ticks) are visible on the component.

Enable Ticks
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DescriptionOption

All except Spinner and Value components

If Enable Ticks is selected, this option automatically
scales the ticks according to the data.

Auto Scale

All except Spinner and Value components

If Enable Ticks is selected, this option allows you to cus-
tomize the appearance of the ticks. Select one of the fol-
lowing options:
• Number of Ticks -- allows you to specify how many

major and minor ticks are included on the component.
• Size of Divisions - allows you to set the distance be-

tween ticks. Higher values result in larger distances.
You can set the value for both Major and Minor ticks.
The size of the minor divisions is not dependent on
the size of the major divisions.

Manual

Dial and Gauge components only

This option allows you to set the angle of the needle on
the component.

For both Minimum Angle and Maximum Angle, type the
angle amount the needle can rotate to.

Note:
If, on the Behavior view, the Minimum Limit is set to
Open, you cannot set the Minimum Angle value. If
the Maximum Limit is set to Open, you cannot set
the Maximum Angle.

Radial Defini-
tion

Value component only

Select this option to display a background for the compo-
nent. If not selected, the component in transparent.

Show Back-
ground
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DescriptionOption

Play Control component only

This option determines which elements appear on the
Play Control component. Select the elements you want
to include: Rewind/Fast Forward buttons, Previous/Next
buttons, and Slider (progress bar).

Layout Op-
tions

Text tab

Use the following table as a guide for setting the Appearance properties on
the Text tab for selectors. In the Show column, select the checkbox for each
Text item you want to display on the selector. Then, select the text item and
format the text appearance Note that some options are available only for
specific selector types.

Note:
The Text tab is not available for Area, Stacked Area, and filled Radar Chart
components.

DescriptionOption

Text tab

All

Displays a title above the component.Title

All

Displays the current value. For Value and Spinner
components, this option cannot be deselected.

Value

All except Play Controll and Value components

Displays the upper and lower limits for the component.
Limits
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DescriptionOption

All

The settings in this area allow you to format the text
for the selected text element.

Note:
If a global font is set for the document, you cannot
change the font type. For more information about
global fonts, see To set global font options.

Format Select-
ed Text

Allows you to set the position for some text ele-
ments relative to the component..Position

Allows you to adjust the position of some text ele-
ments by offsetting it relative to its set position.Offset

Allows you to set the number format for some text
elements.

Number For-
mat

Color tab

Use the following table as a guide for setting the Appearance properties on
the Color tab for single value components. To set the color for a component
element, click the Color Selector icon and from the "Color" dialog box, select
the color you want to use. Note that some options are only available for
specific component types.

DescriptionOption

Color tab

Gauge and Dial components only

Applies to the needle on the component.Needle Color

Gauge component only

Applies to the area surrounding the gauge face.
Frame Color
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DescriptionOption

Dial component only

Applies to the area surrounding the dial face.
Grip Color

Gauge component only

Applies to the center area of the gauge.
Center Color

Gauge, Dial, Spinner, and Value components

Set the color for the background area behind component
elements.

Background
Color

Gauge, Slider, Dial, Progress Bar, Value, and Play
Control components

Applies to the Play button background on the component.

Note:
This option is available only if, on the "Behavior"
view, Enable Play Button is selected.

Play Button
Color

Gauge, Slider, Dial, Progress Bar, Value, and Play
Control components

Applies to the symbol that appears on the Play Button.

Note:
This option is available only if, on theBehavior tab,
Enable Play Button is selected.

Play Symbol
Color

Slider, Progress Bar, and Play Control components
except the Dual Slider component.

Applies to the marker on the slider/progress bar.
Marker Color
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DescriptionOption

Dual Slider component only

Applies to the marker on the slider that shows the low
setting.

Low Marker
Color

Dual Slider component only

Applies to the marker on the slider that shows the high
setting.

High Marker
Color

Slider, Progress Bar, and Play Control components

Applies track area of the slider/progress bar.
Track Color

Gauge, Slider, Dial, Progress Bar, and Play Control
components

Applies to the color of the tick markers on the compo-
nent.

Tick Color

Gauge, Slider, Dial, Progress Bar components

Applies to the color behind the text that indicate the
current limits.

Note:
This is available only if, on the Behavior view, the
Minimum or Maximum Limit is set to Open.

Limits Back-
ground Color

Spinner component only

Applies to the Up button used to set the component's
value.

You can set a different color for the button background
and for the up symbol. You can also set different colors
for the default button (not pressed) and a pressed button.

Up Button
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DescriptionOption

Spinner component only

Applies to the Down button used to set the component's
value.

You can set a different color for the button background
and for the down symbol. You can also set different
colors for the default button (not pressed) and a pressed
button.

Down Button

Related Topics
• To set up Single Value components
• Single Value component behavior properties
• Single Value component general properties
• Single Value component alerts properties

Single Value component alerts properties

You can set up alerts for the following Single Value components:
• Vertical Slider
• Horizontal Slider
• Dual Slider
• Horizontal Progress Bar
• Dial
• Gauge
• Value
• Spinner

To set up alerts, select the component and open the Properties panel. Then
click the Alerts tab, select the Enable Alerts checkbox and set the alert
options. For more information about setting alert options, see Understanding
Alerts.
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Related Topics
• To set up Single Value components
• Single Value component general properties
• Single Value component behavior properties
• Single Value component appearance properties

Using Map components

Map components create models with geographical representations that can
display data by region.

The Map components have two major characteristics: they display data for
each region and each region can also act as a selector. By combining these
two features, you can create a model where the data for each region appears
when you pass the pointer over the region. At the same time, each region
can insert a row of data that contains additional information. This row of data
is displayed by other components, such as a chart or value component.

How does it work?

Xcelsius 2008 associates data with each region in the map by using region
keys. Each region in the map has a default region key, and you can enter
your own region keys. When a region on the map is selected, the component
searches either the first column or first row of that range's key. The data in
the row or column corresponding to the key is associated with the region.

By default, the USA maps use postal abbreviations as region keys; the Europe
map uses the ISO (or International Organization for Standardization) two-digit
country codes as region keys. To use the map components with existing
spreadsheets, you can edit the region keys associated with each region by
clicking the Manual Edit icon ( ) to type the new keys, or by clicking the
Cell Selector icon ( ) beside the Region Key box to select the row or
column containing the new keys by editing the region names.

Note:
In the spreadsheet you must enter the region keys and data in adjacent cells
for both Display Data and Source Data.
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Tip:
Xcelsius 2008 provides a spreadsheet that lists the default region codes for
each map component. The file is located in the following location:
C:\Program Files\Business
Objects\Xcelsius\assets\samples\User Guide Samples

To set up Map components

A list of values has been entered in the embedded spreadsheet.

1. Open the "Components" browser and drag a map component onto the
canvas.

2. Right-click the component and select Properties.
The "Properties" panel for the map component opens.

Note:
If the "Properties" panel has Auto-hide turned on, point to the Properties
tab to expand the panel.

3. On the "Properties" panel, click the General view and enter a title for the
component, then link the component to the data in the spreadsheet. For
more information about the available options, see Map general properties.
The component is updated with the changes.

4. Click the Behavior view and set the options for how the component
functions in the model including interaction options and dynamic visibility.
For more information about the available options, see Map behavior
properties.

5. Click the Appearance view and set the visual characteristics of each
component element. For more information about the appearance options,
see Map appearance properties.

6. If applicable, click the Alerts view to set up notifications that specified
values have been reached. For more information about alerts, see map
Alerts properties].

7. Click File > Save and enter a location and filename for the model. Click
OK.

The map component is added to the model and configured. To see how the
model is working, on the Toolbar, click Preview.
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Map general properties

Use the following table as a guide for setting the Map properties on the
General tab.

DescriptionOption

"Titles"

The title is centered at the top of the
component by default.

Note:
You can change the location and format
of the title on the Appearance tab.

Title

The region keys define the codes used
for each region in the map component.
These codes must be included in the
embedded spreadsheet and in the
range selected for Display Data and
Source Data. Each map has default
region keys set up. You can use the
default values or customize the codes
to correspond to your data.
• To see and modify the region keys,

click the Manual Edit icon.
• To assign codes from cells in the

embedded spreadsheet, click the
Cell Selector icon.

Region Keys
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DescriptionOption

The Display Data is associated with a
specific map region and, when a user
clicks region, the data displays. Click
the Cell Selector icon to select the a cell
from the embedded spreadsheet.

When you select the data range, you must
include the column or row that has the re-
gion codes. When Xcelsius searches for
the region code, it determines the number
of rows and columns in the table and does
one of the following:
• if it has 2 columns and more than 2

rows, it looks for the codes in the first
column.

• If it has 2 rows and more than 2
columns, it looks for the codes in the first
row.

• If it has 2 rows and 2 columns, it looks
in the first column and first row for the
greatest number of codes and uses that.

Display Data

This option determines how data is in-
serted when the user clicks a region.
You can select either rows or columns.

Insertion Type

This option specifies what data will be
inserted into the table when a region is
clicked. When you select the data range,
you must include the column or row that
has the region codes. Xcelsius uses the
region code to associate the data with
specific regions.

Click the Cell Selector icon to select the a
cell from the embedded spreadsheet.

Source Data
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DescriptionOption

This option specifies where the source
data will be inserted in the spreadsheet.
The selected cells must match the Inser-
tion Type and size of the source data.

Note:
The destination cells must be empty.

Destination

Related Topics
• To set up Map components
• Map behavior properties
• Map appearance properties
• Map alerts properties

Map behavior properties

Use the following table as a guide for setting the Behavior properties for
maps.

DescriptionOption

Common Tab

Specifies how the user selects a region. Select
either Mouse Click or Mouse Over.

Interaction Op-
tions

Specifies which region is selected when the
model runs and before the user makes a selection.

Default Select-
ed Region

This option allows you to specify conditions that
control when the map appears in the model. For
more information about using dynamic Visibility,
see Managing the Visibility of Components.

Dynamic Visibil-
ity

Animations and Effects Tab
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DescriptionOption

If dynamic visibility is enabled, select how you
want to the chart to appear on the canvas when
triggered. You can select an entry effect and
specify how long you want to components appear-
ance to take and, for some selectors, whether the
component makes a sound when it appears. For
more information about dynamic visibility, see
Managing the Visibility of Components.

Entry Effect :
Type

Related Topics
• To set up Map components
• Map general properties
• Map appearance properties
• Map alerts properties

Map appearance properties

Use the following table as a guide for setting the Appearance properties for
Map components.

DescriptionOption

Layout Tab

Specifies how clearly objects behind the
map can be seen. Set the slider to a
value between 0 and 100 where 0 is not
transparent at all and 100 is completely
transparent.

Transparency

Text Tab
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DescriptionOption

Displays a title for the map. Select the
checkbox in the Show column to dis-
plays this option. To format the text ap-
pearance, select this item and enter the
format settings.

Title

Displays titles when the user moves the
mouse pointer over an areas of the map.
Select the checkbox in the Show col-
umn to displays this option. To format
the text appearance, select this item and
enter the format settings.

Mouse-over Titles

Displays titles when the user moves the
mouse pointer over an areas of the map.
Select the checkbox in the Show col-
umn to displays this option. To format
the text appearance, select this item and
enter the format settings.

Mouse-over Labels

The settings in this area allow you to
format the text for the selected text ele-
ment.

Note:
If a global font is set for the document,
you cannot change the font type. For
more information about global fonts, see
To set global font options.

Format Selected Text

Allows you to set the position for some
text elements relative to the component..Position

Allows you to adjust the position of
some text elements by offsetting it rela-
tive to its set position.

Offset
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DescriptionOption

Allows you to set the number format for
some text elements.Number Format

Color Tab

Applies to regions that are not associat-
ed with data in the spreadsheet and
cannot be selected.

Default Color

Applies to regions when the mouse
pointer moves over them.Over Color

Applies to the region that is selected.Selected Color

Applies to regions that are associated
with data in the spreadsheet and can
be selected.

Selectable Color

Applies to the borders between regions.Border Color

Related Topics
• To set up Map components
• Map general properties
• Map behavior properties
• Map alerts properties

Map alerts properties

You can set up alerts for all Map components.

To set up alerts, select the component and open the "Properties" panel. Then
click the Alerts view, select the Enable Alerts checkbox and set the alert
options. For more information about setting alert options, see Understanding
Alerts.
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Related Topics
• To set up Map components
• Map general properties
• Map behavior properties
• Map appearance properties

Using the Text components

This category contains components for placing labels and typing text into
your model.

Text components let you customize your model. Not only can you insert static
text to identify areas and elements of your model, but you can also link the
text components to cells in the embedded spreadsheet that contain formulas
that will dynamically change the text displayed in the model based on the
formula result. In addition, formulas can contain html code to increase your
formatting options.

Xcelsius 2008 includes the following Text-based components:

Input Text Area

The Input Text Area lets users input multiple lines of text into the model.

Label

The Label component lets you add an unlimited amount of text to enhance
your models. You can use the Label component to create titles, subtitles,
explanations, help, and more. Label text cannot be changed by the user.
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Input Text

The Input Text component lets users type text into the model.
Related Topics
• To set up Text components

To set up Text components

A list of values is entered in the embedded spreadsheet.

1. Open the "Components" browser and drag a text component onto the
canvas.

2. Right-click the component and select Properties.
The "Properties" panel for the text component opens.

Note:
If the "Properties" panel has Auto-hide turned on, point to the Properties
tab to expand the panel.

3. On the "Properties" panel, click the General view and specify the text to
display as well as a destination to insert data. For more information about
the available options, see Text general properties.
The component is updated with the changes.

4. Click the Behavior view and set the options for how the component
functions in the model including character limits, scroll bar options, and
dynamic visibility. For more information about the available options, see
Text behavior properties.

5. Click the Appearance view and set the visual characteristics of each
component element. For more information about the appearance options,
see Text appearance properties.

6. Click File > Save and enter a location and filename for the model. Click
OK.

The text component is added to the model and configured. To see how the
model is working, on the Toolbar, click Preview.
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Text general properties

Use the following table as a guide for setting the Text properties on the
General tab.

DescriptionOption

All

This option allows you to link the component to a cell
in the embedded spreadsheet. Changes to the data in
the cell are reflected in the Text component. You can
use this option to set dynamic labels by defining formu-
las that update based on data or user selections in the
model.

Link to a Cell

Label component only

If you link the label to a cell, select this option if you
want the label to apply the same Formatting as is set
for the cell in the embedded spreadsheet.

Use Spread-
sheet Format-
ting

All

This option allows you to manually enter text to display
in the component when the model runs.

Enter Text
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DescriptionOption

Label and Input Text Area components only

Select this option to enable the use of HTML codes for
text Formatting. These text components support the
following HTML codes:
• Anchor tag (<a>)
• Bold tag (<b>)
• Break tag (<br>)
• Font tag (<font>)
• Image tag (<img>)
• Italic tag (<I>)
• List item tag (<li>)
• Paragraph tag (<p>)
• Text format tag (<textformat>)
• Underline tag (<u>)

Note:
If you intend to export your model to PowerPoint and
include a link in the text with HTML formatting, you
must include target="_blank" in your link tag so
PowerPoint opens the link in a new window. For exam-
ple, <a href="http://www.google.com"tar
get="_blank">. If you don't include the target setting,
users can open the link in PowerPoint if they right-click
the link and select Open in new window.

Enable HTML
Formatting

Input Text and Input Text Area components

Select this checkbox to insert the default text into the
destination cell when the model loads.

Insert Data on
Load
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DescriptionOption

Input Text and Input Text Area components

This option specifies where the source data will be in-
serted in the spreadsheet.

Note:
The destination cells must be empty.

Destination

Related Topics
• To set up Text components
• Text behavior properties
• Text appearance properties

Text behavior properties

Use the following table as a guide for setting the Behavior properties for
text-based components.

DescriptionOption

Common Tab

Input Text and Input Text Area components
only

If this option is selected, the input is treated as
text, which will preserve leading zeros. Text is
not available for use in formulas or calculations.

If this option is not selected, the input is treated
as numeric input, which allows it to be used for
calculations or formulas, but will remove leading
zeros in the display and in the associated cell in
the embedded spreadsheet.

Treat All Input as
Text
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DescriptionOption

Input Text component only

Select this option to display typed characters as
asterisks (*), Use this option to create password
entry and protect the password from being dis-
played on the screen.

Enable Password
Protection

Input Text and Input Text Area components
only

Use this option to specify set a limit for the
number of characters users can enter.

Maximum Number of
Characters

Input Text component only

This option allows you to control which charac-
ters users can enter into the component. By de-
fault, all characters are allowed. For more infor-
mation about defining allowed and not allowed
characters, see Restricting characters in text-
based components

.

Characters Allowed
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DescriptionOption

Input Text Area and Label components only

If the text exceeds the width of the text area, a
scroll bar allows users to move through the text.
Select one of the following options:

DescriptionOption

The horizontal scroll bar is always
visible.On

The horizontal scroll bar is never
available.Off

The horizontal scroll bar appears
if the text exceeds the width of the
text area and disappears if the text
is within the available area.

Auto

Horizontal Scroll Bar

Input Text Area and Label components only

If the text exceeds the height of the text area, a
scroll bar allows users to move through the text.
Select one of the following options:

DescriptionOption

The vertical scroll bar is always
visible.On

The vertical scroll bar is never
available.Off

The vertical scroll bar appears if
the text exceeds the height of the
text area and disappears if the text
is within the available area.

Auto

Vertical Scroll Bar
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DescriptionOption

Dynamic Visibility

All

This option allows you to specify conditions that
control when the text component appears in the
model. For more information about using dynam-
ic Visibility, see Managing the Visibility of Com-
ponents.

Animations and Effects Tab

All

If dynamic visibility is enabled, select how you
want to the chart to appear on the canvas when
triggered. You can select an entry effect and
specify how long you want to components ap-
pearance to take. For more information about
dynamic visibility, see Managing the Visibility of
Components.

Entry Effect : Type

Related Topics
• To set up Text components
• Text general properties
• Text appearance properties

Restricting characters in text-based components
If you use Input Text component in which users can enter text, for example,
to enter a password, you can specify the characters that can be entered and
those that cannot. By default, the component allows users to enter any
character.

To limit the allowed characters:
1. On the component properties panel, click Behavior > Common .
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1. In the Characters Allowed box, type the allowed and not allowed
characters or click the Cell Selector icon ( ) to select a cell in the
spreadsheet that contains the values.

When defining the characters allowed, use the following conventions:
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ConventionEffect

Type the characters, for example,
abcABC

Allow specific characters

Precede the characters with a carat
(^), for example, ^abcABC

Disallow specific characters

Separate the first and last character
with a dash (-), for example, a-zA-Z

Allow a range of characters

Surround the disallowed characters
with carats (^), for example,
abc^def^gh indicates that "abcgh"
are allowed and "def" are not al-
lowed.

Switch between allowed and
disallowed characters

Precede these special characters
with a backslash (\), for example,
\^\-\\

Allow or disallow a carat (^),
dash (-), or backslash (\)
character

Some common characters sets in-
clude:
• Whole numbers including nega-

tive numbers: \-0-9
• Real numbers including negative

numbers: \-0-9.
• Fractions: \-/0-9
• Positive whole numbers: 0-9
• Positive real numbers: 0-9.
• Letters: a-zA-Z
• Numbers and Letters: 0-9a-zA-Z

Use common character sets

Related Topics
• Text behavior properties
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Text appearance properties

Use the following table as a guide for setting the Appearance properties for
text-based components. Note that some options are available only for specific
component types.

DescriptionOption

Layout Tab

Input Text Area component only

If selected, lines of text that are longer than the width
of the text area wrap to the next line.

Wrap Text

Label component only

Specifies whether objects behind the component are
visible. A transparency of 0 means that users cannot
see objects behind the component. A transparency of
100 means that the component is completely transpar-
ent and invisible to users.

Transparency

Label component only

Select the border side (Top, Bottom, Left, Right, or All
Sides) and then set the format options: Show Border
and Border Thickness.

Draw Border On

Label component only

For the border side selected in Draw Border On, se-
lect this option to show a border.

Show Border

Label component only

For the border side selected in Draw Border On, se-
lect a thickness for the line from 1 to 100.

Border Thick-
ness
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DescriptionOption

Label component only

If selected, the label has a solid background. You can
set the fill color on the Color tab.

Show Fill

Text Tab

Label component only

The settings in this area allow you to format the text
for the selected text element.

Note:
If a global font is set for the document, you cannot
change the font type. For more information about
global fonts, see To set global font options.

Format Select-
ed Text

Allows you to set the position for some text ele-
ments relative to the component.Position

Allows you to adjust the position of some text ele-
ments by offsetting it relative to its set position.Offset

Allows you to set the number format for some text
elements.Number Format

Color Tab

All

Applies to the background area behind the text.
Background
Color

Input Text Area and Label component only

Set the color for the parts of the scroll bar.
Scroll Bar
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DescriptionOption

Label component only

Applies to the background area behind the text.

Note:
This option is available if Show Fill is selected
on the Layout tab.

Labels Back-
ground : Fill
Color

Related Topics
• To set up Text components
• Text general properties
• Text behavior properties

Using the Other components

This category contains an assorted set of components that you can use to
enhance your models. Xcelsius 2008 includes the following Other
components:

Calendar

The Calendar component is a selector that lets you incorporate date selection
into your models.
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Note:
This component is not available in Xcelsius Present.

Local Scenario Buttons

The Local Scenario Button lets users save and load runtime configurations
of an Xcelsius 2008 model on their local machine. Once saved, these
configurations or scenarios can be loaded again, even after closing the model.
The user also has the option to set a saved scenario as the default scenario
so it loads when the model opens. These scenarios are saved to the local
machine, and will be unavailable if the model is opened on a different
machine.

Trend Icon

The Trend Icon changes its pointing direction, depending on the value of the
cell to which it is linked:

• If the value is positive, the arrow points up.

• If the value is zero, the symbol is neutral.

• If the value is negative, the arrow points down.

History

The History component tracks and displays the history of changes in a
selected cell. This allows you to easily see the effect of changes in worksheet
data.

Note:
This component is not available in Xcelsius Present.
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Panel Set

The Panel Set component is a series of framing options that enables you to
easily navigate between files in a presentation. You can embed JPEG or
SWF files into the frames of the Panel Set component and adjust a variety
of formatting features to customize the look of the component in your model.

Note:
This component is not available in Xcelsius Present.

Source Data

The Source Data component has no visual interface. It allows you to push
data into other cells simply by changing the value of the component's Selected
Index.

Note:
This component is not available in Xcelsius Present.

Trend Analyzer

The Trend Analyzer combines data analysis and model. The component
analyzes spreadsheet data and inserts data points for a trend line into the
spreadsheet, which can then be added to your model. You can also configure
this component to forecast based on historical values.

Note:
This component is not available in Xcelsius Present.
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Print Button

The Print Button allows users to easily print the model while it is running.
The user can click the Print button to print the SWF file. The Print button is
part of the canvas and will be visible in the printout.

Reset Button

The Reset Button returns the model to its original state. Users can interact
with the components, then click the button to clear their changes.

Grid

The Grid component is a dynamic table that represents a group of rows and
columns of content. The Grid lets you show the data just as it is on any table,
or perform data modification that can impact other components.

The Grid component differs from the Spreadsheet and List View components
in that rather than being a static representation of the data table, the user
can click the cells of the Grid and type new values or drag the values
higher/lower

Note:
This component is not available in Xcelsius Present.

Other component general properties

Use the following table as a guide for setting the properties on the General
view for Other components.
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DescriptionOption

Calendar and Panel Set components only

The title is centered at the top of the component by default.

Type the text in the box or click the Cell Selector icon to
select the title text from the embedded spreadsheet.

Note:
You can change the location and format of the title
on the Appearance view.

Title

Local Scenario Button, Print Button, and Reset Button
components only

This option defines the text that appears on the button.

Type the text in the box or click the Cell Selector icon to
select the label text from the embedded spreadsheet.

Label

Panel Set component only

These titles appear on each frame of the panel set.

Click the Cell Selector icon to select the label text from
the embedded spreadsheet or click the Manual Edit icon
to type the label text.

Panel Titles

Panel Set component only

From the list, select the option that represents the number
and arrangement of panels you desire.

Layout

Panel Set component only

The number of panels in the list corresponds to the option
selected in Layout. Select each panel and set the content
options.

Content :
Panels
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DescriptionOption

Panel Set component only

This option specifies the type of information provided in
the selected panel. Select one of the following options:

DescriptionOption

The panel is blank.None

Saves a copy of the file with the model.
Click the Import button to specify the
location of the file to embed.

Embedded
JPEG or
SWF

References external JPEG or SWF files
at a URL location. Click the Cell Selec-
tor icon to select the URL from the em-
bedded spreadsheet or click the Manual
Edit icon ( ) to type the URLs manu-
ally.

By URL

Content
Type

Panel Set component only

This option specifies items to display in the list for the se-
lected panel.

Click the Cell Selector icon to select the label text from
the embedded spreadsheet or click the Manual Edit icon
( ) to type the label text.

Drop-Down
Menu La-
bels

189

Working with Components



DescriptionOption

Calendar and Source Data components only

This option specifies the type of information that is inserted
when a selection is made. Select one of the following op-
tions:

For Calendar components:
• Day - inserts the select day, for example, April 7 is en-

tered as "7".
• Date - inserts the Excel formatted date, for example,

April 7, 2010 is entered as "04/07/2010".

For Source Data components:
• Value - inserts the value from a single cell.
• Row - inserts the values in a row of data.
• Column - inserts the values in a column of data.

Insertion
Type

Source Data component only

Specifies the location of the source data for selections.
Click the Cell Selector icon to select the range from the
spreadsheet.

Source Data

Calendar and Source Data components only

Specifies the location in the spreadsheet where the data
will be inserted. Click the Cell Selector icon to select the
range in the spreadsheet.

Note:
The required size of the destination range varies ac-
cording to the structure selected in Insertion Type.
For structures that use columns or rows of data, be
sure to select a range that is large enough to contain
your largest column or row of data.

Destination
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DescriptionOption

Calendar component only

Specifies the location in the spreadsheet to insert the
month value for the selected date.

Month Desti-
nation

Calendar component only

Specifies the location in the spreadsheet to insert the year
value for the selected data.

Year Desti-
nation

Trend Analyzer, Grid, Trend Icon, and History compo-
nents only

Specifies the source data that the component will use.
Click the Cell Selector icon to select the range in the
spreadsheet.

For the Grid component, a value is displayed for each cell
selected and values are arranged in the same order as in
the spreadsheet. Changes to the spreadsheet values are
reflected in the Grid and changes to the Grid values are
reflected in the Spreadsheet and may affect other compo-
nents linked to those cells.

For the Trend Icon component, if the value in this cell is
greater than 0, the component displays an up arrow. If the
values is less than 0, it displays a down arrow, and if it
equals 0, it displays a neutral symbol.

Data

Grid component only

This option specifies a lower limit to the values entered
into the grid. Type the limit in the box or click the Cell Se-
lector icon to select the limit amount from the embedded
spreadsheet.

Minimum
Limit

191

Working with Components



DescriptionOption

Grid component only

This option specifies an upper limit to the values entered
into the grid. Type the limit in the box or click the Cell Se-
lector icon to select the limit amount from the embedded
spreadsheet.

Maximum
Limit
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DescriptionOption

Trend Icon component only

This option specifies the colors that represent the overall
trend. Click the Color Picker icon beside each of the follow-
ing options and select a color.

DescriptionOption

Indicates the data value is greater
than 0.

Positive Value
Color

Indicates the data value is equal to
0.

Zero Value Col-
or

Indicates the data value is less
than 0.

Negative Value
Color

Colors

History component only

This option specifies the location where the history data
will be inserted.

Note:
The number of cells in this range determines the
number of data changes retained for historical
records. Once the limit is reached, the oldest data
change is overwritten. If the range is a single column,
with multiple rows, the newest data is inserted in the
bottom cell bumping older data up one row. If the
range is a single row with multiple columns, the
newest data is inserted in the right-most cell bumping
older data left one column. If the range has multiple
rows and multiple columns, the newest data is insert-
ed in the right-most column's bottom cell and older
data I bumped left to the limit of the range and then
up one row to the right most column in a zigzag pat-
tern.

Data Desti-
nation
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DescriptionOption

History component only

Select this option to record the cell history each time the
value in the cell changes.

When Value
Changes

History component only

Select this option to record the cell history at regular inter-
vals. In the Duration (seconds) box, enter the interval du-
ration.

On Interval

Other component behavior properties

Use the following table as a guide for setting the Behavior properties for
other components. Note that some options are available only for specific
component types.

DescriptionOption

Common Tab

Calendar component only

The option specifies the date the calendar will use
when the model loads and before the user selects a
date. Select one of the following options:
• Use current date - the calendar loads with the cur-

rent date.
• Use custom date - the calendar loads with a specific

date selected. Enter values for Day, Month, and
Year.

Default Date
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DescriptionOption

Calendar component only

This option allows you to control the date range avail-
able for the Calendar component. If you select this
option, enter values for Start Month, Start Year, End
Month, and End Year to define the range available.

Enable Calen-
dar Limits

Grid component only

If Enable Interaction is selected, select this option to
restrict the increment that can be entered. The entered
number will round to the nearest increment, for exam-
ple, for dozens.

Increment

Grid component only

If Enable Interaction is selected, this option allows
you to restrict the lowest number that can be entered
for grid items. This setting is based on the Scale Min-
imum Limit on the General tab. Select one of the fol-
lowing options:
• Open - users can enter values that are less than

the Scale Minimum Limit.
• Fixed - users cannot enter values that are less than

the Scale Minimum Limit.

Minimum Limit
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DescriptionOption

Grid component only

If Enable Interaction is selected, this option allows
you to restrict the lowest number that can be entered
for grid items. This setting is based on the Scale
Maximum Limit on theGeneral tab. Select one of the
following options:
• Open - users can enter values that are greater than

the Scale Maximum Limit.
• Fixed - users cannot enter values that are greater

than the Scale Maximum Limit.

Maximum Limit

Grid component only

Select this option to allow users to enter values on the
grid.

Note:
If grid cells are linked to spreadsheet cells that
contain formulas, users are unable to enter values
regardless of this setting.

Enable Interac-
tion

Grid component only

If Enable Interaction is selected, this option deter-
mines how sensitive the component is to mouse
movements. When the setting is high, small pointer
movements can change the value by large increments.
When the setting is low, pointer movements change
the value by small increments.

Mouse Sensitiv-
ity
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DescriptionOption

Grid component only

If Enable Interaction is selected, this option deter-
mines the action required to change the value. Select
one of the following options:
• Manual - the user drags the point above or below

the component to change the value. For each incre-
ment of change, the user must continue to drag the
pointer.

• Auto - The user drags the pointer and places it
above or below the component to adjust the value.
While the mouse button is pressed, the value con-
tinues to change without requiring further pointer
movement.

Scroll Behavior

Panel Set component only

Select this option to allow users to expand a single
panel so it covers the other panels and then minimize
it back to its original size. This feature is useful when
you want to emphasize different sets of data at different
times during a presentation.

Enable Maxi-
mize Button

Panel Set component only

If Enable Maximize Button is selected, this option
specifies how fast panels expand and contract. Move
the marker along the slider to set the speed.

Zoom Speed

Panel Set component only

This option specifies which panel is selected when the
model loads.

Selected Item :
Panel
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DescriptionOption

Panel Set component only

This option specifies which content item displays in
the selected panel when the model loads.

Selected Item :
Item

Panel Set component only

Select In Values to prevent empty values past the last
non-empty value from being displayed in the Panel Set
component. This option allows a variable amount of
data to be displayed in the Panel Set.

Ignore Blank
Cells

Print Button component only

This option specifies how the model scales when
printing. Select one of the following options:
• Scale To - scales to a specific percentage. Select

the percentage from the list.
• Scale to Fit Page - scales to fit within the paper

size.

Print Scale

Source Data component only

This option specifies the index for the source data
component. When the value in this cell changes, the
source data component pushes that value to other
components.

Selected Item
Index

All

This option allows you to specify conditions that control
when the component appears in the model. For more
information about using dynamic Visibility, see Manag-
ing the Visibility of Components

.

Dynamic Visibil-
ity

Animations and Effects Tab
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DescriptionOption

All

If dynamic visibility is enabled, select how you want to
the chart to appear on the canvas when triggered. You
can select an entry effect and specify how long you
want to components appearance to take and, for some
selectors, whether the component makes a sound
when it appears. For more information about dynamic
visibility, see Managing the Visibility of Components

Entry Effect :
Type

Other component appearance properties

Layout tab

Use the following table as a guide for setting the Appearance properties on
the Layout tab for other components. Note that some options are available
only for specific component types.

DescriptionOption

Layout Tab

Local Scenario Button, Print Button, and Reset
Button components only

Specifies whether the background behind the buttons is
visible. If selected for the Print Button and Reset Button
components, you can set the transparency level for the
background.

Show Button
Background

Panel Set component only

If selected, a header displays above each panel in the
set and includes the panel title, list, and minimize or
maximize buttons.

Show Panel
Headers
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DescriptionOption

Panel Set component only

Specifies the number of labels displayed by default in
the list.

Number of
Labels Dis-
played

Panel Set component only

Determines the visibility of the area behind the panels.
Adjust the marker on the slider bar to the desired trans-
parency level.

Background
Transparency

Grid component only

This setting modifies the amount of space between each
row in the grid.

Vertical Mar-
gin

Grid component only

This setting modifies the amount of space between each
column in the grid.

Horizontal
Margin

Text tab

Use the following table as a guide for setting the Appearance properties on
the Text tab for other components. Note that some options are available
only for specific component types.

DescriptionOption

Text Tab

Calendar, Grid, Panel Set, Print Button, Local Sce-
nario, and Reset Buttons only

Lists the elements that can have text appear on the
component. To hide the text for an element, deselect it.

Show Text
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DescriptionOption

Calendar, Grid, Panel Set, Print Button, Local Sce-
nario, and Reset Buttons only

The settings in this area allow you to format the text for
the selected text element.

Note:
If a global font is set for the document, you cannot
change the font type. For more information about global
fonts, see To set global font options.

Format Se-
lected Text

Color tab

Use the following table as a guide for setting the Appearance properties on
theColor tab for other components. To set the color for a component element,
click the Color Selector icon and from the "Color" dialog box, select the color
you want to use. Note that some options are only available for specific
component types.

DescriptionOption

Color Tab

Calendar, Grid, and Panel Set components only

Applies to the background area behind component ele-
ments.

Background
Color

Calendar component only

Applies to the heading bar that contains the month name.
Month Color

Calendar component only

Applies to the heading bar that contains the days of the
week.

Day of the
Week Color
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DescriptionOption

Panel Set component only

Applies to the background area on each panel.
Panel Back-
ground

Panel Set component only

Applies to the panel header color.
Label Head-
er

Panel Set component only

Applies to the text color for items in the drop-down list.

You can set a different color for when the item is not active
(Default color), when the mouse pointer is over the item
(Over Color), and when the item is selected (Selected
Color).

Labels

Panel Set component only

Applies to the background color behind items in the drop-
down list.

You can set a different color for when the item is not active
(Default color), when the mouse pointer is over the item
(Over Color), and when the item is selected (Selected
Color).

Label Back-
ground

Calendar component only

Applies to the text color for the dates in the month.

You can set a different color for when the date is not active
(Default color), when the mouse pointer is over the date
(Over Color), and when the date is selected (Selected
Color).

Date Text
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DescriptionOption

Calendar component only

Applies to the area behind the dates.

You can set a different color for when the date is not active
(Default color), when the mouse pointer moves over the
date (Over color), and when the date is active (Selected
Color).

Date Back-
ground

Calendar and Panel Set components only

Applies to buttons on the component. Depending on the
component, you can set a different color for the following
elements:
• the button background for active, pressed, or disabled

buttons
• the symbol for active, pressed, or disabled buttons
• the button label for default and pressed buttons

Buttons

Print Button, Local Scenario Button, and Reset Button
components only

Applies to the button color.

You can set a different color for when the button is pressed
and when it is not.

Button

Print Button, Local Scenario Button, and Reset Button
components only

Applies to the text color on the button.

You can set a different color for when the button is pressed
and when it is not.

Labels

Panel Set component only

Set the color for the parts of the scroll bar.
Scroll Bar
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Other component alerts properties

You can set up alerts for the Grid components.

To set up alerts, select the component and open the Properties panel. Then
click the Alerts tab, select the Enable Alerts checkbox and set the alert
options. For more information about setting alert options, see Understanding
Alerts.

To configure Trend Analyzer components

A Trend Analyzer component has been placed on the canvas.

Use the Trend Analyzer component to analyze spreadsheet data and identify
a trend in the data. You can also configure the Trend Analyzer to forecast
future trends based on the existing data. The resulting trend and forecast
data can then be added to a component in your model.
1. Select the Background component and open the "Properties" panel.
2. On the General view, set the following options:
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DescriptionOption

Specifies the source data that the component will
use. Click the Cell Selector icon to select the range
in the spreadsheet.

Data

This option specifies the pattern the data might
conforms to. Select an appropriate trend type from
the list or select Use Best Fit to have Xcelsius pick
the curve type that best fits the data. If you select
Polynomial, in Order (Polynomial only) list, select
the desired polynomial order from 2 to 6.

Trend/Regres-
sion Type

Specifies the location in the spreadsheet to insert
the analyzed data.

Analyzed Da-
ta Destina-
tion

If the number of cells in the Analyzed Data Desti-
nation range is greater than the number of cells
in the Data range, specify the number of periods
you want to forecast. Type a number in the box or
click the "Cell Selector" icon to bind this value to
a cell in the spreadsheet.

Tip:
If you bind this value to a cell in the spreadsheet
and link that cell to another component, you can
use that component to specify the number of peri-
ods to forecast within the set range.

Number of
ForecastPeri-
ods

To see this option, click More.

Specifies a location for the type of equation used to
analyze the data.

Equation
TypeDestina-
tion
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DescriptionOption

To see this option, click More.

Specifies a location for the equation used to analyze
the data.

Equation
Destination

To see this option, click More.

Specifies a location for the R2 value for the analysis.

R2 Value
Destination

To see this option, click More.

Specifies a location for the F value for the analysis.

F Value Desti-
nation

3. Click the Behavior view to set dynamic visibility options. For more
information about dynamic visibility, see Managing the Visibility of
Components.

Using Art and Background components

Art and background components provide visual enhancements for models.
You can use them to enhance and customize your dashboards. The
background components can also be used to import images or Flash movies
into your models.

Xcelsius 2008 includes the following Art and Background components:

Background

Backgrounds are prebuilt artwork that you can add to your models. You can
use them to create visual divisions or groups of related components. Unlike
Container components, backgrounds cannot contain or hold other
components. They simply provide a visual background.
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Ellipse

The Ellipse or Oval component allows you to create visual divisions or outlines
to define or contain sections or components.

Image Component

Use this component to display JPEG images or SWF files. The Image
component allows you to add your own logos or artwork to models. You can
also import Flash files into this component to add videos, animations, and
other interactive elements.

Line

The Vertical or Horizontal Line component allows you to create visual
divisions or outlines to define or contain sections or components.

Rectangle

The rectangle component allows you to create visual divisions or outlines to
define or contain sections or components.

To configure Background components

A Background component has been placed on the canvas.
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Use the Background component to change the appearance of your model.
You can apply different backgrounds to different area to visually group items.

Tip:
You can also use the Background component to control user ability to interact
with other components. To do that, place the Background component over
the other item. Set the Background component to 100% transparency and
enable Block Mouse Actions. At runtime, users will not be able to click or
change values on the underlying component. For more information, see
Disabling User Input.

1. Select the Background component and open the "Properties" panel.
2. On the General view, set the following options:
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DescriptionOption

Click the Color Selector icon to select a color for the
background. For more information about using the
Color Selector tool, see Setting colors for component
elements.

Back-
ground
Color

To allow components behind the background to be
visible to users, move the slider to the right to in-
crease the transparency of the component. To hide
items behind the background, move the slider to the
left.

Transparen-
cy

Sets the thickness of the border around the back-
ground. Move the slider to the right to increase the
border thickness.

Border
Scale

If the Image component is placed over other compo-
nents, selecting this option prevents users from using
the mouse to interact with the underlying compo-
nents. For more information, see Disabling User In-
put.

Note:
For imported SWF files, mouse events are blocked
even if this option is not selected.

Block
Mouse
Events

3. Click the Behavior view to set dynamic visibility options. For more
information about dynamic visibility, see Managing the Visibility of
Components.

To configure Image components

An Image component has been placed on the canvas.

If you want to add images, videos, animations, or other interactive elements,
you can import them into the Image component. This allows you to add your
own logos and artwork to models. You can even insert another exported
Xcelsius model.
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Note:
The Image component supports standard RGB JPG file formats and SWF
files. It does not support progressive JPGs or JPGs with CMYK color profiles.

When you add an image to a model, you can choose to embed the file in the
SWF file or reference the external file. Files that are not embedded, are
saved to a folder with the same name and location as the exported model
and are loaded as needed. For the model and external files to load correctly,
the folder and external files must be in the same folder location as the
exported model.

Inserted SWF files may have external assets such as other SWF files, images,
or XML files. If these assets are referenced with relative paths, those paths
must be available from the location where the host model is run. For example,
if a SWF file located at z:\file.swf loads an external image from
z:\images\myImage.jpg, and you add that SWF file to your model at
c:\visualization.xlf. When you open your model, the added SWF file will
attempt to load the referenced image from c:\images\myImage.jpg, which is
the relative location from the model's location.

Caution:
If a model references an external file, when the model runs, Adobe security
restrictions apply. When the model is run locally, the SWF file or the host
application file must be made trusted. If the file is run on a web server, there
must be a cross-domain policy file. For more information, see Adobe Flash
Player Security Restrictions.

Use the Image component to add JPEG images (standard RGB format only)
and SWF files to models. For example, you could add your own logos or
artwork, as well as videos, animations, and other interactive elements. You
could even add another exported Xcelsius model.

Note:
The Image component does not support Progressive JPEGs or JPEGs with
CMYK coloring.

1. Select the Image component and open the "Properties" panel.
2. On the General view, before you import an image file, specify the Resize

Image to Component option. When the image is imported, its size is set
according to this setting. If you select this option, the image size is
adjusted to fit within the size of the Image component. If this option is not
selected, the Image component size is adjusted to fit the actual size of
the image.
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3. Under JPG or SWF Options, click Import.
4. On the "Open" dialog box, navigate to the JPG or SWF file and click

Open.
5. Set the following options:
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DescriptionOption

Select this file to add a copy of the image file to the
model. If you embed the image it becomes part of
the Xcelsius SWF file and is always available. It will
add to the size of the SWF file and may affect perfor-
mance. If this option is not selected, the image file
is loaded when the user views it.

Note:
You can load an Xcelsius SWF file into the image
component, but you cannot embed the file in the
model.

Embed File

Use this option to allow objects behind the Image
component to be seen through the components.
Move the slider to the right to increase its transparen-
cy and move it to the left to reduce its transparency.

Transparen-
cy

If the Image component is placed over other compo-
nents, selecting this option prevents users from using
the mouse to interact with the underlying compo-
nents. For more information, see Disabling User In-
put.

Note:
For imported SWF files, mouse events are blocked
even if this option is not selected.

Block
Mouse
Events

For imported SWF files, select this option to make
the SWF background invisible. If this option is not
selected, the SWF background can be seen in the
model.

Hide SWF
Back-
ground
Color

6. Click the Behavior view to set dynamic visibility options. For more
information about dynamic visibility, see Managing the Visibility of
Components.
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Embedding vs. referencing external files
When you import image or Flash files into the Image component, you can
embed the file or reference it in an external location. Each option has its own
advantages and disadvantages. The following table describes the differences
between embedding external files in the model and referencing them.

Referenced FilesEmbedded Files

The external file is copied to a
folder with the same name and
location as the exported SWF
file.

The external file is built into the
SWF file when the model is im-
ported.

The model (either XLF or SWF)
must be distributed along with
the external file folder, and the
folder and external file must re-
main in the same relative location
to the model.

The model (either XLF or SWF)
can be distributed as a single file.

The external file loads as need-
ed. If it is hidden through dynam-
ic visibility, the file isn't loaded.

The external file loads when the
model loads, even if it is hidden
through dynamic visibility.

The model loads quickly because
it doesn't have to load the exter-
nal file immediately.

The model take longer to load
because it has to load the exter-
nal file as well.

If dynamic visibility is configured
to load external files, it takes
longer to show hidden compo-
nents because it has to load the
external files first.

If dynamic visibility is configured
to load external files, it works
faster because the files are al-
ready loaded.

When hidden with dynamic visi-
bility, external files are closed
and revert to their default state.

When hidden with dynamic visi-
bility, external files maintain their
state.
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Referenced FilesEmbedded Files

If the external file changes, it can
be replaced in the external file
folder and the model will load it
without having to re-export the
model.

If the external files changes, the
model must be re-exported.

To configure Ellipse or Rectangle components

An Ellipse or Rectangle component has been placed on the canvas.

Use the Ellipse or Rectangle components to change the appearance of your
model. You can add these shapes to different areas of the canvas to visually
group items.
1. Select the component and open the "Properties" panel.
2. On the General view, under the "Enable Border" area, set the following

options:

DescriptionOption

Select this option display an outline around the
shape.

Enable
Border

If Enable Border is selected, click the Color Selector
icon to set the border color.

Color

If Enable Border is selected, type or select a border
thickness from the list.

Thickness

If Enable Border is selected, to allow components
behind the border to be visible, move the slider to
the right to increase the transparency of the border.
To cover items behind the border, move the slider
to the left.

Transparen-
cy

3. Under the Fill area, set the following options:

214

Working with Components



DescriptionOption

From the list select one of the following options:
• None - the shape has no fill and is completely

transparent.
• Solid - the shape is filled with a solid color.
• Linear (gradient) - the shape color changes from

one side to the other.
• Radial (gradient) - the shape color changes from

the center of the shape to the edge.

Type

If Type is not set to None, click the Color Selector
icon to select the color for the shape or gradient.

Color

If Type is not set to None, to allow components be-
hind the shape to be visible, move the slider to the
right to increase the transparency of the shape fill.
To cover items behind the shape, move the slider to
the left.

Transparen-
cy

If Type is set to Linear (gradient) or Radial (gradi-
ent), this Preview panel illustrates how the color
transitions for the gradient. To adjust the gradients
in the shape, do any of the following:
• To add another gradient, move the mouse over

the Preview panel and, when you see a Plus icon,
click the panel.

• To change start or end positions of the gradient,
drag the gradient markers that are below the
Preview panel.

• To change the color of a gradient. click the gradi-
ent marker below the Preview panel, then click
the Color Selector icon and select a color.

• To change the transparency of a gradient, click
the gradient marker below the Preview panel, then
on the Transparency slider, move the marker to
increase or decrease the visibility.

Gradient
Preview
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DescriptionOption

Rotation If Type is set to Linear (gradient), use this option
to adjust the gradient axis. Enter a value between 0
and 360 to rotate the gradient axis.

4. Click the Behavior view to set dynamic visibility options. For more
information about dynamic visibility, see Managing the Visibility of
Components.

Related Topics
• Setting colors for component elements

To configure Line components

A Line component has been placed on the canvas.

Use the Horizontal Line and Vertical Line components to change the
appearance of your model. You can add lines to different areas of the canvas
to visually separate items.
1. Select the component and open the "Properties" panel.
2. On the General view, set the following options:

DescriptionOption

Click the Color Selector icon to set the border color.
For more information about using the Color Selector
tool, see Setting colors for component elements.

Line Color

Type or select a border thickness from the list.Thickness

3. Click the Behavior view to set dynamic visibility options. For more
information about dynamic visibility, see Managing the Visibility of
Components.
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Using the Web Connectivity components

This category contains a group of components that provides options for
linking your models to the Web.

Note:
In Xcelsius Engage and Xcelsius Enterprise, web connectivity is built in. In
addition to using these components, you can use the "Data Manager" to
configure web connectivity options. For more information, see Managing
data connections.

Connection Refresh Button

A button that manually refreshes the connection it is linked to.

Note:
This component is not available in Xcelsius Present.

Tip:
To see an example of a model with a Refresh Button, click File > Samples
and open the sample file Connection Refresh.

Reporting Services Button

The Reporting Services Button component enables you to connect to the
XRS server and select a report to use to populate the model.

Note:
This component is available only in Xcelsius Engage Server and
BusinessObjects Xcelsius Enterprise.
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Slide Show

The Slide Show component creates a slide show of URL-based images and
SWF files.

Note:
This component is not available in Xcelsius Present.

Unlike the normal Image Component, which requires that you first Import
the file, the Slide Show component loads the image from the URL specified
in the URL data source. If the Slide Show URL changes, the Slide Show
component attempts to load the image from the new location. Once the image
is loaded , the component transitions from the current image to the one
specified at the new URL data source.

Note:
When an image is imported into normal Image components, Xcelsius stores
its own local copy of the file internally in the XLF file. The original file is no
longer accessed or used in the model. Because the file data is stored within
the XLF, the XLF can be moved or emailed and the contents of the file travels
with it. However, the Slide Show points to a URL, which can change at
runtime. Since the image is not built into the XLF, the Slide Show component
must be able to access the URL and the image must be available to load at
runtime.

Caution:
If a model is connected to an external data source, when the model runs,
Adobe security restrictions apply. When the model is run locally, the SWF
file or the host application file must be made trusted. If the file is run on a
web server, there must be a cross-domain policy file. For more information,
see Adobe Flash Player Security Restrictions.

SWF Loader

Note:

• This component is not available in Xcelsius Present.
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• The Adobe Flash Player memory management method controls when
inactive items are removed from memory. To avoid heavy memory
consumption when using the SWF Loader:
• Reduce the number of SWF Loader and Slide Show components

included in a single model
• Reduce the number of SWF files that the SWF Loader and Slide Show

components in the model must load concurrently at run-time.

The SWF Loader component is similar to the Slide Show component; it loads
SWF files from a specified URL and avoids the need to first import the files.
The SWF Loader has better memory management than the Slide Show
component, but it doesn't have transition effects and cannot block mouse
events.

Loaded SWFs are not built into the XLF, so the SWF Loader component
must be able to access the URL and the file must be available to load at
runtime.

Caution:
If a model is connected to an external data source, when the model runs,
Adobe security restrictions apply. When the model is run locally, the SWF
file or the host application file must be made trusted. If the file is run on a
web server, there must be a cross-domain policy file. For more information,
see Adobe Flash Player Security Restrictions.

URL Link Button

A button that links to a relative or absolute URL when pressed.

To set up Web Connectivity components

A Web Connectivity component is placed on the canvas.

1. Select the component and open the "Properties" panel.
2. On the "Properties" panel, click the General view and specify the text to

display as well as a destination to insert data. For more information about
the available options, see Web connectivity general properties.
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3. Click the Behavior view and set the options for how the component
functions in the model. For more information about the available options,
see Web Connectivity behavior properties.

4. Click the Appearance view and set the visual characteristics of each
component element. For more information about the appearance options,
see Web Connectivity appearance properties.

5. Click File > Save and enter a location and filename for the model. Click
OK.

The Web Connectivity component is added to the model and configured. To
see how the model will look at run-time, on the Toolbar, click Preview.

Web connectivity general properties

Use the following table as a guide for setting the Text properties on the
General tab.

DescriptionOption

All except Slideshow and SWF Loader compo-
nents

The text that appears on the button. Type the text in
the box or click the Cell Selector icon ( ) to link it
to a cell in the embedded spreadsheet.

Label

Refresh Button only

In the Connections List box, select the checkbox
corresponding to the external data connections to be
refreshed when the user clicks this Refresh Button.
To select all connections, select the checkbox at the
top of the column.

Available Con-
nections
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DescriptionOption

Refresh Button only

The items in theAvailable Connections list are based
on connections configured in the "Data Manager".
Click this button to open the "Data Manager" to add
or modify external data connections.

Launch Data
Manager

URL Button only

The web address this button will link to. Type the URL
in the box or click the Cell Selector icon ( ) to link
it to a cell in the embedded spreadsheet.

Tip:
When this value is linked to the embedded
spreadsheet, the button is updated whenever the
value in the cell changes. You can then configure
the source cell to be updated dynamically by an-
other component or user input allowing the URL
Button to call different pages.

Note:
You must include "http://" or "https://" in the web
address.

URL

URL Button only

Specifies where the web page at the URL address will
open. Select New Window to open the page in a
separate browser window or This Window to open
the page in the same window and replace the current
contents in the window.

Window Op-
tions

Reporting Services only

Click this button to open the "Select Report" dialog
box.

Reporting Ser-
vices: Select
Report

221

Working with Components



DescriptionOption

Reporting Services only

Select this option to display the report parameters
when the model runs.

Display Parame-
ters at Run-time

Reporting Services only

Select a parameter in the list and select a service value
from this list to include the values in the report.

Use Service
Values

Reporting Services only

Select a parameter in the list and click the "Cell Selec-
tor" icon ( ) to use values from the embedded
spreadsheet.

Link to Cell
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DescriptionOption

Reporting Services only

To map the report data to the model, select default to
use the default data maps or select Advanced and
then configure the following options:

DescriptionOption

The list shows currently mapped
ranges. Click the Plus and Mi-
nus icons to add or delete
ranges.

Mapped
Ranges

The list shows the columns for
the selected range. Select a
column and click the Up and
Down arrows to change the sort
order. Click the X button to re-
move the selected column from
the list.

Selected
Columns

Type a name for the selected
range.Name

Data Mapping

Reporting Services only

This option defines the destination location for the re-
port data. Type or click the Cell Selector icon ( ) to
select cells in the embedded spreadsheet.

Range

Reporting Services only

To enable use of the report's history, select this option.
User Report
History
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DescriptionOption

Slide Show and SWF Loader only

The web address where the Slide Show or SWF
Loader component will retrieve images. Type the URL
in the box or click the Cell Selector icon ( ) to link
it to a cell in the embedded spreadsheet.

For the Slide Show component, once the image file is
loaded, the Slide Show transitions to the image using
the transition parameters defined on the Behavior tab.
Transition Behavior settings are not available for the
SWF Loader component.

Caution:
Progressive JPEGs and JPEGs with CMYK coloring
are not supported.

URL (JPEG or
SWF only)

Slide Show only

Select this option if you want to prevent users from
interacting with the Slide Show component at run-time.

Block Mouse
Events
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DescriptionOption

Application Do-
main
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DescriptionOption

Slide Show and SWF Loader only

Allows you to specify which domain the slideshow or
SWF Loader model will load into. The following three
options are available:

DescriptionOption

Loads into a child application domain.

Note:New If the model is connected using an
LCDS connector, the data will not load.

Loads into the current application do-
main. The model uses only the first
class definition; subsequent class def-

Current

initions that are loaded in the domain
(such as for the LCDS connector) are
ignored. Use this option if the LCDS
connection can share the main model's
domain.

Note:
This option allows you to embed exter-
nal codes to control the model, but if
the LCDS connection is unable to
share the main model's domain, data
is not loaded.

Loads into a compatible bootstrap
loader. If you need to run an LCDS
model in a slideshow or SWF Loader,Compati-

ble this option allows the model to share
the classes defined in the bootstrap
loader but use its own class definitions
for everything else. For example, the
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DescriptionOption

DescriptionOption

bootstrap loader loads the Slideshow
or SWF Loader model and the
Slideshow or SWF Loader model loads
the LCDS model. When the LCDS
model is run in a slideshow or in the
SWF Loader, the data is loaded correct-
ly.

Note:
For more information about bootstrap
loaders, see the Adobe Flex documen-
tation.

Related Topics
• To set up Web Connectivity components
• Web Connectivity behavior properties
• Web Connectivity appearance properties

Web Connectivity behavior properties

Use the following table as a guide for setting the Behavior properties for Web
Connectivity components.

DescriptionOption

Common Tab

Connection Refresh Button
Refresh After
Components
are Loaded
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DescriptionOption

URL, Connection Refresh, and Reporting Services
Buttons only

To configure an action within the model to trigger the
component, you can select a cell in the embedded
spreadsheet as the trigger cell. When the value in that
cell is set to a specific value (for example, by another
component in the model), the component responds as
though it were clicked. Click the Cell Selector icon ( )
and select a cell in the spreadsheet. Then set the follow-
ing options:

DescriptionOption

The component is triggered when
the value in the trigger cell
changes.

When Value
Changes

The component is triggered when
the value in the trigger cell is set
to a specific value. Enter the val-
ue or click the Cell Selector icon
( ) to select a source location
from the embedded spreadsheet.

When Value
Equals

Trigger Cell

Reporting Services Button

When this option is selected , the Reporting Services are
loaded at run-time before the components are loaded.

Refresh Be-
fore Compo-
nents are
Loaded

Reporting Services Button

The data is refreshed automatically at a set interval based
on the time values set for this option.

Refresh Ev-
ery
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DescriptionOption

Reporting Services Button

Type or click the Cell Selector icon ( ) to select a
source location for a message to display when the data
connection is loading.

Loading Mes-
sage

Reporting Services Button

Type or click the Cell Selector icon ( ) to select a
source location for a message to display when the data
connection is idle.

Idle Message

Reporting Services Button

Type or click the Cell Selector icon ( ) to select a
destination location for the Loading and Idle messages.

Insert In

Reporting Services Button

When this option is selected, a special cursor displays
while the data connection is loading.

Enable Load
Cursor

Reporting Services Button

When this option is selected, user input is disabled while
the data connection is loading.

Disable
Mouse Input
on Load

Slide Show component only

Specifies the style of the transition between slides.
Transition
Type
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DescriptionOption

Slide Show component only

Specifies a method for transitioning to the next slide.
Select from the following options:

DescriptionOptions

The transition begins slowly and
accelerates as it progresses.Slow In

The transition begins quickly and
slows down as it progressesSlow Out

The transition begins slowly and
increases its speed until the mid-
dle of the transition and then
slows down as it finishes.

Slow In and Out

Easing Type

Slide Show component only

Specifies the amount of time the transition between im-
ages takes. Enter or select the value from the list.

Tip:
A slower transition time create a smoother transition.

Transition
Time

All

This option allows you to specify conditions that control
when the component is visible in the model. For more
information about using dynamic Visibility, see Managing
the Visibility of Components.

Dynamic Visi-
bility

Animations and Effects Tab
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DescriptionOption

All

If dynamic visibility is enabled, select how you want to
the component to appear on the canvas when triggered.
You can select an entry effect and specify how long you
want the components appearance to take and, for some
selectors, whether the component makes a sound when
it appears. For more information about dynamic visibility,
see Managing the Visibility of Components.

Entry Effect :
Type

Related Topics
• To set up Web Connectivity components
• Web connectivity general properties
• Web Connectivity appearance properties

Web Connectivity appearance properties

Use the following table as a guide for setting the Appearance properties for
Web Connectivity components. Note that some options are available only
for specific component types.

DescriptionOption

Layout Tab

Refresh Button and URL Button

If selected the button has an opaque background. If
not selected, the button is completely transparent,
which allows you to create a text only link or place
the component over an imported image to create a
custom button.

Show Button
Background
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DescriptionOption

Reporting Services, Slide Show, and SWF
Loader components

Specifies whether objects behind the component are
visible. A transparency of 0 means that users cannot
see objects behind the component. A transparency
of 100 means that the component is completely
transparent and invisible to users.

Transparency
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DescriptionOption

Slide Show and SWF Loader components only

Defines how images are sized within the bounds of
the Slide Show component. Select one of the follow-
ing options:

DescriptionOption

This image is shown at its actu-
al size. Areas of the image that
extend outside of the Slide
Show are not shown.

Original Size

The image is stretched to fit in
the bounds of the Slide Show.Stretch

The image is sized proportion-
ately to fit within the bounds of
the Slide Show.

Scale

Sizing Method

Slide Show and SWF Loader components only

Defines how images are aligned from left to right
within the bounds of the Slide Show. Select one of
the following options:

DescriptionOption

The image is centered horizon-
tally within the Slide ShowCenter

The image is aligned to the left
edge of the Slide ShowLeft

The image is aligned to the
right edge of the Slide ShowRight

Horizontal Align-
ment
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DescriptionOption

Vertical Align-
ment

Slide Show and SWF Loader components only

Defines how images are aligned from top to bottom
within the bounds of the Slide Show. Select one of
the following options:

DescriptionOption

The image is centered vertically
within the Slide ShowMiddle

The image is aligned to the top
edge of the Slide ShowTop

The image is aligned to the
bottom edge of the Slide ShowBottom

Text Tab

URL, Refresh, and Reporting Services Buttons
only

Defines the text that appears on the button.
Label

URL, Refresh, and Reporting Services Buttons
only

The settings in this area allow you to format the text
for the selected text element.

Note:
If a global font is set for the document, you cannot
change the font type. For more information about
global fonts, see To set global font options.

Format Selected
Text

Allows you to set the position for some text ele-
ments relative to the component.Position
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DescriptionOption

Allows you to adjust the position of some text el-
ements by offsetting it relative to its set position.Offset

Allows you to set the number format for some
text elements.Number Format

Color Tab

All except Slide Show and SWF Loader compo-
nents

Applies to the button color.

You can set a different color for when the button is
on and when it is off.

Buttons

Input Text Area and Label component only

Applies to the label text.

You can set a different color for when the element is
not active (Default color), when the mouse pointer
moves over the element (Over color), and when the
element is active (Selected Color).

Labels

Related Topics
• Setting colors for component elements
• To set up Web Connectivity components
• Web connectivity general properties
• Web Connectivity behavior properties

Deleting components

Delete any selected components by pressing DELETE or selecting Delete
from the right-click context menu.
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Tip:
You do not need to ungroup components to delete components that are in
the group.

Deleting a component can be undone pressing CTRL+Z or clicking Undo
on the Edit menu.

Understanding Alerts

Alerts call the attention of the user to a specific item or action that has reached
a pre-established limit. These limits, often called targets, budgets,
benchmarks, and so on, are a standard to which an item is compared.

In Xcelsius 2008, you can define alerts on most charts and single-value
components. When alerts are enabled, the component represents the current
alert level as a color. Typically, green represents a desired condition, yellow
indicates that the situation is not ideal, and red marks an issue as critical.
When you define the alert, you specify which values to monitor, as well as,
the alert thresholds and whether it is preferable for the values to be higher
than, lower than, or as close to the target value as possible. You can also
define custom colors.

Alerts are available on the following components:
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Component
Component
Type

Bar, Bubble, Column, Combo, Line, Radar, Stacked
Bar, Stacked Column, XY

Note:
Alerts are not available when charts display multiple
series of data.

Charts

Combo Box, Icon, Label Based Menu, List Box, List
Builder, Ticker, Scorecard

Selectors

Dial, Dual slider, Gauge, Horizontal Progress Bar,
Horizontal Slider, Spinner, Value, Vertical Progress
Bar, Vertical Slider

Single Value

AllMaps

GridOther

Related Topics
• Using Chart components
• Using the Single Value components
• Using Selector components
• Using the Other components

To configure alerts

If you want a component to indicate when its data value reaches a specific
range, you can configure and customize alerts.

1. Select the component and open the "Properties" panel.
2. On the "Properties" panel, click the Alerts view.
3. Select the Enable Alerts check box.

Note:
For Scorecard components, you can enable alerts for different columns
individually. For each column that you want to show alerts for, select the
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checkbox in the Show column and then define the alert properties for the
selected column.

For Label-Based Menu, List Builder, List Box, and Combo Box
components, in the Alert Values box, specify the values to be compared
to the target values for alerts. Type a value or click the Cell Selector icon
and select a source location in the spreadsheet.

4. Select one of the following methods to use for the alerts:

DescriptionOption

For Single Value components only. Select this
option to base alerts on specified percentages of
the value set on the General view for the scale
Maximum Limit.

As a Percent
of Max Value

Select this option to base the alerts on percent-
ages of specified target values.

To set the target values by linking to cells in the embed-
ded spreadsheet, click the Cell Selector icon. To
manual define the target values, click the Manual Edit
icon ( ).

Note:
You can set separate target values for each data point.

As Percent-
age of Target

Select this option to base the alerts on values you
set in the "Alert Thresholds" area.

By Value

5. Under Alert Thresholds, set the following options:
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DescriptionOption

Select this option to select the threshold levels from
cells in the embedded spreadsheet, then click the
Cell Selector icon to select the cells.

Use a
Range

To manually define the threshold values, do the fol-
lowing:

Do thisTo

Click the value in the From or To
column and type a new value

Edit existing
values

Type it in the box and click Add.Add a value
to the list

Click the Delete icon beside the
value.

Delete a level

Click the Color Selector icon beside
each level to set the color. For more
information about using the color
selector, see Setting colors for
component elements.

Note:
If theEnable Auto Colors checkbox
is selected, you cannot set colors
for each threshold individually.

Assign colors
to threshold
levels

Enter a Val-
ue

6. To automatically define the colors assigned to each threshold level, select
the Enable Auto Colors checkbox.

Note:
To manually assign colors to each threshold level, deselect this option
and select the Color Selector icon beside each threshold level to set its
color.
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7. IfEnable Auto Colors is selected, to set a different color gradient scheme,

click the Auto-color icon ( ).
The Color dialog box opens.

8. On the Color dialog box, select a color scheme from the "Custom" or
"Built-in" lists, or, to create a new color gradient, click Create new
gradient and set the following options:

DescriptionOption

Select this option to include 2 colors on the alert
scale.

2-Color
Gradient

Select this option to Include 3 colors on the alert
scale.

3-Color
Gradient

For each color on the scale and for a "no data" color,
set the color to use for the fill and the text. Click the
down arrow beside each color to open the Color di-
alog box.

Colors

9. To set the color order, select one of the following options:
• Low Values are Good - Use this option when the ideal value type is

lower than the target value. For example, to represent expenses when
you want them to be as low as possible.

• Middle Values are Good - Use this option when the ideal value type
is as close as possible to the target value. For example, to represent
inventory when you want inventory quantities to be as accurate as
possible.

Note:
This option is only available when using percentages.

• High Values are Good - Use this option when the ideal value type is
higher than the target value. For example, to represent revenue when
you want revenue values to be as high as possible.

10. For Vertical Slider, Horizontal Slider, Horizontal Progress Bar, Dial, Dual
Slider, and Gauge components, select where you want the alert color to
appear:
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DescriptionOption

The component background displays the alert color.Back-
ground

The marker, needle, and so on displays the alert
color.

Marker

A text box beside the component contains the cur-
rent value and displays the alert color.

Value

Alerts are configured for the component.

Managing the Visibility of Components

When models contain too much information or too many visual components,
users may have difficulty focusing on specific sets of information. If you need
to display a lot of information, you can simplify the visual layout by displaying
some information only when it is needed. To make your model easy to
navigate you may want to re-use certain areas of the canvas and hide and
show components at runtime.

Dynamic visibility allows you to control when components are visible based
on the contents of a spreadsheet cell. Put simply, a component using dynamic
visibility is visible when the status matches the key, otherwise the component
is hidden. For example, you can add a Toggle Button to display a specific
chart. The Toggle Button is configured to alternately insert showChart and
hideChart into a Destination cell each time it is clicked. By linking the
Chart's status to this Destination cell and setting the Chart's Key to
showChart, the Chart becomes visible when the Toggle Button inserts the
value showChart and hidden when the Toggle Button inserts hideChart.

In a more complex model, you may want to switch between several different
components. To accomplish this, use the Key and a Selector. For example,
a model might need to switch between different charts. You can assign each
chart a unique Key, such as chart1, chart2, and so on. Then, add a List
Box component to the canvas and set the source data to match the chart
keys and the destination as a blank cell in the spreadsheet. When you link
each chart's Status to the destination cells, each time a selection is made
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on the List Box and the chart's key is inserted into the destination cell, the
chart is visible and the others are hidden.

When dynamic visibility is enabled, you can also add animation effects to
how the component appears and disappears from the model.

Tip:
To see an example of a model with dynamic visibility, click File > Samples
and open the sample file Dynamic Visibility.

Note:
Add-on components do not support dynamic visibility. If you want to control
the visibility of Add-on components, you can place the component in a Canvas
container and apply the dynamic visibility settings to the Canvas container
to show or hide the Add-on component it contains.

Related Topics
• To set up Dynamic Visibility
• To configure entry effects for dynamic visibility
• Chart Behavior properties
• Container behavior properties
• Selector behavior properties
• Single Value component behavior properties
• Map behavior properties
• Text behavior properties
• Other component behavior properties

To set up Dynamic Visibility

A model containing a component is open on the canvas.

1. Select the component and open the "Properties" panel.
2. On the "Properties" panel, click Behavior > Common.
3. In the "Dynamic Visibility" area, beside the Status box, click the Cell

Selector icon ( ) and select a cell in the spreadsheet that will control
the component's visibility.

242

Working with Components



Note:
Do not select cells that are already bound to this component, for example,
its data ranges, or those data sources will not refresh when dynamically
changed.

4. In the Key box, type a value or click the Cell Selector icon ( ) and
select a cell that will contain the key value for this component.

Note:
The Key box is not available unless Status has been set.

When the value in the Status cell matches the key value, the component
will be visible.

5. Place a component on the canvas that you will configure to enter values
into the Status cell set in step 3. Open the "Properties" panel.
Typically, this will be a Selector component, such as a Checkbox
component or a Radio Button component, but could also be a chart or a
map component that is configured to insert data into the specified cells.

6. On the "Properties" panel, on the General tab, in the Source Data box,
enter or select the key values for the components it is controlling.

Note:
If the selector is controlling only one component, you need to enter a key
value for hiding the component as well.

7. In the Destination box, click the Cell Selector icon ( ) and select the
cells selected for the Status box in step 3.

At runtime, when the user clicks the selector component, it inserts a key
value into the Status cell. The dynamically visible component is visible when
the inserted value matches its key value.

If desired, you can configure the component's entry effect to specify how the
component appears and disappears from the model.
Related Topics
• Managing the Visibility of Components
• To configure entry effects for dynamic visibility
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To configure entry effects for dynamic visibility

A model is open on the canvas and contains one or more components that
are configured for dynamic visibility.

When dynamic visibility is enabled, you specify how components arrive in
the model. For example, it could slide in from one side or slowly fade into
few. You can also specify how long the component's entrance will take.

1. Select the component and open the "Properties" panel.
2. Click Behavior > Animations and Effects.
3. Under Entry Effect, in the Type list, select one of the following options:

DescriptionOption

The component appears in a semi-transparent state
and gradually becomes solid.

Fade-in

The left side of the component appears and then the
remainder of the component is gradually drawn in
from left to right.

Wipe Right

The top left corner of the component appears and
the remainder of the component is gradually drawn
in both down and toward the right.

Wipe
Right-
Down

Note:
If you select None, the component appears without any effects and you
cannot set the duration for its entrance.

4. In the Duration (seconds) list, select the number of seconds the
components entrance should take.

When the model is run and the component is triggered to appear, it is added
to the screen using the selected entry effect and duration.
Related Topics
• Managing the Visibility of Components
• To set up Dynamic Visibility
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Disabling User Input

Many components can be configured to allow users to modify values at
runtime. If you do not want users to change data values from the model, for
many components, you can adjust their configuration to prevent interaction.
However, if the design requires that the component accept user input, you
can use a Background component to block input.

Note:
For Single Value components, you can also prevent users from changing
data values in two ways: bind the component to a cell that contains a formula
or deselect the Enable Interaction option on the Behavior > Common
menu of the "Properties" panel.

Related Topics
• Single Value component behavior properties

To configure Background components to block user
input

A component is placed on the canvas.

Note:
If you want to block user input in specific situations, you could use the
Dynamic Visibility option to only display the transparent background in those
situations. For more information about configuring dynamic visibility, see
Managing the Visibility of Components.

1. From the Components browser, drag a background component onto the
canvas and place it over the component for which you want to block user
input.

2. Select the Background component and open the Properties panel.
3. On the General view, in the Background Color option, click the Color

Selector icon and select a suitable color.
4. Set the Transparency slider to 100%.
5. Select the Block Mouse Events option.
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When the model runs, if users click the component that is behind the
background, the mouse click is not registered.
Related Topics
• Using Container components
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Working with Models

Models are visual representations of your data. By linking visual components,
such as charts and gauges to your data, you can create a visual model of
that data. You can also add interactive options that allow users to make
adjustments to the data at the time the model runs.

At their very basic, creating models involves three steps:
1. Import or enter data into the embedded spreadsheet.
2. Add components to the canvas and link them to the spreadsheet cells

where the data is stored.
3. Preview and publish your model.

Xcelsius offers numerous possibilities for laying out and formatting models.
to save time, you may want to start with a predefined template. Xcelsius
provides several templates that have been professionally designed for specific
purposes. You can use these templates as they are or customize them for
your specific needs.

In addition to using templates to quickly create models, you can create a
specific look to all components in your model with themes and color schemes.

Xcelsius also includes sample models that illustrate its features and
demonstrate what you can do with components. You can open these samples
and explore their functionality.
Related Topics
• Using templates
• Using themes
• Using color schemes
• Previewing models
• Sample models
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Using templates
If you often create models with similar components or settings, you can use
a template as a starting point for new models. Templates demonstrate
assorted layouts and combinations of components. Some templates are
bound to sample data to illustrate how the template works, others, such as
the Layout templates, are not bound to any data. When you open a template,
it is inserted on the canvas as a new model. You can then add, delete, or
modify the template, and save it as a new model or as a modified or new
template.

Xcelsius 2008 offers a set of templates you can use to create a new model.
You can also create a model starting from a blank canvas and save it as a
template.

Note:
Templates cannot be applied to existing models. To change the look of an
existing model, you can apply a different theme or change the color scheme.

Related Topics
• Using themes
• Using color schemes

To open a template

Rather than building your model from a blank canvas, you can use a template
that contains the basic components that you want to use and customize it
to suit your needs.

1. Click File > Templates.
The "New From Template" dialog box opens. The "Category" area lists
the categories available templates may be assigned to.

2. In the "Category" area, click a category.
The "Items" area displays the available templates for that category.

3. In the "Items" area, click a template.
In the "Preview" area, a sample of the template is displayed and, if a
description was written for the template, it appears in the "Description"
area.
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Note:
You can click the selectors in the preview to see the intended functionality
of each component.

4. When you have selected the template you want to open, click OK.

The template opens on the canvas, but is not bound to any data. You can
now import a spreadsheet from Microsoft Excel or enter data in the embedded
spreadsheet, as well as modify the components to create a new model or a
new template.

To create a template

If you often use a similar layout and components for models, you can create
templates that you can reuse for new models rather than starting from a
blank canvas. For example, if you are creating a set of Portlets for use in
your corporate portal, you may want to save your models as templates so
you can re-use them when updates are necessary. To save a model as a
template, you first save the file to the templates folder and then export the
model (SWF file) to the same location.

1. Create a model that you want to save as a template.
2. Click File > Save As.

The "Save As" dialog box opens.

3. Navigate to the folder where the Xcelsius program is installed and then
to the following location: ...\assets\template.

Note:
To create a new template category, create a folder under the \template
directory.

4. In the Filename list, type a file name for the template and click Save.
5. Click File > Export > Flash (SWF).
6. Navigate to the templates folder where you saved the template.
7. In the File Name list, type the same file name for the SWF file that you

entered for the template and click Save.

The model is saved as a template. The next time you open the templates
window, your template will be available for preview and use.
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Using themes
Themes (formerly called Skins) provide an easy way to customize your model
and maintain a consistent look throughout the model. Themes control the
style and properties applied to each component. Themes also include a color
scheme, but you can further customize your model by changing the color
scheme. If a new color scheme is applied, the components retain their style
and property settings, but use the new color palette.

Note:
Some themes include custom styles for components that are not available
in other themes, for example, the half gauge component is available only in
the Graphite theme. If you change the theme, the custom components change
to the default component for that category. If you want to use the custom
component, you must change the theme back.

To apply a theme

If you want to change the look of your model, you can apply a theme to set
the style and property settings for all components.

1. Click Format > Theme.
2. From the "Theme" list in the left panel, select a theme.

The "Preview" area shows a sample of how the theme will look.

3. Click OK.
The model is changed to use the styles and properties for the selected
theme.

The new theme applies to all existing components and all new components.
You can select individual components and change their properties.

Using color schemes
Color Schemes (formerly called Styles) alter the color palette used for
components in your model. You can apply a color scheme to your entire
model or only to specific components. Xcelsius provides numerous
pre-defined color schemes that you can apply to your models or you can
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create your own color schemes based on an existing scheme or combination
of custom colors. Color schemes do not affect the colors of fonts, text
formatting, or alerts.

Note:
Color schemes are not transferred with XLF files. If the color scheme used
by a model is not available in the XLF file, the custom color scheme continues
to be used by the existing components but is not available for new
components. If you want the custom color scheme to be available for new
components, you must create the custom color scheme in the new file.

To change the color scheme

You can change the way your model looks by changing its color scheme.
You can apply the new color scheme to new components only or choose to
apply the change to existing components as well.

1. Open a model.
2. Click Format > Color Scheme.
3. In the "Color Schemes" dialog box, select the color scheme you want to

apply.

Note:
To change the color scheme back to its original settings, select Current
Theme Colors.

4. If you want the color change to apply to components already in the model,
click Apply to Existing Components.

5. Click OK.

The color scheme for the model changes. If you selected the Apply to
Existing Components option, the colors of existing components change.
Otherwise, the new color scheme applies when you place new components
on the canvas.

Tip:
You can also change the color scheme from the toolbar. Click the (Color)
icon and select the color scheme you want to apply. Scroll to the bottom of
the list to set the Apply to Existing Components option.
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To create a custom color scheme

You can create custom color schemes by modifying the parameters of an
existing color scheme.

When you create a custom color scheme, it is saved to...\Xcelsius\as
sets\themes\custom. To share the color scheme with other Xcelsius
work stations, copy the custom color scheme XML file to the same file location
on the other system.

1. Click Format > Color Scheme.
The "Custom Color Scheme" dialog box opens.

2. In the "Color Schemes" dialog box, select a color scheme to modify and
click Create New.

Tip:
You can also open the Custom Color Scheme dialog box from the toolbar.
Click the Color Scheme icon and select Create New Color Scheme.

3. In the "Custom Color Schemes" dialog box, set the following options:
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DescriptionOption

Type a name for the new color scheme.Name

Click the color you want to change and, from the
color selector, click the color you want to change it
to.

color bar

If you want Xcelsius to select a color palette based
on a selected color, select the color you want to base
the palette on and select this option. Move the slider
to have Xcelsius adjust the palette to be more like
the selected color or less like it.

AutoMatch
Colors

If you want to set the color for specific elements in
components, clickAdvanced. In the advanced area,
click the tabs to view the elements for each compo-
nent. Click the color box beside each element name
and select the color you want to apply to that ele-
ment.

Advanced

4. Click Save.

The color scheme for the model changes. If you selected the Apply to
Existing Components option, the colors of existing components change.
Otherwise, the new color scheme applies when you place new components
on the canvas.

Previewing models
As you are designing your model, you may want to test your design,
experiment with different combinations of components, colors, and layouts,
and explore how it interacts with the data. When you preview a model you
can interact with it as you or users would after it is published.

To preview models

A model has been created and is open on your workspace.

253

Working with Models



If you want to view and interact with a model as you would after it is published,
you can preview the model.

• Click File > Preview.

Tip:
To preview a model, you can also click Preview in the toolbar.

Xcelsius generates an SWF file of the model and displays it on the screen.
You can now interact with the model as you would after it is published. To
close the preview and return to the working version of the model, follow the
same step to toggle back to the working copy.
Related Topics
• To take snapshots of models
• To export visualization previews

To export visualization previews

A visualization has been created and is open in your workspace.

If you would like to export an SWF of your visualization to view in a browser,
you can export a preview of the visualization.

• Click File > Export Preview.
A progress bar opens on the screen.

To take snapshots of models

A model has been created and is open on the Xcelsius workspace.

When you preview a model, you can interact with the model. If you find a
view that you would like to keep, you can take a snapshot of the model's
data or components in their changed state.

1. On the toolbar, click Preview.
Xcelsius generates an SWF file for your model.

2. Interact with the model and when you want to take a snapshot, click File
> Snapshot and select one of the following options:
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DescriptionOption

Generates an Excel spreadsheet (XLS) with the
current data values.

Tip:
This option can be useful for diagnosing models that
are not performing as desired.

Current Ex-
cel Data

Generates a Flash (SWF) file showing the current
state of the components.

Note:
This option is not available in Xcelsius Present.

Flash
(SWF)

Generates an HTML file and a Flash (SWF) file that
show the current state of the components.

Note:
This option is not available in Xcelsius Present.

HTML

Generates an Adobe PDF file showing the current
state of the components.

PDF

Generates a Microsoft PowerPoint file with one slide
that contains a Flash (SWF) file that shows the cur-
rent state of the components.

Power-
Point Slide

Opens a Microsoft Outlook email and attaches the
Flash (SWF) file showing the current state of the
components to a new message.

Outlook

The "Save As" dialog box opens.

3. Enter the location and filename for the snapshot and click Save.
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Working with Data

Xcelsius provides an embedded spreadsheet to store the source data required
for each model. Source data can be entered directly into the embedded
spreadsheet or you can import data from Excel. You can also copy and paste
data from Excel into the embedded spreadsheet. Regardless of how you
enter the data into the embedded spreadsheet, the data is not linked to any
other source. If you make changes in the source Excel file, those changes
are not automatically made to the data in the embedded spreadsheet. If you
need to maintain the data in Excel and Xcelsius, you must make the changes
in both locations or make the change in one location and import or export
the changed data to the other location.

Once the data is entered into the embedded spreadsheet, you can link the
components in models to specific cells in the embedded spreadsheet. You
can also link cells in the embedded spreadsheet to external data sources so
the data in the spreadsheet can be updated based on a live data source.

Understanding the embedded spreadsheet
The embedded spreadsheet is a functional Excel spreadsheet that you can
work with in the same way as you would in Excel. To associate your models
with specific data, you link components in models to cells in the embedded
spreadsheet.

Note:
The embedded spreadsheet does not support all Excel functions. It does not
support macros, conditional formatting, linking to other external spreadsheets,
and some formula functions. For a full list of supported formula functions,
see Supported Excel functions.

The embedded spreadsheet includes the Excel toolbars. If you use Excel
2003, the embedded spreadsheet shows your default toolbars. Buttons that
are not related to working with data are disabled, for example the Save,
Open, and Print options are handled by Xcelsius and are disabled on the
embedded spreadsheet toolbar. If you use Excel 2007, the embedded
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spreadsheet displays the ribbon that appears at the top of the spreadsheet
in Excel. Any buttons or menus not related to working with data are disabled.
To add Excel functionality to the embedded spreadsheet, in Xcelsius,
right-click a spreadsheet toolbar and add the toolbar that includes the desired
functionality.

Xcelsius uses the regional formatting settings defined on your computer,
including the settings for decimal separator, thousands separator, general
format name, month, day, year, hour, minute, second, time separator, and
date separator. To change the regional formatting settings, open the
"Windows Control Panel", double-click Regional and Language Options,
adjust the settings, and click OK.

While you are working on your model, you can display the embedded
spreadsheet below the canvas. This arrangement allows you to easily see
the data and bind components to cells in the spreadsheet. The embedded
spreadsheet is completely independent from Excel; you can add, modify,
and delete data directly within the embedded spreadsheet without having to
import or re-import from Excel.

To set up the data in the embedded spreadsheet, you can:
• Import a spreadsheet from Excel. See To import Excel spreadsheets.
• Open an Excel spreadsheet and copy and paste data from it to the

embedded spreadsheet. See To copy data between Excel and Xcelsius.
• Manually enter data into the embedded spreadsheet.

Preparing Excel spreadsheets for Xcelsius

Before you import an Excel spreadsheet into Xcelsius, make sure the
spreadsheet provides a good structure for achieving the best performance
for models in Xcelsius. Consider the following guidelines:

• Use only supported Excel functions

For a list of supported Excel functions, see Supported Excel functions.

• Use these Excel functions with small data sets only

The following Excel functions are supported in Xcelsius, but can affect
the model's performance if used with larger data sets (over 100 rows):
• SUMIF
• COUNTIF
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• HLOOKUP
• VLOOKUP

Note:
If you must access larger data sets, have the server or database perform
the aggregation on the server side.

• Organize your data in a logical fashion

To make your spreadsheet easier to understand, lay out your data in a
logical fashion. Group related items together and use colors, labels, and
borders to describe the structure and function of cells.

• Use colors, labels, and borders to identify data types (input and output)

To make it easier to maintain your visual models, use colors, labels and
borders to identify cells or ranges of cells in the spreadsheet and to
describe their use. Adding a legend that describes what the colors
represent helps maintain consistency and usability of the model.

• Place frequently used data and logic at the top of the spreadsheet

To make it easier to select the data you want to bind to components and
minimize the amount of scrolling required, place frequently used or
common logic or data at the top-left of the tab in your spreadsheet.

• Use multiple tabs

If your spreadsheet becomes large and requires a lot of scrolling to see
your logic or data, consider separating data into multiple tabs (or
worksheets).

To set preferences for the embedded spreadsheet

1. Click File > Preferences.
2. In the "Preferences" dialog box, from the list on the left, click Excel

Options.
3. In the "Excel Options" dialog box, set the following options:
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DescriptionOption

Allows you to work with LiveOffice enabled spread-
sheets within Xcelsius. Enabling this option may
affect the performance of other Microsoft Office
programs. If this option is not enabled, you must set
up and work with LiveOffice in a spreadsheet outside
of Xcelsius and then import the spreadsheet into
Xcelsius.

Available in only Xcelsius Enterprise.

Live Office
Compatibili-
ty

Use this option to set the number of rows in the
embedded spreadsheet that can be selected and
bound to components.

Xcelsius supports an unlimited number of rows in a range
selection; however, linking components to large range
selections can affect the performance of models. By
default, you can select a maximum of 512 rows in a
range.

Maximum
Number of
Rows

Use this option to optimize the spreadsheet for
runtime. When this option is enabled, Xcelsius cal-
culates formulas in the model when you export the
model and saves them with the SWF. It takes longer
to generate the SWF, but since the calculations are
already complete, the file performs better at runtime.

Optimize
Spread-
sheet

Use this option to avoid errors appearing in models
because of formula errors in the spreadsheet. When
selected, any cell that contains a formula error is
treated as a blank cell.

Note:
If formula errors are ignored, functions that refer to
cells with errors, such as ISERROR, will not work
correctly in the embedded spreadsheet.

Ignore Ex-
cel Formula
Errors

4. Click OK.
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The changes are applied to the spreadsheet.
Related Topics
• Understanding the embedded spreadsheet

Synchronizing data between Excel and Xcelsius

The embedded spreadsheet in Xcelsius is not connected to the source data
imported from an Excel spreadsheet. Changes made to the data in one
location are not automatically updated in the other location. If you want to
maintain synchronized copies of the data in Xcelsius and Excel, you can
export the modified data back to Excel or copy and paste the changed cells
to the source spreadsheet.
Related Topics
• To export data to Excel
• To copy data between Excel and Xcelsius

To import Excel spreadsheets

If you want to use an existing Excel spreadsheet as the source data for your
model, you can import the spreadsheet into Xcelsius.

WARNING:
Importing an Excel spreadsheet overwrites any data currently in the
embedded spreadsheet. If components have already been bound to cells in
the embedded spreadsheet, when you import, the cell binding locations
remain the same, but the data may change.

Note:
When the Excel file is imported the data is copied and is no longer connected
to the original data. Editing the original source file will not change the data
imported into Xcelsius.

1. Click Data > Import.

Note:
You can also use the (Import Model) icon on the toolbar to import
files.
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2. In the warning dialog box, click Yes.
3. Select the spreadsheet you want to import and click OK.

The data from the selected Excel spreadsheet is added to the embedded
spreadsheet.

To copy data between Excel and Xcelsius

You have an Excel spreadsheet that contains data you want to use in Xcelsius
models.

If you want to add some data from an Excel spreadsheet to the embedded
spreadsheet without importing the entire spreadsheet, you can copy the data
you want in Excel and paste it into the embedded spreadsheet.

You can copy and paste data only between Xcelsius and Excel. Although
you can open two instances of Xcelsius on your desktop and view the data
in each embedded spreadsheet, you cannot copy and paste data from an
embedded spreadsheet in one instance of Xcelsius to the embedded
spreadsheet in another instance of Xcelsius that is open on your desktop.

Note:
When you copy cells in an Excel spreadsheet, you can paste the values and
formulas into the embedded spreadsheet, but any conditional formatting is
not retained.

1. Open Xcelsius on your desktop and load the model you want to add data
to.

2. Open Excel on your desktop and load the spreadsheet you want to copy
data from.

3. In Excel, select and copy the cells you want to add to the embedded
spreadsheet.

4. In Xcelsius, select the cells where you want to paste the data, right-click
and select Paste.

The copied cells are pasted into the embedded spreadsheet.
Related Topics
• To import Excel spreadsheets
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Linking components and data

When you create models, you need to link or bind components to specific
cells in the embedded spreadsheet. You can bind elements of components
to cells that specify labels or those that contain data values or formulas. In
addition, component elements might retrieve data from the cells they are
bound to or populate those cells with values based on user input or other
calculations. If you add an external data connection, the external connection
must be configured to insert data in the embedded spreadsheet. Components
that use the data from the external source are then bound to the cells updated
by the external connection.

Once a component is bound to cells in the embedded spreadsheet, you can
import updated data or modify the embedded spreadsheet and the changes
are reflected by the component except in the following situations:
• If you move a range after it is bound to components, for example, to insert

a heading row to the spreadsheet, Xcelsius retains the new information
and changes the reference to the new range. However, if you move only
part of the range, the cell reference is not updated for the bound cells
and you must open the "Properties" panel for the component and re-link
it to the new location.

Note:
After you move a range, insert cells to expand a range, or delete cells to
decrease a range, the "Properties" panel does not display the changed
range values; however, when you preview or publish the model, the
component does use the new range values.

• If you change the sort order for data that is bound to components, the
component updates its display when you preview or export the model.
To force the component to display the new sort order in design mode,
re-bind the component to the sorted cells.

If the data in your spreadsheet changes frequently, but the structure of the
spreadsheet stays the same, you can generate SWF files based on the data
in an external Excel spreadsheet. For example, if you need to generate the
same model for multiple customers using the same spreadsheet layout with
different values, after you create your model and link the components to cells
in the embedded spreadsheet, you can set an option to export the SWF file
using the external Excel file as the data source. Then you can update the
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data in the external file for each customer and generate their model without
having to re-upload the spreadsheet and re-link the components.

To bind components to the embedded spreadsheet

When you link a component to cells in the embedded spreadsheet, you set
a reference to those cells on the component's "Properties" panel. Each field
that can be bound to the embedded spreadsheet, has a Cell Selector icon
( ) to its right. For more information about the options available for each
component, see the Using Xcelsius 2008 Components section.

Note:
Xcelsius supports an unlimited number of rows in a range selection; however,
linking components to large range selections can affect the performance of
your model. By default, you can select a maximum of 512 rows in a range.
To change this value, see To set preferences for the embedded spreadsheet
.

1. On the canvas, double-click the component you want to link to the
embedded spreadsheet.
The component's "Properties" panel opens. If the "Properties" panel has
been hidden, move the mouse pointer over the "Properties" panel tab to
expand it.

2. Click the tab that contains the field you want to link to the spreadsheet.

Note:
For many components, fields on the General view and Behavior view
can be bound to the spreadsheet.

3. Click the Cell Selector icon ( ) to the right of the field.
The "Select a Range" dialog box opens.

4. On the embedded spreadsheet, select the cell or range of cells that you
want to bind to that field.
The Select a Range box is updated to reference the selected cells.

5. In the "Select a Range" dialog box, click OK.

The component is updated to refer to the specified cells.
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To generate a SWF file using an external data source

A model has been created and components are linked to cells in the
embedded spreadsheet.

If you need to generate the same model using the same spreadsheet structure
but different values, you can export the SWF using an external data source.

Note:
This option does not update the data in the embedded spreadsheet; it
retrieves the data from the external file only to generate the SWF file. If you
preview the model or export to any other format, Xcelsius uses the data in
the embedded spreadsheet. In addition, the structure of the external
spreadsheet must match the structure of the embedded spreadsheet. If you
add or delete columns or rows in the external spreadsheet, those changes
are not reflected in the generated SWF file. To make structural changes to
the spreadsheet, you must re-import it and re-link the components.

1. Click File > Export Settings.
The "Export Settings" dialog box opens.

2. Select the Use Another Excel File option and in the list, click the file
folder and select the spreadsheet file to use.

Note:
The spreadsheet must have the same structure as the embedded
spreadsheet.

Click OK

3. Click File > Export > Flash (SWF).
The "Save As" dialog box opens.

4. Enter a path and name for the SWF file and click OK.

An SWF file is created using the data in the external Excel spreadsheet.

To export data to Excel

If you want to view the data in the embedded spreadsheet in Excel or
synchronize the data between the embedded spreadsheet and the Excel
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source file, you can save the data in Excel format so you can open it using
Microsoft Excel.

1. Click Data > Export.
The "Save As" dialog box opens.

2. Enter a path and name for the Excel file and click OK.

The data from the embedded spreadsheet is saved in the specified location
in Excel format.

Supported Excel functions

Xcelsius 2008 supports the following Excel functions:

ASINANDAD-
DRESS

ACOSHACOSABS

AVEDEVATANHATAN2ATANASSIGNASINH

CHARCEILINGBE-
TADIST

AVER-
AGEIF

AVER-
AGEA

AVER-
AGE

CON-
CATE-
NATE

COMBINCOLUMNSCOLUMNCODECHOOSE

COUNT-
BLANK

COUNTACOUNTCOSHCOSCORREL

DAYDAVER-
AGE

DATEVAL-
UE

DATECOVARCOUNTIF

DE-
GREES

DDBDCOUN-
TA

DCOUNTDBDAYS360

DOLLARDMINDMAXDIVIDEDGETDEVSQ

DVARPDVARDSUMDSSTDE-
VP

DSTDEVDPROD-
UCT

EXPEXACTEVENEOMONTHEFFECTEDATE
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FISHERFINDFALSEFACT-
DOUBLE

FACTEX-
PONDIST

GEFVFORE-
CAST

FLOORFIXEDFISHER-
INV

IFHOURHLOOKUPHARMEANGTGE-
OMEAN

IPMTINTER-
CEPT

INTINDI-
RECT

INDEXIFERROR

ISLOGI-
CAL

ISEVENISERRORISERRISBLANKIRR

KURTISTEXTISODDISNUM-
BER

ISNON-
TEXT

ISNA

LOGLNLENLEFTLELARGE

MAXAMAXMATCHLOWERLOOKUPLOG10

MINUTEMINUSMINAMINMIDMEDIAN

NENMONTHMODEMODMIRR

NOWNOTNORM-
SINV

NORMINVNOR-
MDIST

NET-
WORK-
DAYS

PER-
CENTILE

PEAR-
SON

OROFFSETNPVNPER

PPMTPOWERPMTPIPERMUTPER-
CENTRANK

RANDRADIANSQUO-
TIENT

QUAR-
TILE

PVPROD-
UCT

REPTREPLACERATERANKRANGE_COLONRANDBE-
TWEEN

ROWSROWROUNDUPROUND-
DOWN

ROUNDRIGHT
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SLNSINHSINSIGNSECONDRSQ

STDEVASTDEVSTAN-
DARDIZE

SQRTSMALLSLOPE

SUMSQSUMPROD-
UCT

SUMIFSUMSUBTO-
TAL

STDEVP

TANHTANSYDSUMXMY2SUMX2PY2SUMX2MY2

TRUNCTRUETODAYTIMEVAL-
UE

TIMETEXT

VARPAVARPVARAVARVALUETYPE

YEARWORK-
DAY

WEEKNUMWEEK-
DAY

VLOOKUPVDB

YEAR-
FRAC

Using external data sources
Note:
External data sources are not available in Xcelsius Present.

In Xcelsius 2008, you can connect your models to an external data source.
When the model runs, the data is updated from the external source so the
model is based on current information rather than information that was
available when the model was created.

The Data Manager is a centralized location where you can add and configure
all external data sources.

Managing data connections

Restriction:
The Data Manager is not available in Xcelsius Present.
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The "Data Manager " provides a central location where you can manage and
configure all connectivity options in your model including Flash Variables
and XML maps.

You can use the "Data Manager" to add several types of XML-compliant
data connections to your model. In addition, when you open a model, the
Data Manager detects any existing connection types. Excel XML maps and
Live Office Connections (supported in Xcelsius Enterprise only) are not
available to add as a new connection, but they are supported as existing
connections in data sources created outside of Xcelsius.

Note:
To see a list of existing connections in a model, open the model and click
Data > Connections to open the "Data Manager" dialog box. In the "Data
Manager" dialog box, click Add. The existing connections are listed under
"Existing Connections".

In Xcelsius Engage, models can have multiple connections, but they can
only have one of each of the following connection types:
• Web Service Connections
• XML Data
• Flash Variables
• Crystal Reports Data Consumer
After one of these connection types has been added to a model, that
connection type is no longer available in the list of connections types and
can't be added to the model again.

Note:
If you add external data connections to a model, Adobe Flash Player security
restrictions may affect users ability to run the model. For more information,
see Adobe Flash Player Security Restrictions.

Xcelsius supports the following types of connections:
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DescriptionConnection Type

Note:
Available in Xcelsius Enterprise only .

Query as a Web Service (QaaWS) is a tool that al-
lows you to create custom web services for queries
to SAP BusinessObjects Enterprise. Using QaaWS,
you can define a query from a universe and then
publish that query as a standalone web service. In
Xcelsius Enterprise, you then create a QaaWS
connection to allow the model to securely access
the web service.

For more information about creating QaaWS, see the
Query as a Web Service Guide available on the SAP
Help Portal (help.sap.com) under SAP BusinessObjects
Enterprise.

For information about configuring QaaWS connections,
see To configure QaaWS connections.

QaaWS

Web Services support interoperable interaction over
a network using the HTTP Protocol. When you add
Web Services to models, they have a live connec-
tion to data.

For information about configuring Web Service connec-
tions, see To configure Web Service connections.

Web Service

An XML data connection connects to an external
source through HTTP. When added to a model, this
connection can send live model data to an external
source to request specific information, for example,
if a date is sent to a server script, the script could
return the sales totals for that date.

For information about configuring XML Data connections,
see To configure XML Data connections.

XML Data
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DescriptionConnection Type

Flash Variables Flash variables provide a way to pass data or vari-
ables from HTML to the _root level of a Flash movie.
When you export your SWF as HTML, the Flash
Variables are generated in the OBJECT and EM-
BED tags.

Note:
Flash Variables are not secure. Do not send sensi-
tive or confidential information through Flash Vari-
ables, for example, passwords.

For information about configuring Flash Variable connec-
tions, see To configure Flash variable connections.

Note:
Not available in Xcelsius Engage.

Portal data connections allow you to define param-
eters in models or send and receive data from an-
other web part in SAP BusinessObjects Dashboard
Builder, IBM WebSphere or Microsoft SharePoint.
The portal connection can be set up to receive data
from another web part (consumer), to provide data
to another web part (provider), or to allow users to
define the parameter values at runtime.

For information about configuring Portal Data connec-
tions, see Configuring Portal Data connections.

Portal Data

The Crystal Reports Data Consumer connections
allow you to retrieve information from Crystal Re-
ports and embeds metadata in the SWF file that
Crystal Reports uses to bind Crystal Reports data
with the Xcelsius model.

For information about configuring Crystal Reports Data
Consumer connections, see To configure Crystal Reports
Data Consumer connections.

Crystal Reports
Data Consumer
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DescriptionConnection Type

The FS command connection allows you to include
Flash FS commands in models. FS Commands al-
low Flash to run JavaScript statements in a web
browser.

Note:
In Xcelsius 2008, External Interface connections
are the preferred connection for transferring data
using JavaScript in a web browser. If you use FS
Commands in your model, consider the Adobe Flash
security restrictions. For more information, see FS-
Command restrictions.

For information about configuring FS Command connec-
tions, see To configure FSCommand connections.

FS Command

The LiveCycle Data Services (LCDS) connection
streams real-time data through Adobe LiveCycle
Data Services. When you add an LCDS connection
in a model, data changes are pushed to the model
when they occur at the source.

For information about configuring LCDS connections,
see To configure LCDS connections.

LCDS
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DescriptionConnection Type

External Interface connections allow you to expose
selected data ranges in the embedded spreadsheet
to transfer data to the SWF file using JavaScript
when the file is embedded in an HTML web page.

For information about configuring External Interface
connections, see To configure External Interface connec-
tions.

External Inter-
face

When you import an Excel spreadsheet that has an
XML map, Xcelsius retains the defined structure of
the XML file and how it maps to the data within the
spreadsheet. When you include Excel XML Maps
connections in a model, the data can be dynamically
refreshed from the XML file each time the model
loads, at designated intervals, or when the user
clicks a refresh button.

For information about configuring Excel Data Maps
connections, see Working with Excel XML maps.

Excel XML
Maps

Note:
Available only in Xcelsius Enterprise.

If you create a model from a LiveOffice-enabled
Excel spreadsheet (Excel spreadsheets constructed
from managed Crystal Reports or Web Intelligence
data), the Live Office connection allows you to make
the model data refreshable against the source data.

For information about configuring Live Office connec-
tions, see Using Live Office Data Connections.

Live Office

Related Topics
• Using external data sources

273

Working with Data



To add an external data connection

If you want the data in a model to update based on the data in an external
source, you can use the Data Manager to add an external data connection.

Caution:
If a model is connected to an external data source, when the model runs,
Adobe security restrictions apply. When the model is run locally, the SWF
file or the host application file must be made trusted. If the file is run on a
web server, there must be a cross-domain policy file. For more information,
see Adobe Flash Player Security Restrictions.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, click Add and select a connection
type from the list.

3. Configure the connection. For more information about configuring data
connections, see the instructions to configure specific connection types
in this guide.

To remove data connections

You can use the Data Manager to delete data connections from model.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. Select the connection you want to remove and, from the bottom of the

connections list, click the Delete button ( ).

The selected connection is deleted from the model.

To configure QaaWS connections

A web service has been created using QaaWS (Query as a Web Service)
and you have the URL for accessing the web service.

Note:
This Data Connection is available only in Xcelsius Enterprise.
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Use a QaaWS connection to create a live connection (using a web service)
to data in SAP BusinessObjects Enterprise.

Caution:
If you include external data connections in models, security restrictions in
Adobe Flash Player may prevent users from accessing the data source. For
more information, see Adobe Flash Player Security Restrictions.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, click Add and selectQuery as aWeb
Service.

3. On the Definition tab, set the following options:
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DescriptionOption

A name for the connection.Name

Type the URL for the WSDL generated by the
QaaWS, or select it from the list. Then, click Import.
The model is linked to the QaaWS. The Method, Web
Service URL, and Input, and Output values defined in the
QaaWS are displayed in the associated fields on the page.

WSDL URL

Method
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DescriptionOption

When you import the WSDL, this list displays the methods
defined in the web service. Select the method you want
to use for this connection. QaaWS may generate the fol-
lowing methods:

DescriptionMethod

This web service call is
generated for index un-
aware prompts. The in-

RunQueryAsAService

put and output parame-
ter sets are the same as
for Run-
QueryAsAServiExceEx
method except for the
input Prompt for Year
values. This method re-
quires an En-
ter_Year_As string as
the prompt value for
year.

For more information
about these methods and
the parameters available,
see the Query as a Web
Service Guide available
on the SAP Help Portal at
help.sap.com.

This web service call is
generated for index
aware prompts. The in-RunQueryAsAService

Ex put and output parame-
ter sets are the same as
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DescriptionOption

DescriptionMethod

for RunQueryAsASer-
viceEx method except
for the input Prompt for
Year values. This
method requires an in-
stance of LovValueIn-
dex for year.

For more information
about these methods and
the parameters available,
see the Query as a Web
Service Guide available
on the SAP Help Portal at
help.sap.com.

This method is generat-
ed only when QaaWS
encloses at least one
prompt and is intended
to provide a list of val-
ues for the prompt it is
named after.

Valueof_

Web Ser-
vice URL
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DescriptionOption

When you import the WSDL, this box displays the Web
Service URL defined in the QaaWS.

Tip:
If you want to control the Web Service URL value
through Flash Variables, you can copy the URL pro-
vided by the WSDL to a cell in the embedded
spreadsheet. Then click the Cell Selector icon ( )
to link theWeb Service URL box to that cell. To point
to a different server, you can then set up Flash Vari-
ables to update the cell with a different URL.

When you import the WSDL, the required inputs and
prompts defined for the web service are displayed
in this list. To set a value for each prompt, select the
Input object from the list then set the Read From
option to map it to your Xcelsius model.

Note:
QaaWS Input objects include a user ID and password
for Business Objects. Xcelsius will generate a logon
screen to prompt users for these values as required.
The values and behavior of these prompts is based
on the Authentication configuration defined in the
QaaWS. Unless you want to set these items to spe-
cific values, you generally do not need to specify
values or map them to your Xcelsius model on this
page.

Caution:
If you enter specific username and password values
here, those values are stored in the XLF and SWF
files without encryption. For security reasons, it is
best not to enter specific values for these input items.

Input Val-
ues
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DescriptionOption

If the Input Values list includes prompts defined in
the QaaWS, select the Input item and then click the
Cell Selector icon ( ) to select a cell from the em-
bedded spreadsheet where the selected object will
retrieve its value.

Read From

When you import the WSDL, the output parameters
for the Results objects in the QaaWS are displayed
in this list in a tree structure, along with some addi-
tional parameters created by the QaaWS. When us-
ing a QaaWS web service, the Results objects output
is stored in the table node under the rows node.

Note:
To see the data type for results objects, move the
mouse pointer over the object.

To add the result values for a single object to your model,
select an Output object from the list, then set the Insert
In option to map it to your Xcelsius model.

You can also map all objects in an enclosing folder in a
single step. Click the enclosing folder to see the number
of columns required for the objects within that folder. Then
click the "Cell Selector" icon ( ) and select a range in
the spreadsheet that is large enough to contain the
specified number of columns. The number of rows re-
quired depends on the amount of data you expect to re-
ceive.

Output Val-
ues

Insert In
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DescriptionOption

For the selected Output value, click the Cell Selector
icon to select a cell from the embedded spread-
sheet to store the values retrieved by the QaaWS.

Note:
By default, Xcelsius allows up to 512 rows to be re-
trieved and inserted into the embedded spreadsheet.
To increase the number of rows allowed, see To set
preferences for the embedded spreadsheet .

4. Click the Usage tab and set the refresh and message options. For more
information, see To set refresh optionsand To create load and idle
messages.

Once the data is available in Xcelsius, you must map components to the
data. Mapping a component to QaaWS is the same as mapping it to the
embedded spreadsheet. For more information about mapping components
to data, see Linking components and data.
Related Topics
• Managing data connections
• To add an external data connection

To configure Web Service connections

A Web Service has been created and you have a WSDL URL.

Note:
This Data Connection is available only in Xcelsius Enterprise.

Use a Web Service connection to add a live service connection (using a web
service) to a model.

Caution:
If you include external data connections in models, security restrictions in
Adobe Flash Player may prevent users from accessing the data source. For
more information, see Adobe Flash Player Security Restrictions.
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Tip:
If you are connecting to SAP BusinessObjects Enterprise using a web service,
use a QaaWS connection.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, click Add and select Web Service.
3. On the Definition tab, set the following options:

DescriptionOption

Type a name for the connection.Name

Type the URL for the WSDL generated by the Web
Service, or select it from the list. Then, click Import.
The model is linked to the Web Service and the methods,
web service URL, and Input and Output values available
in the Web Service are added to those lists.

WSDL URL

The available methods are defined by the WSDL
specified in the WSDL URL box. If there is there is
more than one method, select the method that you
want to use for this connection.

Method

The available URLs are defined by the WSDL file
specified in the WSDL URL box. Select the URL that
you want to use for this connection. When the model
runs, it will use this URL, not the WSDL URL.

Tip:
If you want to control the Web Service URL value
through Flash Variables, you can copy the URL pro-
vided by the WSDL to a cell in the embedded
spreadsheet. Then click the Cell Selector icon ( )
to link theWeb Service URL box to that cell. To point
to a different server, you can then set up Flash Vari-
ables to update the cell with a different URL.

Web Ser-
vice URL
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DescriptionOption

When you import the WSDL, the required inputs de-
fined for the web service are displayed in this list. To
set a value for each item, select the Input object from
the list then set the Read From option to map it to
your Xcelsius model.

Input Val-
ues
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DescriptionOption

If the Input Values list includes items that required
input, select the Input item and then click the Cell
Selector icon ( ) to select a cell from the embed-
ded spreadsheet where the selected object will re-
trieve its value.

Read From

When you import the WSDL, the output parameters
for the Results objects in the web service are dis-
played in this list.

Note:
To see the data type for results objects, move the
mouse pointer over the object.

To add the result values for a single object to your model,
select an Output object from the list, then set the Insert
In option to map it to your Xcelsius model.

You can also map all objects in an enclosing folder in a
single step. Click the enclosing folder to see the number
of columns required for the objects within that folder. Then
click the "Cell Selector" icon ( ) and select a range in
the spreadsheet that is large enough to contain the
specified number of columns. The number of rows re-
quired depends on the amount of date you expect to re-
ceive.

The available values are set by the WSDL file. Select
an Output object from the list then set the Insert In
option to map it to your Xcelsius model.

Note:
Repeat for each value you want to use in the model.

Output Val-
ues

Insert In
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DescriptionOption

For the selected Output value, click the Cell Selector
icon to select a cell from the embedded spread-
sheet to store the values retrieved by the web ser-
vice.

Note:
By default, Xcelsius allows up to 512 rows to be re-
trieved and inserted into the embedded spreadsheet.
To increase the number of rows allowed, see To set
preferences for the embedded spreadsheet .

4. Click the Usage tab and set the refresh and message options. For more
information, see To set refresh optionsand To create load and idle
messages.

5. If your Web Service connection requires information to be passed in the
SOAP header, click the Advanced tab. Type the information in HTML
format or click the Cell Selector icon ( ) to select cells in the embedded
spreadsheet that contain the information.

Note:
When you use the Cell Selector icon, the <soap:Header> HTML tags
are automatically added to the text values in the cell. For example, the
selected cell would only need to contain “<username>joe</username>
<password>1234</password>”.

Related Topics
• Managing data connections
• To configure QaaWS connections

To configure XML Data connections

XML Data Connections allow you to refresh model data from an external
source using HTTP and to send live data from models to external sources.
For example, if a model has an XML Data connection, users could use the
model to submit information and collect data for forms. When you configure
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the XML Data connection, you can specify how and when the data will be
refreshed from the source.

Caution:
If you include external data connections in models, security restrictions in
Adobe Flash Player may prevent users from accessing the data source. For
more information, see Adobe Flash Player Security Restrictions.

The XML Data connection sends and loads functionality simultaneously
through one URL. The send ranges are sent to the URL prior to retrieving
the load data. This lets you create scripts that examine the sent data and
return data that corresponds to the sent values—much like a web request.
For example, if a date was sent to a server script, the script could return the
sales figures for that date.

Excel ranges are mapped to XML using a row-column structure. For example,
a one-row, three-column range named "ExampleRange" would be represented
in XML as:

<variable name="ExampleRange">
<row>
<column> Row1 Column1 value </column>
<column> Row1 Column2 value </column>
<column> Row1 Column3 value </column>

</row>
</variable>

where "Row1 Column1 value" would be the actual value of the cell in the
first row and first column of the range, and so on.

The entire group of ranges is encapsulated within <data> tags.

When the model loads, the XML is translated into Excel ranges using the
reverse process.

Note:
XML Data connections support a simple row/column structure. If you need
to access more complex XML data sources, use an XML Map connection.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, click Add and select XML Data.
3. On the Definition tab, set the following options:
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DescriptionOption

Type a name for the connection.Name

Type the URL for the XML data or click the Cell Se-
lector icon ( ) to select cells from the embedded
spreadsheet.

Note:
Include "http://" for hyperlinks.

XML Data
URL

If more than one type is available, select the MIME
type to use for this data.

MIME Type

Select this option to load (or receive) the XML data
from the specified URL into the specified range when
the connection is triggered.

Select a range from the list or click the Add icon to
add a new range and then set the Name and Range val-
ues for that range.

Click the Remove icon to delete a range from the
list.

Note:
Click Preview XML to see the structure of the XML that
the model must have to receive data from the external
data source.

Enable
Load

If you select the Enable Load option, for each range
in the list, type a name or use the Cell Selector icon
( ) to select a name from the embedded spread-
sheet.

Name

If you select the Enable Load option, for each range
in the list, type a range or use the Cell Selector icon
( ) to select the range from the embedded
spreadsheet where the retrieved data will be saved.

Range
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DescriptionOption

Select this option to send the XML data to the speci-
fied URL from the specified ranges when the connec-
tion is triggered. The translated ranges are sent in
HTTP format using the POST method.

Select a range from the list or click the Add icon to
add a new range and then set the Name and Range val-
ues for that range.

Click the Remove icon to delete a range from the
list.

Note:
Click Preview XML to see the structure of the XML that
the model must have to send data to the external data
source.

Enable
Send

If you select the Enable Send option, for each range
in the list, type a name or use the Cell Selector icon
( ) to select a name from the embedded spread-
sheet.

Name

If you select the Enable Send option, for each range
in the list, type a range or use the Cell Selector icon
( ) to select the range from the embedded
spreadsheet.

Range

Import
Named
Ranges

4. Click the Usage tab and set the refresh and message options. For more
information, see To set refresh optionsand To create load and idle
messages.

Related Topics
• Managing data connections
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To configure Flash variable connections

If you export your model to HTML you can add a Flash Variable connection
to pass values into your model as it loads. When you configure the Flash
Variable connection, you specify a name and define where the values are
stored in the spreadsheet.

You can use Flash Variables to send global session variables that you want
your model to consume and re-use. For example, you can send session
tokens, user IDs, Web Service URLs, and parameters passed from other
embedded scripts or controls.

Note:
Flash Variables are not secure. Do not send sensitive or confidential
information through Flash Variables, for example, passwords.

When you run the SWF in a web page, the Adobe Flash player enables it to
consume data directly from the HTML. If you are dynamically generating
your HTML page, you can pass variables into the SWF when it loads. You
can also use JavaScript to dynamically change the variables during runtime
using an External Interface connection, which allows other HTML embedded
controls to pass data into the SWF without reloading the HTML page.

The Adobe Flash player also enables a SWF to consume data directly from
defined parameters within a browser or path for which it is loaded. This
method allows one SWF to pass parameters to another SWF that is loaded
on a separate HTML page.

Caution:
If you include external data connections in models, security restrictions in
Adobe Flash Player may prevent users from accessing the data source. For
more information, see Adobe Flash Player Security Restrictions.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, clickAdd and select Flash Variables.
3. On the Definition tab, set the following options:

289

Working with Data



DescriptionOption

Type a name for the connection.

Use only numbers, letters, and underline. Do not start
the name with a number and do not include spaces in
the name.

Name

Select whether to send the variables to the SWF
in XML or CSV format.

Variable For-
mat

Select a range from the list or click the Add icon
to add a new range and then set the Name and Range
values for that range.

Click the Remove icon to delete a range from the
list.

Variable Data

Use this button to import named ranges from the
spreadsheet.

ImportNamed
Ranges but-
ton

4. Click the Usage tab and set the refresh and message options. For more
information, see To set refresh options and To create load and idle
messages.

Related Topics
• Managing data connections

Configuring Portal Data connections

Portal Data connections allows SWF-to-SWF communications when models
are deployed in SAP BusinessObjects Dashboard Builder, IBM WebSphere
or Microsoft SharePoint environments. The Portal Data connection can be
configured as a provider (sends data to another SWF (portlet, also known
as a web part in SharePoint) or as a consumer (receives data from another
SWF (portlet)). You can also set up the Portal Data connection to allow user
input during run-time. For more information about deploying Xcelsius models
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in a portal environment, see the Portal Integration Kit documentation available
in the Portal Integration Kit folder on your installation CD.

Caution:
If you include external data connections in models, security restrictions in
Adobe Flash Player may prevent users from accessing the data source. For
more information, see Adobe Flash Player Security Restrictions.

Related Topics
• Managing data connections

To configure Portal consumer/provider connections
If you want a model to provide data to another portlet, set up the Portal Data
connection as a provider. If you want it to receive data from another portlet,
set up the Portal Data connection as a consumer. Only Xcelsius 2008 Portal
portlets can consume information from a model that is using the Portal
Provider connection.

1. Click Data > Connections.
2. On the "Data Manager" dialog box, click Add and select Portal Data.
3. On the Definition tab, set the following options:
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DescriptionOption

To configure this connection to send data to another
portlet, set this option to "Provider". To configure it
to receive data from another portlet, set it to "Con-
sumer".

Connec-
tion Type

Type a name for the range.

Note:
This name is displayed when you connect portlets
together in portals. If you don't specify a name, the
connection is not available for connecting portlets.

Range
Name

Select from the following options to define the amount
of data to pass:
• Cell -- a single cell from another web part.
• Row -- a single row with multiple columns.
• Table -- multiple rows and columns.

Cell and row are usually used for passing data between
models. In SharePoint, tables are used to pass data from
a Portal list.

Range
Type

Type or click the Cell Selector icon ( ) to select
the area on the embedded spreadsheet where the
incoming data will be retrieved from (provider) or
written to (consumer).

Range

Define the parameter ranges that users can set from
within the portal. To add a range, click the Plus icon,
then select each range and set its name, range, and
type values.

Parameters
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DescriptionOption

Type a name for the parameter or click the Cell Se-
lector icon ( ) to link the name to a cell in the em-
bedded spreadsheet.

Note:
The entered name will appear in the "Property" dialog
box for the model in SharePoint. If you do not enter
a name, the parameter will not be listed as a param-
eter in SharePoint.

Name

Type the area in the spreadsheet where the param-
eters are set or click the Cell Selector icon ( ) to
select the range from the spreadsheet.

Range
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DescriptionOption

Select one of the following parameter types:
• Text - to set text-based data within the XLF, for

example, chart titles.
• Number - to set numeric-based data, for example,

alert levels.
• Check Box - to toggle the value of a cell between

zero and one. This option can be useful for
showing or hiding components using dynamic
visibility.

• Date - to define a date in the XLF. It sets the for-
mat to Date and uses a true date value within the
XLF, for example, users can set date ranges for
data access or for the amount of data to display.

• List Box - to build user selection options into the
parameters. This option allows you to specify set
values that users can select to ensure their entry
is compatible with the model. Text, Number,
Check Box, and Date types do not restrict user
entries.

Type

Available only when List Box is selected in the Type
list.

Set the values users are able to select from the list box.
Click the Cell Selector icon ( ) to select the values from
the embedded spreadsheet.

Entries

Available only when List Box is selected in the Type
list.

Specify the values to use if the user doesn't make a se-
lection in the list box.

Default Se-
lection

4. If you are defining a provider connection, click the Usage tab to set the
refresh options. For more information about setting refresh options, see
To set refresh options.
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Related Topics
• Managing data connections
• Configuring Portal Data connections
• To configure a Portal Data connection for user input

To configure a Portal Data connection for user input
To define parameters that users can customize from within a portal, set up
a Portal Data connection with the Connection Type set to "None".

1. Click Data > Connections.
2. On the "Data Manager" dialog box, click Add and select Portal Data.
3. On the Definition tab, set the following options:

DescriptionOption

To configure this connection for user input, set this
option to "None".

Connec-
tion Type

Define the parameter ranges that users can set from
within the portal. To add a range, click the Plus icon,
then select each range and set its name, range, and
type values.

Parameters

Type a name for the parameter or click the Cell Se-
lector icon ( ) to link the name to a cell in the em-
bedded spreadsheet.

The entered name will appear in the Property dialog box
for the model in SharePoint. If you do not enter a name,
the parameter will not be listed as a parameter in Share-
Point.

Name

Type the area in the spreadsheet where the param-
eters are set or click the Cell Selector icon ( ) to
select the range from the spreadsheet.

Range
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DescriptionOption

Select one of the following parameter types:

DescriptionOption

Sets text-based data within the XLF, for
example, chart titles.

Text

Sets numeric-based data, for example,
alert levels

Number

Toggles the value of a cell between zero
and one. This option can be useful for
showing or hiding components using dy-
namic visibility.

Check
Box

Defines a date in the XLF. It sets the
format to Date and uses a true date value
within the XLF, for example, users can
set date ranges for data access or for the
amount of data to display.

Date

Builds user selection options into the
parameters. This option allows you to
specify set values that users can select
to ensure their entry is compatible with
the model. Text, Number, Check Box,
and Date types do not restrict user en-
tries.

List Box

Type

Available only when List Box is selected in the Type
list.

Set the values users are able to select from the list box.
Click the Cell Selector icon ( ) to select the values from
the embedded spreadsheet.

Entries
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DescriptionOption

Default Se-
lection

Available only when List Box is selected in the Type
list.

Specify the values to use if the user doesn't make a se-
lection in the list box.

Related Topics
• Managing data connections
• Configuring Portal Data connections
• To configure a Portal Data connection for user input

To configure Crystal Reports Data Consumer
connections

You have set up the embedded spreadsheet and components in your model
to correspond to the Crystal Reports data you will be connecting to.

If you want to embed an Xcelsius model in Crystal Reports and receive data
from Crystal Reports for the model, you can add a Crystal Reports Data
Consumer connection.

Note:
You can add only one Crystal Reports Data Consumer connection to a model.

1. Click Data > Connections.
2. On the "Data Manager" dialog box, clickAdd and selectCrystal Reports

Data Consumer.
3. On the Definition tab, set the following options:
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DescriptionOption

Click the Cell Selector icon ( ) to select the row
header labels from the embedded spreadsheet.

Row Head-
ers

Click the Cell Selector icon ( ) to select the column
header labels from the embedded spreadsheet.

Column
Headers

Click the Cell Selector icon ( ) to select the data
range from the embedded spreadsheet.

Data

Type an optional description for the connection.Descrip-
tion

Export the model in Flash (SWF) format and embed the SWF in the Crystal
Reports file. When you open the SWF file with the Flash Data Expert in
Crystal Reports, an Xcelsius tab will be available in the Flash Data Binding
Expert so you can connect the SWF to the Crystal Reports data.

To configure FSCommand connections

FSCommand connections are available in Xcelsius Enterprise only

Note:
In Xcelsius 2008, External Interface connections are the preferred connection
for transferring data in a web browser using JavaScript when the SWF is
embedded in an HTML web page.

For detailed information about FS Command, see the Adobe Flash support
site at http://www.adobe.com/support/flash/action_scripts/actionscript_dictio
nary/actionscript_dictionary372.html

1. Click Data > Connections.
2. On the "Data Manager" dialog box, click Add and then select FS

Command.
3. On the Definition tab, set the following options:
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DescriptionOption

Type a name for the connection.Name

Type a command for the FS Command, or click the
Cell Selector icon ( ) and select a command from
the spreadsheet.

Command

Type a parameter value for the FS Command, or
click the Cell Selector icon ( ) and select a value
from the spreadsheet.

Parameters

Related Topics
• Managing data connections

To configure LCDS connections

The Xcelsius LiveCycle Data Services (LCDS) is installed on your system.
For more information, see the LCDS Installation Guide available in the
Xcelsius LCDS Install Guide available in the LiveCycle Data Services folder
in your Xcelsius Installation Package. And, a model and embedded
spreadsheet are set up and ready to connect to LCDS.

To provide up-to-the-second views of your business data using Adobe
LiveCycle Data Services, a component of Adobe LiveCycle Enterprise Suite
software, add an LCDS connection to your model. The LCDS connection
streams real-time data into your models without users having to request a
data refresh.

1. Click Data > Connections.
2. On the "Data Manager" dialog box, click Add and then select LCDS

Connections.
3. On the Definition tab, set the following options:
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DescriptionOption

In the list, select the LCDS host connection to
associate with this connection or click Host to
add a new host. Then, on the "Manage Hosts"
dialog box, click Add and enter a name for the
host and the URL for the LCDS server using
the following format: http://<server
name>:<port>/<LCDS context path>/xcel-
sius where server name is the name of the
LCDS server, port is the server port number,
and LCDS context path is the context root
for the virtual directory. For example,
http://localhost:8700/flex/xcelsius

Host

To retrieve information about the available feed
destinations from the selected host, clickQuery
.

Query

Select one of the available feed destinations to
bind to the CX model.

Available Data
Destinations

To expand the settings available for the selected
feed destination, click Advanced.

Advanced

Available when you click Advanced.

The identification number of the LCDS feed destina-
tion.

CurrentDestina-
tion ID
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DescriptionOption

Available when you click Advanced.

The type of channel (or communication protocol)
being used.

CurrentDestina-
tion Channel
Type

Available when you click Advanced.

The URL associated with the selected feed destina-
tion.

CurrentDestina-
tion Channel
URL

This section lists the data elements available
from the selected host, their data type (number,
text, or true/false), and their shape or structure
(singleton - a single value, !D - a column or row
of values, or 2D - a table of values).

Select a data element, and then click the Cell Selec-
tor icon ( ) at the bottom right to select the range
in the embedded spreadsheet where the data will
be stored.

Destination Da-
ta

To configure External Interface connections

External Interface connections allow you to expose selected data ranges in
the embedded spreadsheet to an external source so data can be copied to
and from the spreadsheet. Essentially, this creates a generic framework for
moving data into and out of the exported model. It also provides built-in
eventing so the model instantly recognizes when the data source changes.
When you configure the External Interface connection, you specify a name
and define where the values are stored in the spreadsheet.

Caution:
If you include external data connections in models, security restrictions in
Adobe Flash Player may prevent users from accessing the data source. For
more information, see Adobe Flash Player Security Restrictions.

1. Click Data > Connections.
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The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, click Add and select External
Interface.

3. On the Definition tab, set the following options:

DescriptionOption

Type a name for the range.

Use only numbers, letters, and underline. Do not start the
name with a number and do not include spaces in the
name.

Range
Name

Select one of the following options:
• Cell - the range consists of a single cell.
• Row/Column - the range consists of a single row

or column.
• Table - the range consists of more than one col-

umn or row.

Range
Type

Click the Cell Selector icon and select the cells in the
range.

Range

Specifies whether the range is for input, output, or
both. Select one of the following options:
• Read - the external application can read data from

the range.
• Write - the external application can write data to

the cells in the range.
• Read/Write - the external application can read

data in the range, as well as write data to the cells
in the range.

Access

4. Click the Usage tab and set the refresh and message options. For more
information, see To set refresh options and To create load and idle
messages.
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Related Topics
• Managing data connections

Working with Excel XML maps

In Microsoft Excel 2003 and 2007, you can embed XML documents and
schemas into spreadsheets. When you add an XML schema to a spreadsheet,
you create an XML map. The XML map allows you to map cells in the
spreadsheet to elements in the XML schema. These maps can be used to
translate XML content from a remote data source to the rows and columns
of a spreadsheet. If you want to load XML data directly into your model, you
can include XML maps in the embedded spreadsheet in Xcelsius.

By default, XML functionality is not included in the embedded spreadsheet
in Xcelsius. You can define the XML maps in Excel. When you import the
spreadsheet into Xcelsius, it retain the link to the XML source and the cell
mappings to the XML schema. If you want to work with the XML maps directly
in Xcelsius, you can enable the XML features in the embedded software.

Note:
Data that has been mapped using the Excel mapping functionality can be
manually refreshed by using a Connection Refresh button in your model.

Note:
If a Dynamic URL is used with the XML Map feature and an interval refresh,
it must be bound to an Excel cell that contains a formula.

To add Excel XML maps to models
You have set up an XML data source.

To add an XML map to the embedded spreadsheet, you can set up the map
in the Excel spreadsheet and then import the spreadsheet into Xcelsius or,
if XML features are enabled in Xcelsius, you can create the XML map directly
in Xcelsius. For more information about creating Excel XML maps, see the
Microsoft Excel Online Help. Once the map is available in the spreadsheet,
you can add components to the canvas and link them to the spreadsheet,
and add an Excel XML map data connection to retrieve data from the XML
source.
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1. To add an Excel XML map to the embedded spreadsheet, do one of the
following:
• If you set up the XML map in your Excel spreadsheet, import the Excel

spreadsheet. For more information about importing spreadsheets, see
To import Excel spreadsheets.

• To create the XML map directly in Xcelsius:
a. On the embedded spreadsheet, for Excel 2007, click the Developer

tab and then click Import XML Data, or for Excel 2003, on the
toolbar, click the Import XML Data.

b. On the Import XML dialog box, in the File Name list, type the URL
for your XML data source and click Open.

c. If the XML content doesn't incorporate a schema definition, Excel
can create a schema based on the source data. Click OK.

d. On the Import Data dialog box, select where you want to store the
data and click OK.

e. Embed the URL that will be used to fetch data in the underlying
spreadsheet, for example, enter a static query (the same URL used
to import the XML data) in a cell in the spreadsheet.

f. Set up input cells in the spreadsheet and convert the static query
to an interactive query using a formula that reads the values from
the spreadsheet cells.

2. Add components to your model and link them to the cells in the
spreadsheet. For more information about adding components, see Using
Chart components.

3. Click Data > Connections.
4. On the Data Manager dialog box, click Add and select Excel XML Map

Connections.
An Excel XML Map connection is added to the list of connections.

Note:
The Excel XML Map Connections option only adds a connection if an
Excel XML Map is defined in the embedded spreadsheet.

5. On the Definition tab, set the following options:
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DescriptionOption

Type a name for the connection.Name

Select the location where the model will get updated
data. You can map this to the URL where the XML
data is stored or to the cell in the spreadsheet where
you defined an interactive query formula.

XML Data
URL

6. To set the refresh and load status options, click the Usage tab. For more
information about setting these options, see To set refresh optionsand
To create load and idle messages.

7. Save your model and export it to a suitable format.

Enabling XML in the embedded spreadsheet
The Xcelsius embedded spreadsheet does not make all Excel features
available by default. If you want to define XML maps in Xcelsius, you need
to enable XML features in the embedded spreadsheet. The procedure to
enable XML features depends on which version of Excel you are using.

To enable XML features with Excel 2003
In Excel 2003, to use the XML features in Xcelsius, you must add them to
the Excel toolbar.
1. If Xcelsius or Excel are running, close both applications.

Note:
To make sure there are no instances of either program still running, view
the process in the Windows Task Manager. There should be no processes
named Xcelsius or Excel in the list of running processes.

2. Launch Excel 2007.
This should be the only instance of Excel running.

3. In Excel, click Tools > Customize.
4. On the "Customize" dialog box, click the Toolbars tab, click New, and

enter a name for the toolbar, for example, XML Toolbar. Click OK.
An empty, floating toolbar is created.

5. In the "Customize" dialog box, click the Commands tab.
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6. In the "Categories" list, select Data, then in the "Commands" list, select
XML Source, Import XML Data, and XML Map Properties. Drag these
items to the floating toolbar you created in step 4.

7. Drag the floating toolbar and park it along the other Excel toolbars at the
top of your application window, and then close Excel.

The next time you start Xcelsius, the new XML toolbar should be available.

To enable XML features with Excel 2007
In Excel 2007, the XML features are available in the Developer ribbon tab.
1. If Xcelsius or Excel are running, close both applications.

Note:
To make sure there are no instances of either program still running, view
the process in the Windows Task Manager. There should be no processes
named Xcelsius or Excel in the list of running processes.

2. Launch Excel 2007.
This should be the only instance of Excel running.

3. In the main application menu of Excel 2007, click Excel Options.
4. Under Popular options, select Show Developer Tab in the Ribbon and

click OK.

The next time you start Xcelsius, the Developer tab should be available in
the ribbon.

To set refresh options

A data connection has been defined for the models.

If you add a QaaWS, Web Service, XML Data, FS Command, Portal data,
or Live Office connection to a model, you can specify how and when the data
for that connection will be updated for the model.

Note:
If you add a Connection Refresh Button component to a model, you can also
set refresh options for that component. When refresh options are set in the
Data Manager, the data is refreshed when the model runs and before
components are loaded. When refresh options are set for the Connection
Refresh Button, the refresh options are applied when the component loads
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in the model. For more information about using the Connection Refresh
Button component, see Using the Web Connectivity components.

1. Click Data > Connections.
The Data Manager dialog box opens.

2. Click the connection you want to set refresh options for.

Note:
You can only set refresh options for QaaWS, Web Service, XML Data,
FS Command, Portal, and Live Office data connections.

3. Click the Usage tab.
4. On the Usage tab, set the following options:
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DescriptionOption

Note:
For QaaWS, Web Services, XML, and Live
Office data connections only.

Select this option if you want to refresh the
data each time the model loads and use that
data as the initial data for the model (if you
use a Reset Button component, it will reset
the data to the values from the last time the
model was loaded).

Refresh Before
Components are
Loaded

Note:
For SAP NetWeaver BW connections only.

Select this option if you want to refresh the data
each time the model loads.

Use Query De-
fault Data

Note:
For QaaWS, Web Services, and XML Data
connections only.

Select this option to automatically refresh the
data at specific intervals. In the first list, select
the interval value and in the second list, select
the time unit (minutes, seconds, and so on).

Refresh Every

In the Trigger Cell box, type or select the cells
that will trigger a refresh. Then select one of
the following options:
• When Value Changes
• When Value Becomes and enter the value

that will trigger the refresh.

Refresh on Trig-
ger

Related Topics
• Managing data connections
• To configure QaaWS connections
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• To configure Web Service connections
• To configure XML Data connections
• Integrating with SAP NetWeaver BW
• Using Live Office Data Connections

To create load and idle messages

A model has been created and a data connection has been defined for
QaaWS, Web Services, or XML Data.

When you create a model that has a QaaWS, Web Services, or XML Data
connection, you can define messages that will be displayed while the model
loads or is idle. You can also specify whether the cursor will be visible during
loading and whether mouse input will be available.

1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. Click the connection you want to set messages for and click the Usage
tab.

3. Under Load Status, set the following options:
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DescriptionOption

Type or select a message to display while the
model is loading.

Loading Mes-
sage

Type or select a message to display while the
model is idle.

Idle Message

Type or use the Cell Selector icon ( ) to select
the cells in the embedded spreadsheet where the
loading and idle messages will be inserted.

Insert In

Select this option to display the cursor while the
model is loading.

Enable Load
Cursor

Select this option to prevent users from entering
mouse input while the model is loading.

Disable
Mouse Input
on Load

Related Topics
• Managing data connections
• To configure QaaWS connections
• To configure Web Service connections
• To configure XML Data connections
• Integrating with SAP NetWeaver BW
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Integrating with the SAP Data Sources

Integratingwith the SAPBusinessObjects
Enterprise

Xcelsius Enterprise enables you to create interactive presentations from
managed SAP BusinessObjects Enterprise data using SAP BusinessObjects
Live Office connections. You can also store and manage XLF and SWF files
on the SAP BusinessObjects Enterprise or Crystal Reports Server where
any user with appropriate permissions can view the XLF and SWF files.

Restriction:
Xcelsius supports managed Crystal reports only. If you have unmanaged
files, you must move them to a managed environment to refresh SAP
BusinessObjects Live Office connections in Xcelsius. For more information
about moving to a managed environment, see "Best Practices for Prompting"
in the Crystal Reports User's Guide available at help.sap.com.

Using the Live Office connections in SAP BusinessObjects Xcelsius Enterprise
and the Live Office Web Services in SAP BusinessObjects Enterprise XI
Release 2 (XI R2) or Crystal Reports Server XI R2, you can create and
refresh models against managed Enterprise data.

Note:

• The functionality discussed in this chapter is only supported in SAP
BusinessObjects Enterprise XI R2 and Crystal Reports Server XI R2.

• Single Sign-on is not supported.

Using Live Office Data Connections

Live Office Data Connections allow you to create models using Excel
spreadsheets constructed from managed Crystal Reports or Web Intelligence
data and refresh that data in the model from within InfoView or, with a
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connection to the Crystal Reports Server or SAP Enterprise system, from
outside InfoView.

Before you can add a Live Office data connection to your model, you must
have a Live Office-enabled spreadsheet. A Live Office-enabled spreadsheet
includes data that is actually a View created from either a managed Crystal
Reports document or a managed Web Intelligence document. You can
created Live Office-enabled spreadsheets in Microsoft Excel outside of
Xcelsius and then import them into models to add Live Office data
connections.

If you want to work with Live Office in Xcelsius, you must have Live Office
installed and, in Xcelsius, Live Office Compatibility mode must be enabled.
For more information about enabling Live Office Compatibility mode, see To
set preferences for the embedded spreadsheet .

To add and configure Live Office data connections

SAP BusinessObjects Live Office is installed on your machine and a Live
Office-enabled spreadsheet has been created or imported in Xcelsius.

Use a Live Office data connection when you want to use data from managed
Crystal Reports or Web intelligence documents in a model and make it
refreshable against the source data.

Note:
The Live Office data connection option is not available until a Live
Office-enabled spreadsheet is added to Xcelsius.

1. Click Data > Connections.
2. On the "Data Manager" dialog box, click Add and select Live Office.
3. On the Definition tab, set the following options:
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DescriptionOption

Displays the name of the Live Office connection.Name

If your SAP BusinessObjects Enterprise or Crystal
Reports Server has a default Web Services installa-
tion, replace the webserver in this default URL with
the name of your Central Management Console
(CMC)

Session
URL

This option controls how many rows of data are re-
turned.

Note:
It does not affect the number of columns.

Ranges

4. Click the Usage tab and set the refresh and message options. For more
information, see To set refresh options and To create load and idle
messages.

The model is connected to a Live Office data source and, at runtime, the
data will refresh as defined in the refresh options settings.

Passing parameters to Live Office

When a model has a Live Office data connection, you can set up the model
to insert data into the spreadsheet and pass those values back to Live Office
to retrieve specific data from the data source.

To pass parameters to Live Office
A model has been created with a Live Office-enabled spreadsheet, a Live
Office data connection, and it requires user input for the parameters when
it is refreshed.

When you adjust the Single Value component in the SWF file, you receive
a prompt to log on to your Enterprise system. When you have successfully
logged on, the data is refreshed and the new value or values are reflected
in your SWF file.

1. Place a Single Value component such as a dial or a slider on the canvas.
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2. On the General view of the Single Values properties browser, click the
Cell Selector button next to the Data field.

3. Click the cell that contains the bound parameter and then click OK.
4. Add and configure a Live Office connection. For more information, see

To add and configure Live Office data connections.
5. On the Usage tab, click the Cell Selector button beside the Trigger Cell

field.
6. Click the cell that contains the bound parameter and then click OK.
7. Ensure that Trigger on Change only is selected.

Configuring the Trigger Behavior this way causes the SWF to refresh
each time there is a change to the cell and in this case, the parameter
value.

8. Click the Preview button to generate a SWF file.

Updating LiveOffice connection settings after system
migration

When content is migrated from one SAP BusinessObjects Enterprise system
to another, the location of the Live Office Web Service changes. When the
Web Service location changes, the configuration of the Live Office data
connection will no longer be correct and you will not be able to refresh the
model data.

To update the Live Office Web Services location for the model without having
to open each individual file, you can modify web.config file or web.xml file
directly.

Note:
Editing the web.config or web.xml file incorrectly can lead to unexpected
behavior. Before making any changes to these files, make a back up of them.

To update web.config files for .NET InfoView
1. Locate web.config at the following location: <drive>:\Program

Files\Business Objects\BusinessObjects Enterprise
11.5\Web Content\Enterprise115\InfoView\web.config

2. Open web.config in a text editor such as Notepad.
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3. Search for the following text at the end of file:

<appSettings>
<add key="applications" value="com.businessobjects.
encyclopedia.reportviewer.wrapper.InfoViewPanel, ana
lyticwrapper"/>

4. When you find this text, add the following text below it:

<add key="webConnectorUrl" value="http://webser
vice:port/dswsbobje/services/session"></add>

Where webservice represents the name of your web service and port
represents the port number that the web server communicates on.

5. Save the file.

This setting overrides the setting that is in Xcelsius 2008.

To update the web.xml file for Java InfoView
1. Locate web.xml at the following location:C:\Program Files\Busi

ness Objects\<web server>\webapps\businessobjects\en
terprise115\desktoplaunch\WEB-INF\web.xml.

Where <web server> is the name of your web server.

2. Open web.xml in a text editor such as Notepad.
3. Search for the following text at the end of file:

<context-param>
<param-name>crystalXcelsius 2008.webconnec
torurl</param-name>

4. When you find this text, add the following text below it:

<param-value>http://webservice:port/dswsbobje/ser
vices/session</param-value>

Where webservice is the name of your web service and port is the
port number that the web server communicates on.

5. Save the file.

This setting overrides the setting that is in Xcelsius 2008.
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Launching InfoView documents from models

Xcelsius models stored in InfoView can be configured to open reports or
other documents that are also in InfoView. To do this, you must add the
OpenDocument API (Application Programming Interface) to the URL that is
used to call the document.

The OpenDocument API provides a standard method for opening documents
and reports that have been published to SAP BusinessObjects Enterprise
using a simple URL. OpenDocument allows you to specify, not only the
report, but also report parameters so the report returns only the desired data.

You can enter the URL directly into the URL field of a URL Button component
in the model or, to allow users to change the URL dynamically, configure the
URL Button component to retrieve the URL from a cell in the embedded
spreadsheet. Then configure the Selector component to enter different URLs
in that cell when the user makes a selection.

Note:
OpenDocument launches the report or document in a separate browser
window.

Tip:
You can also use OpenDocument with primary models that are not in
InfoView, if they have secondary files in InfoView. The user will be prompted
for InfoView credentials prior to launching the document.

For more information about URL reporting using OpenDocument, see the
Viewing Reports and Documents using URLs guide.

URL syntax for openDocument in SAP BusinessObjects XIR2

http://<server>:<port>/businessobjects/enter
prise115/<platformSpecific>?sDocName=<document
name>&sPath=<path>&sRepoType=corporate&sType=<document
type>&<parameter1>&<paramter2>&...&<parameterN>

Replace the variables as indicated in the following table:
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Replace withVariable

The name of the machine that
houses the SAP BusinessObjects
Enterprise repository where the
document is stored.

<server>

Since there are two implementa-
tions of the openDocument func-
tion (for JSP and ASPX), the ex-
act syntax of this parameter de-
pends on your implementation:
• For Java deployments, use

openDocument.jsp

• For .NET deployments, use
opendocument.aspx

<platformSpecific>

The type of document you are
opening. For example, use rpt for
a Crystal report and wid for a
Web Intelligence document.

<document type>

When using the sPath parameter,
replace <path> with the path to
the document in the repository.
Enclose each subfolder name in
square brackets, and separate
subfolder names with commas.

Note:
Replace any spaces with plus
signs.

<path>
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Replace withVariable

When using the sDocName pa-
rameter, replace <document
name> with the name of the doc-
ument in the repository.

Note:
Replace any spaces with plus
signs.

<document name>

Note:
Do not add [Public+Folders] to the path; start with the name of the first
subfolder within Public Folders.

Public Folders
folder 1
folder 1.1

folder 1.1.1

If your document is in folder 1.1.1, you would set sPath to: [fold
er+1],[folder+1.1],[folder+1.1.1].

Example: Using Opendoc.jsp

http://cdi5boe:8080/businessobjects/enterprise115/desk
toplaunch/opendoc/openDocument.jsp?sType=rpt&sRepo
Type=corporate&sPath=[folder],[subfolder1],[subfold
er2]&sDocName=ReportName&IsSpromptName1=promptValue1

URL syntax for openDocument in SAP BusinessObjects XI3x

http://<server>:<port>/OpenDocument/opendoc/<platformSpe
cific>?sIDType=CUID&sType=<document type>&iDocID=<docu
ment ID>&<parameter1>&<parameter2>&...&<parameterN>

Replace the variables as indicated in the following table:
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Replace withVariable

The name of the machine that
houses the SAP BusinessOb-
jects Enterprise repository where
the document is stored.

<server>

<port>

Depending on your SAP Busines-
sObjects Enterprise deployment,
use one of the following:
• For Java deployments, use

openDocument.jsp

• For .NET deployments, use
opendocument.aspx

<platformSpecific>

When using the iDocID parame-
ter, replace <document ID>
with the document CUID number
of the document.

Note:
In InfoView XI3x when you view the
document properties you can also
see the document CUID.

The CUID is unique so there is no
need to use sDocumentName or
sPath when using a CUID.

When you migrate your document
from one system to another the
CUID stays the same, which is why
it is best to use the CUID.

<document ID>
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Replace withVariable

The type of document you are
opening. For example, enter rpt for
a Crystal report and wid for a Web
Intelligence document

<document type>

<parameters>

Example: Using iDocID to open a Crystal report by its document CUID
http://olapserver1:8080/OpenDocument/opendoc/openDocu
ment.jsp?sType=rpt&sIDType=CUID&iDocID=1234

Opening InfoView SWFs from Xcelsius models

Xcelsius models stored in InfoView can be configured to open SWF files that
are also in InfoView. To do this, you must add the DocumentDownload
function to the URL that is used to call the file. The DocumentDownload
function provides a standard way of opening SWF files that have been
published to SAP BusinessObjects Enterprise.

DocumentDownload opens the secondary SWF file within Xcelsius, for
example in a Slide Show component, which is useful when creating a "nested"
or "parent-child" model within InfoView.

Note:
• Logon credentials are not passed from the parent Xcelsius model file

when calling a secondary SWF file. To send logon credentials from
DocumentDownload, append CELogonToken to the URL.

Tip:
To obtain the document ID, navigate to the document in InfoView, move your
mouse over the document name hyperlink, and look for the ID number in the
browser's status bar. You can also obtain the document ID from the Central
Management console.
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URL syntax for DocumentDownload in SAP BusinessObjects XIR2

http://<server>:<port>/businessobjects/enterprise115/desk
toplaunch/opendoc/documentDownload?<parameter1>&<parame
ter2>&...&<parameterN>&CELogonToken=<token>

Replace the variables as indicated in the following table:

Replace withVariable

The name and port of the ma-
chine that houses the SAP Busi-
nessObjects Enterprise repository
where the document is stored.

<server:port>

Since there are two implementa-
tions of the openDocument func-
tion (for JSP and ASPX), the ex-
act syntax of this parameter de-
pends on your implementation:
• For Java deployments, use

openDocument.jsp

• For .NET deployments, use
opendocument.aspx

<platformSpecific>

When using the iDocID parame-
ter, replace <document ID>
with the document ID number of
the document.

<document ID>

When using the sPath parameter,
replace <path> with the path to
the document in the repository.
Enclose each subfolder name in
brackets, and separate subfolder
names with commas.

Note:
Replace any spaces with plus
signs.

<path>
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Replace withVariable

When using the sDocName pa-
rameter, replace <document
name> with the name of the doc-
ument in the repository.

Note:
Replace any spaces with plus
signs.

<document name>

Note:
Do not add [Public+Folders] to the path; start with the name of the first
subfolder within Public Folders.

Public Folders
folder 1
folder 1.1

folder 1.1.1

If your document is in folder 1.1.1, you would set sPath to: [fold
er+1],[folder+1.1],[folder+1.1.1].

Example: DocumentDownload URL for SAP BusinessObjects XIR2

http://cdi5boe:8080/ businessobjects/enterprise115/desk
toplaunch/opendoc/documentDownload?iDo
cID=10348&sKind=Flash&CELogonToken=SERV
ER%408757Jxnge3URUJ8L4

The following table identifies each of the parameters used in the sample
URL. Sections in bold need to be customized to the file. Parameters marked
with an asterisk (*) are required with the documentDownload function :

http://

(can be https://)
Proto
col:
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cdi5boe:Server
name:

8080/Port:

businessobjects/enterprise115/desktoplaunch/open
doc/documentDownload?

Func
tion:

iDocID=10348&

Note:
iDocID is the ID or the CUID of the SWF file.

Docu-
ment
ID*:

sKind=Flash&

Note:
sKind must be Flash.

File
Type*:

CELogonToken=SERVER%408757JxmheURUJ8L4
Logon
Creden
tials*:

URL syntax for DocumentDownload in SAP BusinessObjects XI3x

Note:
Additional parameters can be passed into the SWF file by adding FlashVar
ranges to the URL, for example: "Range1=yyy&Range2=zzz&"

To pass the CELogonToken from the parent model to a child SWF, a Flash
Variable connection must be added to the child model. Open the Data
Manager, click Add, and select Flash Variables. In addition to the connection
required for the CELogonToken, any additional parameters must have Flash
Variable connections. Any additional parameters are converted to FlashVars
by the Flash Player. For more information about configuring Flash Variable
connections, see To configure Flash variable connections.
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You can enter the URL directly into the URL field of a Slide Show component
in the model or, to allow users to change the URL dynamically, configure the
Slide Show component to retrieve the URL from a cell in the embedded
spreadsheet. Then configure the Selector component using the Excel
CONCATENATE function, to enter different URLs in that cell when the user
makes a selection.

http://<server>:<port> /OpenDocument/opendoc/<platform
Specific>?sType=amw&sIDType=InfoObject&iDocID=<document
ID>&sPath=<path>&sDocName=<document name>

Replace the variables as indicated in the following table:

Replace withVariable

The name of the machine that
houses the SAP BusinessOb-
jects Enterprise repository where
the document is stored.

<server>

<port>

Depending on your SAP Busines-
sObjects Enterprise deployment,
use one of the following:
• For Java deployments, use

openDocument.jsp

• For .NET deployments, use
opendocument.aspx

<platformSpecific>

When using the iDocID parame-
ter, replace <document ID>
with the document ID number of
the document.

Note:
You can use the sDocName
(document name) parameter as
an alternative to the iDocID.

<document ID>

324

Integrating with the SAP Data Sources



Replace withVariable

When using the sPath parame-
ter, replace <path>with the path
to the document in the repository.
Enclose each subfolder name in
brackets, and separate subfolder
names with commas.

Note:
Replace any spaces with plus
signs.

<path>

When using the sDocName pa-
rameter, replace <document
name> with the name of the
document in the repository.

Note:
Replace any spaces with plus
signs.

<document name>

Note:
Do not add [Public+Folders] to the path; start with the name of the first
subfolder within Public Folders.

Public Folders
folder 1
folder 1.1

folder 1.1.1

If your document is in folder 1.1.1, you would set sPath to: [fold
er+1],[folder+1.1],[folder+1.1.1].
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Storing models in SAP BusinessObjects
Enterprise systems

You can store and manage Xcelsius XLF and SWF files on SAP
BusinessObjects Enterprise or Crystal Reports Server.

Once the files are added to the Enterprise system, any user with appropriate
permissions can access the files. You can manage files saved to the
Enterprise system through InfoView and the Central Management Console
(CMC).

In InfoView, you can:
• View a list of your XLF and SWF files.

• Search for specific files.

• Move or copy files to different folders.

• View and refresh SWF files in InfoView.

If you have administrative rights on the Enterprise system, you can also
modify the edit and view rights for XLF and SWF files within the Central
Management Console (CMC).

Note:
You cannot view XLF files in InfoView. To view XLF files that have been
added to the Enterprise system, you must open the XLF file within Xcelsius.
For more information, see To open XLF files from Enterprise folders.

In Crystal Reports 2008, you can also embed an Xcelsius SWF file in a
Crystal report and have the SWF use data from that report. To set up the
SWF to use source data from a Crystal report, add a Crystal Reports Data
Consumer connection to the model. For more information about configuring
this data connection, see To configure Crystal Reports Data Consumer
connections.

When you export the model as an SWF file, you can embed the SWF into
the Crystal Reports source data file. For more information about working
with Crystal Reports, see the Crystal Reports 2008 User Guide.
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To save Xcelsius files to Enterprise folders

1. Click File > Save to Platform.

The "Log On to BusinessObjects Enterprise" dialog box opens.

2. On the "Log On to BusinessObjects Enterprise" dialog box, enter the
following information:

DescriptionOption

Type the name of the Central Management console
(CMC) where you want to save the XLF file.

The CMC stores information about the objects saved to
the Enterprise system. For more information about the
CMC, refer to the SAP BusinessObjects Enterprise or
Crystal Reports Server documentation available n the
SAP Help Portal (help.sap.com).

System

Type your logon name.User name

Type you password.Password

Click the appropriate authentication type.

Note:
If you are unsure of your logon information, contact
your system administrator.

Authentica-
tion

3. Click OK.
4. Select the folder where you want to save the XLF file, enter a file name,

and click Save.

Tip:
To add a folder to the CMC, click New Folder.

To open XLF files from Enterprise folders

1. Click File > Open from Enterprise.
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2. On the "Log On to BusinessObjects Enterprise" dialog box, enter the
following information:

DescriptionOption

Type the name of the Central Management console
(CMC) where you want to save the XLF file.

The CMC stores information about the objects saved to
the Enterprise system. For more information about the
CMC, refer to the SAP BusinessObjects Enterprise or
Crystal Reports Server documentation available on the
SAP Help Portal (help.sap.com).

System

Type your logon name.User name

Type you password.Password

Click the appropriate authentication type.

Note:
If you are unsure of your logon information, contact
your system administrator.

Authentica-
tion

3. Click OK.
4. In the "Open" dialog box, select the folder that contains the file you want

to open. Click Open.

The XLF file opens in Xcelsius.

To export models to Enterprise folders

A model has been created and is open on the canvas.

1. Click File > Export > BusinessObjects Platform.

The "Log On to BusinessObjects Enterprise" dialog box appears.

2. On the "Log On to BusinessObjects Enterprise" dialog box, enter the
following information:
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DescriptionOption

Type the name of the Central Management console
(CMC) where you want to save the XLF file.

The CMC stores information about the objects saved to
the Enterprise system. For more information about the
CMC, refer to the SAP BusinessObjects Enterprise or
Crystal Reports Server documentation available on the
SAP Help Portal (help.sap.com).

System

Type your logon name.User name

Type you password.Password

Click the appropriate authentication type.

Note:
If you are unsure of your logon information, contact
your system administrator.

Authentica-
tion

3. Click OK.
4. In the "Save As" dialog box, select the folder that you want to export the

SWF file to, enter a file name, and click Save.

The model is exported to the Enterprise repository as an SWF file.

Integrating with SAP NetWeaver BW
In SAP BusinessObjects Xcelsius Enterprise, you can use Business Explorer
(BEx) queries or query views as data sources for Xcelsius models. You can
add one or more data connections to SAP NetWeaver BW, configure the
connection and link it to components, and then publish your model on the
SAP NetWeaver BW system as BW Objects (TLOGO objects). Published
Flash models can be assigned to NetWeaver Enterprise Portal roles and
accessed through an iView. These models support lifecycle through Data
Warehousing transport of BW Objects.

The SAP NetWeaver BW connection returns a snapshot of the BEx query
pivot result set, as well as the keys and value helps for the characteristics
and variables in one request.
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Note:

• Business Data Warehouse level authorization applies.
• To run BEx queries, Xcelsius requires the BEx Web run-time environment,

which is not available when previewing models in Xcelsius or when models
are deployed in desktop applications like Microsoft PowerPoint or Adobe
PDF. If you include SAP NetWeaver BW connections in your Xcelsius
model, you can preview them through the NetWeaver portal launch URL
command.

In addition, the connection provides metadata, such as the query and
InfoProvider names, query filters, key date, refresh date, hierarchies, and
the current message log.

Before connecting to SAP NetWeaver BW
systems

Before connecting to SAP NetWeaver BW, you must install SAP NetWeaver
BW 7.0 Enhancement Pack 1 Service Pack 5 on the same machine as SAP
BusinessObjects Xcelsius. Xcelsius requires both Java and ABAP to connect
to NetWeaver SAP Ehp1 SP5 for SAP NetWeaver 7.0. You must also set
up user mapping to configure Single Sign-On (SSO) between the NetWeaver
Java Application Server and the NetWeaver ABAP system. For more
information, see the SAP NetWeaver BW documentation available at
help.sap.com.

Note:
To allow Xcelsius to retrieve data, the SAP NetWeaver Business Warehouse
and BEx queries must be available.

Related Topics
• To connect to SAP NetWeaver BW systems
• To connect to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To disconnect from the SAP NetWeaver BW system
• To publish Xcelsius models to SAP NetWeaver BW systems
• To preview Xcelsius models with SAP NetWeaver BW data
• To open XLF files from SAP NetWeaver BW servers
• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

330

Integrating with the SAP Data Sources

http://help.sap.com/saphelp_nwmobile71/helpdata/en/4d/dd9b9ce80311d5995500508b6b8b11/content.htm


To connect to SAP NetWeaver BW systems

SAP NetWeaver BW 7.0 Enhancement Pack 1 Service Pack 5, BW and BW
Java are installed on your machine.

When you enter a command that requires a connection to the SAP NetWeaver
BW system, Xcelsius attempts to connect to the system automatically. If
authorization is required, you are prompted to log onto the SAP NetWeaver
BW system. The following actions require a connection to the SAP NetWeaver
BW system:
• Click SAP > Open
• Click SAP > Publish
• Click SAP > Publish As
• Click Data > Connections and add and configure an SAP NetWeaver

BW connection

Note:
If Single Sign-On has been set up between SAP NetWeaver Java AS and
SAP NetWeaver ABAP, you are prompted for authorization only once by
Xcelsius.

Related Topics
• Before connecting to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To disconnect from the SAP NetWeaver BW system
• To publish Xcelsius models to SAP NetWeaver BW systems
• To preview Xcelsius models with SAP NetWeaver BW data
• To open XLF files from SAP NetWeaver BW servers
• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

To disconnect from the SAP NetWeaver BW
system

You are connected to an SAP NetWeaver BW system.
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If you are connected to an SAP NetWeaver BW system, you can connect
and publish to that system. If you want to connect or publish to a different
SAP NetWeaver BW system, you must first disconnect from the current SAP
system.

1. Click SAP > Disconnect.
2. Click OK.

The connection with the SAP NetWeaver BW system ends. You can now
connect to a different SAP system or change the user authentication.
Related Topics
• Before connecting to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To connect to SAP NetWeaver BW systems
• To publish Xcelsius models to SAP NetWeaver BW systems
• To preview Xcelsius models with SAP NetWeaver BW data
• To open XLF files from SAP NetWeaver BW servers
• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

To configure SAP NetWeaver BW connections

SAP NetWeaver BW 7.0 Enhancement Pack 1 Service Pack 5 is installed
on your local machine and the model you want to add the connection to has
been designed and is open on the canvas.

Use the SAP NetWeaver BW connection to create a connection to the
Business Warehouse data.

Note:
In addition to the items you configure and preview when you set up an SAP
NetWeaver BW connection, the returned result set will include at least two
rows of data that provide more details about the results. For example, these
rows contain the labels, as well as information about the unit and scaling of
the keyfigure. The result set also includes a row representing the Overall
Result. If you don't want the result set to include the Overall Result row, in
the BW query add the option Result Rows to the option Always Suppress
for each characteristic.
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1. Click Data > Connections.
The "Data Manager" dialog box opens.

2. On the "Data Manager" dialog box, clickAdd and select SAPNetWeaver
BW Connection.

3. On the Definition tab, set the following options:
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DescriptionOption

A name for the connection.Name

The name of the SAP system you are currently con-
nected to.

Note:
You can connect different components in a model to
different queries or query views, but all queries and
query views must be on the same SAP system.

System

The name of the query or query view that is currently
selected. Click Browse to select a different query or
query view on the connected SAP system.

Query

From the list, selected one of the following options
to set the format for retrieved data:
• Raw — data is not formatted. This option is best

for use in charts or with Excel calculations.
• Formatted — data uses the BEx format and in-

cludes information such as sealing factor, number
of decimals, currency, and sign change. This op-
tion is best for use with text-based components,
such as Label, Spreadsheet, Table, Scorecard,
and so on.

Return Da-
ta As

Input Val-
ues
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DescriptionOption

Lists the input-enabled values and selectable character-
istics that are available to customize the data returned
from the query or query view.

DescriptionInput

Lists the characteristics and key figures
included in the query and that are avail-
able to filter the data returned from the
query or query view. Use filters to allow
model users to navigate into slices of the
overall dataset.

Filters

Set the values for mandatory and option-
al query variables.

Note:
Mandatory variables are initialized before
the Flash file loads are displayed through
standard BEx dialogs.

Vari-
ables

To set a value for each input, select the input object from
this list and then in the Read From box, type a value or
click the Cell Selector icon ( ) to select a cell from the
embedded spreadsheet where the selected object will
retrieve its value.

Output Val-
ues
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DescriptionOption

Lists the values returned by the query or query view,
as well as any filters that can be applied to the data
after it is returned.

DescriptionOutput

Returns a snapshot of the query or query
view pivot table. The Header rows con-
tain information about unit and currency,

Cross-
tab data

as well as the scaling factor. Basic, re-
stricted, and calculated key figures are
available cross-tab data. Cross-tab data
reflects the Characteristics Value Display
settings, such as Result Rows or Sort
Characteristics.

Returns characteristics and structures
the value help text and keys for the filters
applied in the Input Values box, and the
hierarchy information.

Each characteristic includes the following
items:

DescriptionItem

Charac-
teristics

Represents the
description of the
characteristic.

Label

Represents the
technical name for
the characteristic.

Display String

Shows the current
filter selection for
the characteristic.

Input String
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DescriptionOption

DescriptionOutput

DescriptionItem

Members Value
Help

The options avail-
able under this
category depend
on the InfoObject.
They represent
the options for the
characteristic's
descriptions and
all the available
display attributes.

You can use this
options to create a
list box to allow
users to select val-
ues.

Returns the variable help texts and keys,
as well as the applied filters.

Vari-
ables

Returns any restrictions defined in the
BEx query designer. These restrictions
cannot be changed within Xcelsius.

Static Fil-
ters

Returns general query text elements,
such as name, last refresh and data up-
date, and key date value.

Note:
Key date value cannot be set through the
Xcelsius BEx query connection.

Informa-
tion
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DescriptionOption

DescriptionOutput

Message Returns error text messages from the
SAP NetWeaver BW system.

To set a location to store each output value, select the
output object from this list and then, in the Insert In box,
click the Cell Selector icon to select a cell from the
embedded spreadsheet to store the values retrieved from
the query or query view.

Note:
By default, Xcelsius allows up to 512 rows to be retrieved
and inserted into the embedded spreadsheet. To increase
the number of rows allowed, see To set preferences for
the embedded spreadsheet .

4. Click the Data Preview tab.
5. Click Refresh Data Preview.

The sample data is generated and displayed to show the data structure.

Note:
The data preview does not retrieve data from the BEx query, and filters
and parameters set on the Definition tab are not applied.

6. View and adjust the data structure as desired using the following options:
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DescriptionOption

Expand the tree to show the Columns, Rows, and
Free Characteristics. By default, they are set as they
were defined in the BEx query designer.

Tree view
in left pan-
el

To change the order of the data, select an item in
the tree and click the Up or Down buttons to move
the item up or down one position within the list. After
changing the order of items, click the Refresh Data
Preview button to see the changes.

Up and
Down but-
tons

To move items to different structure element, drag
the item to the new location or select the item and

click the Move Item menu icon ( ) , then click
one of the following options:
• Move to Columns -- moves the data to a column

structure.
• Move to Rows -- move the data to a row structure.
• Move to Free Characteristics -- moves the data

to a free characteristic structure.
• Reset Query Defaults -- sets the structure back

to how it was defined in the query.

After changing the order of items, click the Refresh Data
Preview button to see the changes.

Move Item
menu

7. Click the Usage tab to set the refresh and message options.

Caution:
TheRefreshBefore Components are Loaded option executes the query
for the first time before any input value filters can be specified by the user.
To avoid retrieving large amounts of data, check the Use Default Query
Data option to use the BEx query default values.

For more information about setting refresh and message options, see To
set refresh optionsand To create load and idle messages.

Once your model is configured and connected to the SAP NetWeaver BW
system, you can publish it to the SAP system.
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Related Topics
• Before connecting to SAP NetWeaver BW systems
• To connect to SAP NetWeaver BW systems
• To disconnect from the SAP NetWeaver BW system
• To publish Xcelsius models to SAP NetWeaver BW systems
• To preview Xcelsius models with SAP NetWeaver BW data
• To open XLF files from SAP NetWeaver BW servers
• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

To publish Xcelsius models to SAP NetWeaver
BW systems

SAP NetWeaver BW 7.0 Enhancement Pack 1 Service Pack 5 is installed
on the same machine as Xcelsius, you are connected to the SAP NetWeaver
BW system, and the model you want to publish has one or more SAP
NetWeaver BW connections and is open on the canvas.

Use this option to generate a SWF and publish the Xcelsius model to the
SAP NetWeaver BW system. Publishing a model allows it to be transported
and translated like other BEx Objects. When a model is published, Xcelsius
publishes three files: the XLF, an SWF, and a TXT file. The TXT file is
required for translation on the SAP NetWeaver BW system.

Note:
You must publish the Xcelsius model on the same SAP system that the SAP
NetWeaver BW Query connections connect to.

1. Do one of the following:
• To save a new model, click SAP > Publish.
• To save an existing model with a different name or location, click SAP

> Publish As.

2. If you are not connected to the SAP system, the "SAP Logon" dialog box
opens. Select the appropriate SAP system and enter your credentials.
Click OK.
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Note:
If you are connected to a different SAP system than you want to publish
to, you must disconnect from the SAP network before continuing these
steps.

The "Open" dialog box opens.

3. Navigate to the location you want to save the file and enter a filename.
Click OK.

The SWF file is published to the SAP NetWeaver ABAP system.
Related Topics
• Before connecting to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To connect to SAP NetWeaver BW systems
• To disconnect from the SAP NetWeaver BW system
• To preview Xcelsius models with SAP NetWeaver BW data
• To open XLF files from SAP NetWeaver BW servers
• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

To preview Xcelsius models with SAP
NetWeaver BW data

An Xcelsius model with an SAP NetWeaver BW connection has been
published to an SAP system.

Use this procedure when you want to preview a model with data from the
connected SAP system. When you use the Preview button, you can see the
model configuration and test basic workflow, but the data from the SAP
NetWeaver BW queries and query view result sets are not available.

1. Click SAP > Launch.
A web browser session opens with the SAP NetWeaver Portal Logon
screen.

2. Enter your portal credentials and click Login.
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Once you are logged in, the Xcelsius model loads inside a dashboard BW
template, which contains a single model. You can use this URL in an iView
template to add the model to a SAP NetWeaver Portal role.
Related Topics
• Before connecting to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To connect to SAP NetWeaver BW systems
• To disconnect from the SAP NetWeaver BW system
• To publish Xcelsius models to SAP NetWeaver BW systems
• To open XLF files from SAP NetWeaver BW servers
• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

To open XLF files from SAP NetWeaver BW
servers

SAP NetWeaver BW 7.0 Enhancement Pack 1 Service Pack 5 is installed
on the same machine as Xcelsius, you are connected to the SAP NetWeaver
BW system, and the model you want to open has been published to the SAP
NetWeaver BW server.

1. Click SAP > Open.
2. The "SAP Logon" dialog box opens. Select the appropriate SAP system

and enter your credentials. Click OK.
The "Open" dialog box opens.

3. Select the model XLF file that you want to open. OK.

Related Topics
• Before connecting to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To connect to SAP NetWeaver BW systems
• To disconnect from the SAP NetWeaver BW system
• To publish Xcelsius models to SAP NetWeaver BW systems
• To preview Xcelsius models with SAP NetWeaver BW data
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• Translating and globalizing Xcelsius models on SAP NetWeaver BW
systems

Translating and globalizing Xcelsiusmodels on
SAP NetWeaver BW systems

When you save a model to an SAP system, you can enable translation
settings so text in the model can be translated as BW Objects. When text is
translated, the string length may change, which could affect the layout and
design of the model. For example, a model designed in English might contain
a label for "Sales", which is five characters. When translated into German,
the label would be "Verkaufe", which is eight characters. These additional
three characters might affect the layout of the label and fields around it. You
can limit this impact when you set up translation by setting a limit for the
number of characters in each string.

Xcelsius Enterprise also displays numeric, currency, data, and time values
in a format specific to the location set based on the SAP NetWeaver BW
user locale. The following Excel-formatted elements can also be changed
dynamically based on your SAP profile locale when running the SWF file:

ExampleElement

January, February, MarchLong Month

Jan, Feb, MarShort Month

Sunday, Monday, TuesdayLong Day

Sun, Mon, TueShort Day

“/” as in 01/01/1900Date Separator

“:” as in 12:00:00Time Separator
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ExampleElement

“.” as in 1.5Decimal Separator

“,” as in 1,000,000Thousands Separator

£100, 50¢, 10F50Currency Symbol

The following restrictions apply to Xcelsius Enterprise globalization settings:
• The order that value elements appear are not changed at runtime, even

if the location setting where the model runs uses a different element order.
For example, if the model is created in an operating system where the
location settings use the date format MM/DD/YYYY. When the model is
run in an environment that uses the date format, DD/MM/YYYY, the order
of the month and day are not updated for the new location. This restriction
also applies to whether currency symbols are at the front or the end of
the value.

• Only values that are in the embedded spreadsheet are globalized. If
values are manually entered into the "Properties" panel or into the SWF
at runtime, those values are not changed according to the location setting
when the model runs.

• When designing and editing models, changing location settings does not
affect existing, bound components. If you change the location setting and
want the change to apply to existing components, you must rebind the
components to the embedded spreadsheet.

• If a region-specific format is applied to cells in the embedded spreadsheet,
the format for those cells does not change when the model is run in a
different location. For example, in Microsoft Excel, when you apply the
Currency format, you can choose None, a plain symbol, or symbols
associated with a specific region. If you select the plain symbol, for
example €, the symbol changes depending on the location setting when
the model runs. But, if you choose a symbol for a specific region, for
example € French (France), the symbol does not change when the model
is run in a different location.

Related Topics
• Before connecting to SAP NetWeaver BW systems
• To configure SAP NetWeaver BW connections
• To connect to SAP NetWeaver BW systems
• To disconnect from the SAP NetWeaver BW system
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• To publish Xcelsius models to SAP NetWeaver BW systems
• To preview Xcelsius models with SAP NetWeaver BW data
• To open XLF files from SAP NetWeaver BW servers

To set up translation for Xcelsius models on SAP
NetWeaver BW systems

A model has a SAP NetWeaver BW connection, is open on the canvas, and
is meant to be published to the SAP NetWeaver BW system.

You can set up static text for translation so translated text displays when the
Flash model is viewed. To allow translation, you must designate the cells in
the spreadsheet that can be translated. When the model is published, the
content in the specified cells is available to SAP NetWeaver BW. Once
translation is set up, translated text, based on the SAP NetWeaver BW user
locale, is passed to the Xcelsius model at run-time. For more information
about the translation options, see the SAP NetWeaver BW documentation
located at help.sap.com.

Note:
Text translation is not available from Xcelsius.

1. Click SAP > Translation Settings.
2. If you are not connected to the SAP system, the "SAP Logon" dialog box

opens. Select the appropriate SAP system and enter your credentials.
Click OK.

Note:
If you are connected to a different SAP system than you want to publish
to, you must disconnect from the SAP network before continuing these
steps.

3. In the "Translation Settings" dialog box, select the Enable Support for
Translation option.

4. Below the Ranges list, click Add.
5. In the Name box, type a name for the range.
6. Beside the Range box, click the "Cell Selector" icon ( ) and select a

cell.
7. To translate multiple texts, Repeat steps 4 to 6 .
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8. To minimize the impact of translated words on the model design and
spacing, do one of the following:

Note:
This setting is not supported in SAP NetWeaver 7.0 Enhancement
package 01 SP 05. However, it is a good practice to set this option for
models, so they will work correctly once the option is supported by SAP
Netweaver and you won't need to republish them.

• To enter specific values, beside theMaximumNumber of Characters
box, click the "Manual Edit" icon ( ) and, on the Number of
Characters Settings dialog box, specify the maximum number of
characters allowed for each string.

• To select values from the embedded spreadsheet, beside the
Maximum Number of Characters box, click the Cell Selector icon
( ) and select the cells that will store the values for the maximum
number of characters.

9. Click OK.
Related Topics
• To publish Xcelsius models to SAP NetWeaver BW systems
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Exporting and Deploying Models

Adobe Flash Player Security Restrictions
models generated by Xcelsius 2008 are based on Adobe Flash technology
and are subject to its security protection rules.

The Adobe Flash Player 9 and later includes security restrictions that affect
SWF files that call content files stored on a local drive. If you want to run an
Xcelsius SWF file locally, you must add the file to the trusted locations in
Adobe Flash Player Settings Manager.

Adobe Flash Player also restricts access to external data sources. If your
SWF is hosted on a web server, any web server that your SWF file connects
to for live data must have a cross domain policy file in the web server root.

For more information about Adobe Flash Player security, see the following
documents on the Adobe website.

Note:
Flash Player documentation is version specific and does not address previous
versions. Users with Adobe Flash Player 9 will need to read both documents.

• Security changes in Flash Player 8
• Policy file changes in Flash Player 9 and Flash Player 10

Running Xcelsius SWF files locally

SWF files attempting to call content files (images, XML data, and so on),
using a URL file reference, can deliver the content only when the local drive
is listed as a trusted location in the Adobe Flash Player security settings. If
you create a snapshot or export to a local format, such as PPT, HTML PDF,
Word, or SWF, you may need to add the SWF file or the host application
(PowerPoint, Microsoft Word, and so on) to the trusted locations. Users need
to add the SWF or host application file to the Flash Player trusted locations
if they want to open an Xcelsius SWF file in the following applications:
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• A local HTML web page
• The standalone Flash Player
• A PDF (Acrobat 9 or later)
• A PowerPoint presentation
• A Microsoft Word document

To make a file trusted in Adobe Flash Player Settings
Manager

If you want to run a model locally, you must add the file location to the trusted
locations in the Adobe Flash Player Settings Manager.

1. To open the Adobe Flash Player Settings Manager, go to
http://www.macromedia.com/support/documentation/en/flashplay
er/help/settings_manager04.html

2. On the Adobe Flash Player Settings Manager page, in the "Table of
Contents", click Global Security Panel Settings.

3. Select the Always Allow option.
4. In the Always trust files in these locations list, select Add location.
5. Browse to the location of the SWF file (or container file such as

PowerPoint, HTML, and so on).

Running Xcelsius SWF files from a web server

If your model is hosted on a web server, any web server that the SWF file
connects to for live data must have a cross-domain policy file in the web
server root (differs for each web server). Without a cross domain policy file,
the SWF file may not be able to connect to the web server to retrieve data.

The Adobe Flash Player security restrictions do not allow a SWF file to access
data that resides outside the web domain from which the SWF originated. If
a SWF file attempts to connect to an external data source, Flash Player may
display a variety of messages. The most common message is Unable to
Load URL:
http://boe-server:8080/dswsbobje/services/session.
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A cross-domain policy file is a simple XML file that gives the Adobe Flash
Player permission to access data in a given domain without displaying a
security dialog box. The cross domain policy file on your web server controls
which SWF files, running on which domains, can access your web server.
When placed in a root folder of a server, it tells the Flash Player to allow
direct access to data on that server, without prompting the user to grant
access.

To create a cross-domain policy file

Adobe Flash Player security restrictions prevent SWF files from accessing
data across domains unless a cross-domain policy file gives permission. If
you plan to deploy your model on a web server and want it to access external
data sources, you must create a cross-domain policy file and place it in the
root folder of all the servers the file needs to access.

For more information about cross-domain policy files, see the Adobe website.

1. Download or create a crossdomain.xml file.
For example, the following cross-domain policy file allows any SWF,
running on any domain, to access the web server.

<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM

"http://www.macromedia.com/xml/dtds/cross-domain-
policy.dtd ">
<cross-domain-policy>
<allow-http-request-headers-from domain="*" headers="*"
secure="false" />
<allow-access-from domain="*" secure="false" />
</cross-domain-policy>

2. Place the cross-domain policy file in the root folder of all the servers the
model need to access.
For example, to allow access between different BusinessObjects
Enterprise servers, you would need to place the cross-domain policy file
in the associated Tomcat folders on each server, that is, Location:
C:\Program Files\Business Objects\Tomcat\webapps\ROOT
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FSCommand restrictions

The fscommand() function lets a SWF file communicate with a script in a
web page. However, the allowScriptAccess setting in the browser controls
access to scripts for the web page. If the allowScriptAccess setting is set to
"always", a SWF file can always access web page scripts. If it is set to
"sameDomain", the SWF file can only access scripts that are in the same
domain as the web page. In Adobe Flash Player 7 and earlier, if the
allowScriptAccess attribute is not specified for an HTML page, it is set by
default to "always", but, in Flash Player 8 or later, the attribute is set to
"sameDomain" by default.

Some uses of Adobe's FSCommand action are not supported in the Adobe
Flash Player 9. Although FSCommand can not be used to pass commands
to the Flash Player directly, it can be used communicate with the program
hosting the player or pass messages to Macromedia Director, Visual Basic,
Visual C++, and other programs that can host ActiveX controls.

The six predefined FSCommand commands that are used to manipulate SWF
files within the Flash Player do not currently function. This is a known issue
to be resolved by Adobe. Xcelsius 2008 supports the use of the FSCommand
action to pass commands and parameters to a scripting language, such as
JavaScript, in a Web browser.

FSCommand can also be used to send messages to Macromedia Director or
Visual Basic events to programs that can host ActiveX controls. These uses
may be functional in Xcelsius 2008, however they are not officially supported.

For more information on this topic, please see the Adobe article at:
http://www.adobe.com/support/flash/action_scripts/actionscript_dictionary/ac
tionscript_dictionary372.html.

Flash Player Error Numbers and Messages

Once you export your model, it is saved as a SWF file and is subject to Adobe
Flash Player policies and restrictions. If the Flash Player encounters a
problem when running the model, it may display an error message or number.
Flash Player generates these messages.
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For more information about specific Adobe Flash Player error numbers and
messages, see the Adobe web site.

Exporting models
Once your model is complete, you can export it to the following formats:
• Flash
• Adobe AIR
• HTML
• Business Objects Platform
• Adobe PDF
• PowerPoint Slide
• Microsoft Outlook
• Microsoft Word

For all formats, the model is saved as a Flash SWF file and then inserted
into the selected program. As a SWF file, the model does not required
Xcelsius to run.

Note:
The SWF file created by Xcelsius includes an item in the SWF context menu
that appears when users right-click the open SWF file. The item identifies
Xcelsius and links to an SAP website. The information that appears in this
context menu is stored in the following text file: ....\Xcelsius\as
sets\RightClick.txt. To change the information, modify the
RightClick.txt file using the following format <menuItemName><URL>
where <menuItemName> is the name of the item in the context menu (for
example, About Xcelsius) and <URL> is the address for the website that
opens when users click the menu item. Re-export the SWF to apply the
changes.

To export models

You have created a model and it is open in your workspace. If you are
exporting to Adobe AIR, the Adobe Flex 3.0 SDK is installed on your system.
For more information, see To setup your system for Adobe AIR .
1. Click File > Export and then select one of the following options:
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DescriptionOption

Note:
This option is not available in Xcelsius Present.

Generates an Adobe Flash (SWF) file that can be
executed locally with the standalone Flash player,
opened in a browser, used as part of a web site,
or imported into a number of different programs.

Caution:
Any external files are saved in a folder in the folder
where the model is saved. For the model to work
properly, the external file folder must remain in the
same folder as the model.

Flash (SWF)

Exports the model to a browserless Runtime for
Rich Internet Applications (RIAs) format that can
be run on desktops across multiple operating
systems. Before you can export to Adobe AIR, you
must configure your system. For more information,
see To setup your system for Adobe AIR .

Note:
To run AIR files, you must install the AIR player
from the Adobe website.

AIR

HTML
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DescriptionOption

Note:
This option is not available in Xcelsius Present.

Embeds the Adobe Flash SWF model in an HTML file
to ensure users can view the model by opening one
file even if their computer is not configured to open
Flash files in the browser.

Caution:
When the model is exported, Xcelsius creates an
HTML file and an SWF file with the same name
and saves them in the selected directory. For the
model to work properly, these files must be in the
same folder.

Note:
This option is available in Xcelsius Enterprise only

Exports the model to either BusinessObjects En-
terprise or the Crystal Reports Server.

BusinessOb-
jects Plat-
form
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DescriptionOption

Generates a PDF file that can be viewed locally,
opened in a browser, or deployed on a web site.
The model is embedded in the PDF and is dynamic
and interactive.

Note:
You can save your PDF files to be compatible with
either Acrobat 6 (and later versions) or Acrobat 9.
Acrobat 9 requires users to have the latest version
of Acrobat Reader installed to view the model. In
the "Save As" dialog box, in the Save as Type list,
select the Acrobat version.

Caution:
Any external files are saved in a folder in the folder
where the model is saved. For the model to work
properly, the external file folder must remain in the
same folder as the model.

PDF
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DescriptionOption

Generates a PowerPoint (PPT) file and an SWF
file with the same name. The model is on the first
slide of the PowerPoint presentation. When the
presentation runs, the model is dynamic and inter-
active.

Caution:
Any external files are saved in a folder in the folder
where the model is saved. For the model to work
properly, the external file folder must remain in the
same folder as the model.

PowerPoint
Slide

Generates an SWF file and attaches it to a Microsoft
Outlook message, which you can then customize and
send.

Outlook

Generates a Microsoft Word document and embeds
an SWF of your model in the document. The model is
dynamic and interactive.

Note:
If, in Microsoft Word, the model is static, on the
Microsoft Word Control toolbar, click the Exit De-

sign Mode icon ( ).

Word

2. Do one of the following:
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DescriptionOption

Enter a name for the exported file
and click Save.

If you are exporting to Flash
(SWF), HTML, PDF, Power-
Point Slide, or Word

Enter a message and click Send to
send the message.

If you are exporting to Out-
look

In the "Log On to BusinessObjects
Enterprise" dialog box, enter the
following logon information. (If you
are unsure of your logon informa-
tion, contact your system adminis-
trator.)
• In the System field, type the

name of the Central Manage-
ment Console (CMC) that you
want to export the SWF file to.

• In the User name and Pass-
word fields, type your logon
credentials.

• In theAuthentication list, select
the authentication type.

If you are exporting to
Business Objects Platform

If you are exporting to AIR
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DescriptionOption

a. Set the following options:

Description
Op-
tion

Enter a name for the
application. The name
must be unique for each

Name

installation on the same
system. This name will
display on the installa-
tion screen. The default
value is the current
document name.

Enter a unique ID to
identify the application.
The ID must be unique

ID

for each installation on
the same system. The
default value is
“com.air.flash.DOCU
MENT_NAME” .

Enter a version number
for the application. The
default value is "1.0".

Ver-
sion

Enter the copyright infor-
mation, which will dis-
play on the installation

Copy-
right

screen when users in-
stall the application on
a Macintosh system.

Select a window style
from the following op-
tions:

Win-
dow
Style
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DescriptionOption

Description
Op-
tion

• System Chrome -
the window adopts
the style of windows
in the environment
where it is running.

• Custom Chrome
(Opaque) - the win-
dow has its own
unique look specific
to AIR and has a
solid background.

• Custom Chrome
(Transparent) - If
the canvas for the
model is set to
Transparent, when
you use this setting
the window has a
transparent back-
ground.

Select this option if you
want to set a custom
size for the window. The
set the size values in
the Width and Height
boxes.

Note:
When a custom size is
used, users cannot
change the size of the
window at run-time.

Win-
dow
Size:
Use
Cus-
tom
Size
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DescriptionOption

Description
Op-
tion

Appli-
ca-
tion
Icons
(PNG
only)

Select the image files
you want to use for the
application icons.

Note:
Adobe AIR only sup-
ports PNG files for appli-
cation icon images.

Enter the location where
Adobe will save the AIR
Application Installer.

Note:
If you have trouble ex-
porting your model, se-
lect Export with Tem-
porary Certificate.

Desti-
na-
tion

b. Click Export

To setup your system for Adobe AIR

If you want to export model content as an Adobe Integrated Runtime (AIR)
desktop application, you must install the Adobe Flex 3.0 SDK.

1. Download the Adobe Flex 3.0 SDK from the Adobe website.
2. Extract the files in the zipped Adobe Flex SDK file to the following path:

C:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.0
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Note:
If you want to change the location for the SDK file, after you install
Xcelsius, change the folder location in file Xcelsius’s Installation
Path\Xcelsius\assets\air\sdkPath.dat file.

3. Download and install the Java 2 Runtime Environment (J2RE 1.4 or
higher).

To run the exported AIR file, you will need to download and install the AIR
player from the Adobe website.
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More Information

LocationInformation Resource

http://www.sap.com
SAP BusinessObjects
product information

Select http://help.sap.com > SAP BusinessObjects.

You can access the most up-to-date documentation cov-
ering all SAP BusinessObjects products and their deploy-
ment at the SAP Help Portal. You can download PDF
versions or installable HTML libraries.

Certain guides are stored on the SAP Service Marketplace
and are not available from the SAP Help Portal. These
guides are listed on the Help Portal accompanied by a
link to the SAP Service Marketplace. Customers with a
maintenance agreement have an authorized user ID to
access this site. To obtain an ID, contact your customer
support representative.

SAP Help Portal
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LocationInformation Resource

http://service.sap.com/bosap-support > Documentation

• Installation guides: https://service.sap.com/bosap-
instguides

• Release notes: http://service.sap.com/re
leasenotes

The SAP Service Marketplace stores certain installation
guides, upgrade and migration guides, deployment guides,
release notes and Supported Platforms documents. Cus-
tomers with a maintenance agreement have an authorized
user ID to access this site. Contact your customer support
representative to obtain an ID. If you are redirected to the
SAP Service Marketplace from the SAP Help Portal, use
the menu in the navigation pane on the left to locate the
category containing the documentation you want to ac-
cess.

SAP Service Marketplace

https://boc.sdn.sap.com/

https://www.sdn.sap.com/irj/sdn/businessobjects-sdklibrary
Developer resources

https://www.sdn.sap.com/irj/boc/businessobjects-articles

These articles were formerly known as technical papers.

SAP BusinessObjects ar-
ticles on the SAP Commu-
nity Network

https://service.sap.com/notes

These notes were formerly known as Knowledge Base
articles.

Notes

https://www.sdn.sap.com/irj/scn/forums
Forums on the SAP
Community Network
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LocationInformation Resource

http://www.sap.com/services/education

From traditional classroom learning to targeted e-learning
seminars, we can offer a training package to suit your
learning needs and preferred learning style.

Training

http://service.sap.com/bosap-support

The SAP Support Portal contains information about Cus-
tomer Support programs and services. It also has links to
a wide range of technical information and downloads.
Customers with a maintenance agreement have an autho-
rized user ID to access this site. To obtain an ID, contact
your customer support representative.

Online customer support

http://www.sap.com/services/bysubject/businessobjectscon
sulting

Consultants can accompany you from the initial analysis
stage to the delivery of your deployment project. Expertise
is available in topics such as relational and multidimension
al databases, connectivity, database design tools, and
customized embedding technology.

Consulting
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calendar component 184
candlestick chart 48

appearance properties, setting 74
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setting up 55

canvas
about 25
aligning components 30
arranging components on 29
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components
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custom size 28
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locking components on 37
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scales, setting 68
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changing 251
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color settings
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Combo Box component (continued)
general properties, setting 113
setting up 112

components
aligning 30
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copying size 33
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spacing evenly on canvas 31
visibility 242
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copying between Excel and Xcelsius 262
external data source, adding 268
external sources, using 268
insertion type 130
synchronizing Excel and Xcelsius 261
variable amounts in charts 73
working with 257

data connections 290, 291, 295
connections

removing data 274
Crystal Reports data consumer 297
external interface 301
Flash variables 289
FSCommand 298
LCDS 299
Live Office 311, 312
LiveCycle Data Services (LCDS) 299
load and idle messages, creating 309
refresh data options 306
removing 274
SAP NetWeaver BW 332
XML data 285

data labels
about 89
configuring for charts 89

data manager
about 268

Data Manager 268
device fonts 19
dial component 146

alerts properties, setting 163
appearance properties, setting 157
behavior properties, setting 153
general properties, setting 149
setting up 148

divisions 64
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divisions, chart scales 68
document properties 18
documentation, about 10
DocumentDownload function 320
downloading 39
drilldown

configuring 91
drilldown properties

chart component 62
drilldown, configuring chart 91
dynamic visibility 64

entry effects 244
setting up 242

Dynamic Visibility
about 241
components

visibility, dynamic 241

E
ellipse component 206
ellipse components

configuring 214
embedded fonts 19
embedded spreadsheet

Excel data, copy and paste 262
synchronizing with Excel 261

embedded spreadsheets
understanding 257

enable animation 64
enable range slider 64
enable run time tools 64
enable sorting 64
entry effects 64
Excel 258

copy and paste data from 262
data

export to Excel 265
exporting data to 265
functions, supported 266
importing data from 261
synchronizing data with 261

Excel formula errors, ignoring 259
Excel XML maps

models, adding to 303
working with 303

Excel XML maps connections 268

export
models 351

external data connections
migrating to Xcelsius 2008 11

external files
embedding vs. referencing 213

external interface connections 268
external interface connections, configuring 301

F
file formats 9
Filter component 105

alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

Fish-Eye Picture Menu component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

Flash Player
cross-domain policy files 348, 349
FSCommand restrictions 350
security restrictions 347
trusted locations, adding 348

Flash Variable connections 268
Flash variables, configuring 289
fonts, using global 19
FS command connections 268
FSCommand

restrictions 350
FSCommand connections

configuring 298

G
gauge component 146

alerts properties, setting 163
appearance properties, setting 157
behavior properties, setting 153
general properties, setting 149
setting up 148
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general properties
chart component 56
container component 100
map component 166
other component 187
selector component 113
single value components 149
text component 174

globalization, about 343
grid

canvas
grid, displaying 26

displaying on canvas 26
grid component 184

alerts properties, setting 204
appearance properties, setting 199
behavior properties, setting 194
general properties, setting 187

group components 32

H
history component 184
horizontal line component 206
horizontal line components

configuring 216

I
Icon component 105

alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

idle messages, creating 309
ignore blank cells 64
image component 206

embedding or referencing external files 213
image components

configuring 209
import 13

data 261
InfoView

nesting SWFs in 320
opening SWF files 320
update web.config files 314

InfoView (continued)
update web.xml files 315

InfoView documents
launching from models 316

input text area component 172
appearance properties, setting 182
behavior properties, setting 176
general properties, setting 174
setting up 173

input text component 172
appearance properties, setting 182
behavior properties, setting 176
general properties, setting 174
setting up 173

insertion types, selectors 130
installing 40
interactive calendar

alerts properties, setting 204
appearance properties, setting 199
behavior properties, setting 194
general properties, setting 187

L
Label Based Menu component 105

alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

label component 172
appearance properties, setting 182
behavior properties, setting 176
general properties, setting 174
setting up 173

layout
chart settings 74

LCDS connections 268
LCDS Connections, configuring 299
legends

about 87
adding to charts 87

line chart 48
appearance properties, setting 74
behavior properties, setting 64
drilldown properties, setting 62
general properties, setting 56
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line chart (continued)
setting up 55

line components
configuring 216

linear scales, setting for charts 68
List Box component 105

alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

List Builder component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

List View component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

Live Office
data connections 311, 312
parameters, passing to 313

Live Office compatibility mode
setting 259

Live Office connections 268
LiveCycle Data Services (LCDS) connections,

configuring 299
LiveOffice Connector

updating web service setting 314
load messages, creating 309
local scenario button component

alerts properties, setting 204
appearance properties, setting 199
behavior properties, setting 194
general properties, setting 187

local scenario buttons component 184
logarithmic scales, setting for charts 68

M
map components

alerts properties 171
appearance properties 169

map components (continued)
as display component 164
as selector components 164
behavior properties 168
general properties 166
how they work 164
setting up 165

messages, creating load and idle 309
Microsoft Excel

best practices 258
models 247, 345

changing color schemes 251
custom color schemes 252
exporting 351
exporting to SAP BusinessObjects

Enterprise 328
globalization 343
launching InfoView documents 316
preview with SAP NetWeaver BW data 341
previewing 253
publishing to SAP NetWeaver BW 340
running locally 347
sample models

viewing 11
samples, viewing 10, 11
SAP Business Objects Enterprise, opening

from 327
saving to SAP BusinessObjects Enterprise

327
security issues 348
templates, using 248
themes, applying 250
translating 343, 345
using color schemes 250
using themes in 250
web server, running from 348, 349

O
Object browser

hiding components 35
properties panel, opening from 36
selecting components 34

Object Browser 34
components

deleting 235
context menu 39
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Object Browser (continued)
deleting components with 235
grouping components in 37
renaming components in 37

OHLC chart 48
appearance properties, setting 74
behavior properties, setting 64
drilldown properties, setting 62
general properties, setting 56
setting up 55

OpenDocument, using 316
other components 184

alerts properties 204
appearance properties 199
behavior properties 194
general properties 187

P
panel containers 97

appearance properties, setting 103
behavior properties, setting 101
general properties, setting 100
setting up 99

panel set
alerts properties, setting 204
appearance properties, setting 199
behavior properties, setting 194
general properties, setting 187

panel set component 184
parameters, passing to Live Office 313
pie chart 48

appearance properties, setting 74
behavior properties, setting 64
drilldown properties, setting 62
general properties, setting 56
setting up 55

play button component 146
alerts properties, setting 163
general properties, setting 149
setting up 148

play control component
appearance properties, setting 157
behavior properties, setting 153

Play Selector component 105
alerts properties, setting 145
appearance properties, setting 131

Play Selector component (continued)
behavior properties, setting 121
general properties, setting 113
setting up 112

portal data 290, 291, 295
portal data connections

adding 291, 295
Portal data connections 268
portal data connections, configuring 290
preview models 253
print button component 184
progress bar 146
progress bar component

alerts properties, setting 163
appearance properties, setting 157
behavior properties, setting 153
general properties, setting 149
setting up 148

properties
setting for multiple components 44
single value components 153

properties panel
opening 36

Properties panel 43
Push Button component 105

alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

Q
QaaWs connections 268
QaaWS connections

configuring 274
migrating to Xcelsius 2008 11

R
radar chart 48

appearance properties, setting 74
behavior properties, setting 64
drilldown properties, setting 62
general properties, setting 56
setting up 55
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Radio Button component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

range slider
about 71
configuring 72

rectangle component 206
rectangle components

configuring 214
Refresh Button component

appearance properties, setting 231
behavior properties, setting 227
general properties, setting 220

refresh data 306
removing 40
renaming components, with Object Browser 37
Reporting Services Button component 217
Reporting Services component

appearance properties, setting 231
behavior properties, setting 227
general properties, setting 220

reset button component 184
restricting in text components 179
run-time tools 94

charts
run-time tools 97

displaying 97

S
sample models

viewing 10
SAP BusinessObjects Enterprise

exporting SWF files to 328
integrating with 311
opening files from 327
saving files to 327
storing models in 326

SAP NetWeaver BW
disconnecting from 331
globalization 343
opening XLF from 342
publishing to 340
requirements for connecting to 330

SAP NetWeaver BW (continued)
translation 343, 345

SAP NetWeaver BW connections
configuring 332
preview model 341

SAP NetWeaver BW Integration
about 329

SAP NetWeaver BW systems
connecting to 331

scale 64
scale, adjusting chart at run-time 94
scales

about chart 67
setting chart 68

Scorecard component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

selector components 105
alerts properties 145
appearance properties 131
behavior properties 121
general properties 113
multiple insertions 119, 120
setting up 112

selectors
insertion types 130

SharePoint
connections, configuring for 290, 291, 295

single value components 146, 148
alerts properties 163
appearance properties 157
behavior properties 153
General view properties 149
setting up 148

size settings
copying between components 33

skins. See themes 250
Slide Show component 217

appearance properties, setting 231
behavior properties setting 227
general properties, setting 220

Slide Show components
opening SWFs in 320
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slider component 146
alerts properties, setting 163
appearance properties, setting 157
behavior properties, setting 153
general properties, setting 149
setting up 148

Sliding Picture Menu component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

snapshots, taking of models
models

snapshots, taking 254
sparkline chart 48

appearance properties, setting 74
behavior properties, setting 64
drilldown properties, setting 62
general properties, setting 56
setting up 55

spinner component 146
alerts properties, setting 163
appearance properties, setting 157
behavior properties, setting 153
general properties, setting 149
setting up 148

spreadsheet
binding components to 264
formula errors, ignoring 259
optimizing 259
preferences 259
rows, maximum allowed 259
XML, enabling in 305

Spreadsheet Table component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

spreadsheets
embedded, about 257
functions, supported Excel 266
importing data 261
regional format settings 257

stacked charts, types 48
styles. See color schemes 250

SWF
context menu, modifying 351

SWF files 9
data source

external, using for SWF file 265
external data source for 265
Flash Player security and 347
security restrictions 347

SWF Loader
appearance properties, setting 231
behavior properties, setting 227
general properties, setting 220

SWF Loader component 217

T
tab set containers 97

appearance properties, setting 103
behavior properties, setting 101
general properties, setting 100
setting up 99

templates
about 248
creating 249
opening 248

text components 172
appearance properties 182
behavior properties 176
general properties 174
restricting characters 179
setting up 173

text formatting
charts 74

themes
applying 250
using 250

Ticker component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
setting up 112

Toggle Button component 105
alerts properties, setting 145
appearance properties, setting 131
behavior properties, setting 121
general properties, setting 113
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Toggle Button component (continued)
setting up 112

toolbars 15
toolbars in

spreadsheets 257
tools

Object Browser 34
transparent canvas 25
trend analyzer component 184
trend analyzer components

configuring 204
trend icon

alerts properties, setting 204
appearance properties, setting 199
behavior properties, setting 194
general properties, setting 187

trend icon component 184

U
URL Button component

appearance properties, setting 231
behavior properties, setting 227
general properties, setting 220

URL link button 217
user input, disabling 245

V
value component 146

alerts properties, setting 163
appearance properties, setting 157
behavior properties, setting 153
general properties, setting 149
setting up 148

versions, importing previous 11
vertical line component 206
vertical line components

configuring 216
visibility, setting dynamic 242
visualizations

export previews 254
previews

export 254

W
web connectivity components 217

appearance properties 231
general properties, setting 220
setting up 219

Web Connectivity components
behavior properties 227

web service connections
configuring 281

Web Service connections 268
Web Services connections

migrating to Xcelsius 2008 11
Web Sphere

connections, configuring fo 290
connections, configuring for 291, 295

web.config files, update for .NET InfoView 314
web.xml files, update for Java InfoView 315
WMODE 25
workspace, understanding 15

X
Xcelsius 2008

About 7
compatibility with previous versions 11
documentation 10
editions 7
previous versions, importing 13

Xcelsius 4.5 files 13
XLF files 9

opening from SAP NetWeaver BW 342
Xcelsius 3.0/3.5, import 11

XML
Excel 2003, enabling in 305
Excel 2007, enabling in 306
spreadsheet, enabling in 305

XML Data Button component 217
XML data connections 268
XML data connections, configuring 285
XML maps

models, adding to 303
working with 303

XY chart 48
appearance properties, setting 74
behavior properties, setting 64
drilldown properties, setting 62
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XY chart (continued)
general properties, setting 56

XY chart (continued)
setting up 55
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